[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Enabling Integrated windows authentication gives "The page cannot be found"

Posted on 2004-11-18
11
Medium Priority
?
681 Views
Last Modified: 2010-08-05
hello experts,

my system: WinXP sp2, IIS 5.1

i've got cognos (reporting tool), it supports Integrated Windows Authentication (IWA). When i enable anonymous access and IWA on my IIS, it still asks me for login and pass.
when i disable anonymous login, it gives me an error "The page cannot be found" instead of auto-logging in or prompting for login/pass.
few days ago everything was working fine. I did not messed with configuration, i just noticed today that it stopped working. any ideas?
0
Comment
Question by:tigrine_smiltpele
9 Comments
 
LVL 15

Expert Comment

by:OMC2000
ID: 12615324
It reads data from some windows folders,  where you probably changes access rights.
Most likely there were permissions for anomynous user to access these folders and now there are no such permissions.
0
 

Author Comment

by:tigrine_smiltpele
ID: 12617941
i don't think this is the case - i always log in as administrator.
0
 
LVL 6

Expert Comment

by:sstouk
ID: 12618549
Even if you enable Anonymous access to your Web Site, it still means that the Web Site accesses the NTFS Directories with IUSR_YOURPCNAME account.
Starting from Windows XP and Windows 2003 this account is no longer a part of the "Everyone" group.
It means that even if you have "Everyone" read permissions on the NTFS directory, it does not mean that Anonymous Web account can access the path, hence it asks for a correct User/Password to be able to access it.

If you enable Anonymous - Make sure you specifically open NTFS rights for the Virtual Root Directory on the Drive.

When you disable Anonymous, please make sure you do not have proxy settings in your Web Browser, otherwise your account will not be authenticated.

When it tells "page not found", it means that you successfully passed through the first step of authentication and now have to configure the MIME extention or a Default Document to be Served by the IIS properly.

This reporting tool (cognos), what language is it written on?
Did you configure to allow "Execute" on the web folder and not just "read/script" permissions?
Did you configure default document to be displayed properly under the Documents Tab of the virtual path configuration?
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
LVL 6

Expert Comment

by:sstouk
ID: 12618592
One other reason that I might think of is if you hardened the IIS 5.1 server with the Lockdown Web tool.
It blocks the scripting (if it was requested) executables and practically all the MIME extentions.
If you did execute the lockdown tool and hardened the Web Server, then you will need to manually allow asp,pl,php or whatever language this reporting tool is written on, to execute.
0
 

Author Comment

by:tigrine_smiltpele
ID: 12623775
it looks like i found the cause - when i login to my computer via remote desktop connection and try to open browser on the same PC, it gives me this error, but when i open same page from other computers directy (via browser) it authenticates successfully.
0
 
LVL 6

Expert Comment

by:sstouk
ID: 12625419
The IIS Server might be behind the NAT?
There might be the browser connection configuration as well on the one that it locally to the web server.
0
 

Author Comment

by:tigrine_smiltpele
ID: 12638231
i doubt that it's behind the NAT. both browsers are configured the same (default config). when i get to work tomorrow, i'll try connect directly (not via remote desktop) and see what will happen
0
 

Author Comment

by:tigrine_smiltpele
ID: 13289516
i've found a solution - restarting pc. from time to time this problem appears again, then i simply restart

i would like to close this question
0
 

Accepted Solution

by:
OzzMod earned 0 total points
ID: 13413254
Closed, 250 points refunded.
OzzMod
Community Support Moderator (Graveyard shift)
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…
Suggested Courses

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question