Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Using "Add a Network Place" wizard to add an Internet site

Posted on 2004-11-18
22
Medium Priority
?
493 Views
Last Modified: 2008-01-09
If I try to add an Internet site using the "Add a Network Place" wizard I get the message "The folder does not appear to be valid. Please choose another."  Other my other computers get the standard username and password access box.

I discovered this trying to add my websites in Frontpage 2003.  There I get the error: "The folder 'http://www.websiteaddress/' isn't accessible. The folder may be located in an unavailable location, protected with a password, or the filename contains a / or \."  I am able to edit and access the site if I click on Edit in Frontpage in IE.

This is a new install of Windows XP (sp2), Office 2003, and Frontpage 2003.  I've tried again after disabling the firewall and nothing was different.

Am I just missing an obvious setting or service somewhere?
0
Comment
Question by:AgTerra
  • 10
  • 10
  • +1
22 Comments
 

Expert Comment

by:Sebuturn
ID: 12616195
Maybe I misunderstood something, but basically a web site isn't a network place ... so there's no way to add it as a network place.

Now, you may want to Download the whole website and access it directly on your computer ... it exist several programs who can do that.

Hope this helps

0
 

Expert Comment

by:ib1netmon
ID: 12616271
TYhe Network Places folder is not the place to bookmark an internet site. Network Places are file shares available to your PC, but internet sites are Web servers, FTP servers, etc, NOT file shares, which use a completely different rotocol and security methods.

You can bookmark an Internet site by addint it to your Favorites in Internet Explorer (Click Favorites, then add to Favorites), or you cn create a shortcut to any site you wish on your desktop or in almost any folder EXCEPT the 'Network Places' folder, which is not a regular folder (Most 'folders' are directories on ypuir hard drive, 'Network Places' is not).

To put a shortcut to a site on your desktop or a folder, highlight the URL in the toolbar (example URL: www.yahoo.com)., then either right click and choose 'Copy', OR hit the keys control(hold it down)-C (a keyboard shortcut to Copy)
.
Then on the desktop or in a folder window, right click and choose 'New', then 'Shortcut'. The box that pops up will have a field that says "type the location of the item:" Right click in that fielld and choose 'Paste' OR  left cick in that field and press Control-V (a keyboard shortcut to Paste). The URL should appear in that field. Then click 'Next', give your new shortcut a name in the nect box , and then click 'finish. Voila, you now have a shortcut to that page in the l;ocation of your choice - as long as it is NOT 'Network Places'.

0
 

Author Comment

by:AgTerra
ID: 12616406
One is normally able to add an FTP site or web site as a network place that then becomes quickly accessible in My Network Places.  It is even normal to map a network drive to a network place that accesses a web site or FTP site.  (after entering username and password of course).

I've done this on my other computers routinely, but something is different in the way I set this one up.  Again, I've check all the firewall settings, services and other settings I can think of,

Still at a loss.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Expert Comment

by:ib1netmon
ID: 12616495
Network Places is a special folder where you can put locations that give you access to the FILES at that location. A regularweb site does not give you access to the files using a 'file access method' - it lets you retrieve web pages via HTTP - a different mechanism.

If you want to look at a web page that you see on the net using FrontPage, use the "Save as' option, save the page (as a 'complete" page) to your hard drive, and then load it into FrontPage from there. Is that what you wanted to do?
 
0
 

Author Comment

by:AgTerra
ID: 12616895
I was afraid my question would not be understood the way I had hoped.  Thanks to everyone for their replies.  The fact I'm trying to connect to a web site or FTP site is so that I can get access to the files at that location.  But here's the deal.  I can access my web site in FrontPage, even edit any page I like.  However, if I try to add a hyperlink, it does not automatically go to the website to find that hyperlink, instead it opens up a dialog box defaulting to the desktop, but asking me where the hyperlink is at.  In the past, I could select Network Places, go to my web site and tap on the file I wanted to link to.  Right now, I have to hard code that in which is difficult when trying to maintain relative links with a detailed directory structure.

So I am not trying to create a link to a favorite site, but trying to make my web site a recognized network location so that Frontpage works properly.  Once again, this is all working properly on my other computers- so I know it is possible.

Thanks again for your help.
0
 

Expert Comment

by:ib1netmon
ID: 12617664
OK. I got it. Sounds like you have a permissioning issue. Is your username & PW on that PC the same as on the others? Are you working in a windows domain environment? Where are the web site files actually residing, on your file server or on a service provider's system?


 
0
 
LVL 25

Expert Comment

by:mikeleebrla
ID: 12617795
i think you are misunderstanding what you can access through my network places. You can only access FTP or Web shared resources. The above posts are correct, you cannot access a website through my network places, you can however access a shared place on a web server, which is probably what you are trying to do.  If you are doing this over a WAN then you probably are doing this with what MS calls "web sharing" which is actually webdav, it isn't used very much since it is so insecure and is plagued with problems.  You can use it do access a www site if it was set up correctly and you were trying to access it correctly. what would have to happen is this.... the files where the www files on the www server would have to be shared, and then "web sharing" would have to be enabled. then you would go to my network places and go to http://www.dnsname.com/sharename/ .  It would never work is you were only trying to go to http://www.dnsname.com/ as you didnt specify the sharename.  Again, this would only work if you have "web sharing" enabled on the www server.  

you can only edit the www files through ftp or a share with my network places... the above posts are correct.
0
 

Author Comment

by:AgTerra
ID: 12618296
In response to ib1netmon, the web site files reside on our server which is colocated with our service provider and our other web site reside directly on their servers.  It is my understanding, like mikeleebrla pointed out, that webdav or IIS must be running on the server to tap into it the way I am trying to with Network Places.   The other computers that successfully allow me to connect to them in My Network Places do let me see our web sites that have IIS running on them.  One of our websites does not have these services operating and I cannot tap into it via My Network Places on any machines, but that's okay.

All I know for sure is that my other desktops with Windows 2000 and Frontpage 2002 perform the operation of connecting to these web servers just fine after I enter the requested username and password to access the site and map it as a shortcut in My Network Places.

I hope some of this is making sense.  Thanks to everyone for your responses.
0
 

Expert Comment

by:ib1netmon
ID: 12618565
Mikeleebrla's input is appreciated.

Check the network properties of your network card on that PC to be sure that File & printer sharing is installed along with the other protocols such as TCPIP (almost certainly is, but let's be sure).
0
 

Author Comment

by:AgTerra
ID: 12626949
Sorry about the delay getting back. Per Mikeleebrla's request I've made sure that the File and Print Sharing is installed along with other protocols.  I've also got another programmer in my business checking his machine to try and replicate.  He has installed SP2 and FP2003, but so far cannot replicate te error.  When he calls the website, he gets the expected enter your username and password request box.

I swear I must be the only one in the world with this issue.  It must be an administration setting or something simple.  Is there anything regarding FTP access protocols I should be aware of out there?
0
 

Expert Comment

by:ib1netmon
ID: 12627980
You probably the only one in the world with this issue, my experience is that Windows has an infinite number of ways to screw up, and many are unique, or almost so.

Next place to go is your browser settings.

Control panel, Internet settings. I suggest that you set the Internet zone settings to default level.  Per your statements earlier, your web site should be in the Internet Zone, not the Local Intranet Zone.

On the Privacy tab, check the setting for the Internet zone. It should probably be on medium.

If you do not want to set all the security settings back to default, , on the advanced tab,

Under Browser, set the
Enable Folder view for FTP sites.
Use passive FTP option

Under Security,set

Enable Integrated Windows Authentication


Next, check this:
fire up REGEDIT (hope you know how - probably, right?)
HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\WebClient\Parameters\UseBasicAuth (DWORD)

if it is zero, change it to 1. Reboot. Then try it.




.
0
 

Author Comment

by:AgTerra
ID: 12628472
This is becoming mind-numbing.  I've restored all Internet settings that ib1netmon recommended to default and reset my privacy to medium.  That had been high.  Also Enable Folder View for FTP sites was not checked.  However, it is checked now and everything else is defaulted.  Still no luck.

I went to regedit and did not find UseBasicAuth under Parameters.  It simply isn't listed.

ib1netmon is right that I've probably found an unique way to screw up.
0
 

Expert Comment

by:ib1netmon
ID: 12628614
That last one is almost certainly your problem then.

Add the key (make sure you add a DWORD value) & set it to a non-zero value. That should straighten you out.

see this for the details.:


http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2netwk.mspx#EFAA

That should do it.


0
 

Author Comment

by:AgTerra
ID: 12629198
ib1netmon's suggestion did not work.  I've added the UseBasicAuth to the registry under the following folder:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\WebClient\Parameters\

Under "Name" I have:  UseBasicAuth
"Type" is:  REG_DWORD
"Data" is: 0x00000001 (1)

I then rebooted and tried again.  

It is curious this key was missing though.  I'd didn't delete it intentionally.
0
 

Expert Comment

by:ib1netmon
ID: 12629400
It was missing because SP2 takes it out purposely as a security enhancement.

The next SP2 thing to check is:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows \CurrentVersion\ Internet Settings\DisableBasicOverClearChannel (DWORD)

If it is there, and has a non-zero value, set it to 0 or delete it (I recomend setting to 0).
0
 

Author Comment

by:AgTerra
ID: 12629936
I created the DisableBasicOverClearChannel (DWORD) key.  Everything is still the same.
0
 

Expert Comment

by:ib1netmon
ID: 12630020
ARRGH! Typical windows behavior. Why is it always the LAST thing you try that fixes the problem? (joke)

At the moment I am out of ideas, but not resources.
I'll see if I can find anything else that would apply to your problem.

Did you reboot after changing that key? (I'm not sure that you have to).

0
 

Author Comment

by:AgTerra
ID: 12630051
I did reboot.  I guess you see my frustration.  This one has everyone I know puzzled with nobody able to replicate it.  I know that's the worst kind of problem.

Thank you ib1netmon for all of your help.
0
 

Accepted Solution

by:
ib1netmon earned 900 total points
ID: 12630474
Hey, I haven't helped yet. But thanks for the appreciation.

One more thing.

Back to (control Panel) Internet Options, Security tab,  Internet Zone, hit Custom level, and look down near the bottom -

User Authentication - it should be something other than 'Anonymous'. "auto only in intranet' or 'prompt'. would be good.

I'll keep looking.

0
 

Author Comment

by:AgTerra
ID: 12630539
Automatic logon only on Intranet zone is where it is set now.
0
 

Author Comment

by:AgTerra
ID: 12634013
The issue is now fixed, although technically I don't know how.  Everything is working properly after excuting a Fix and Repair in FrontPage 2003.  There must have been something not installed correctly with this version after I freshly installed it on top of the new install of XP SP2.  I would have done this sooner, but honestly everything, except the inability to hyperlink properly, seemed to be working correctly.  I thought the problem had to be outside of FrontPage and related to the inability to set up an Internet address in a network place properly.  I will award ib1netmon the points for his/hers persistance in helping on the issue.
0
 

Expert Comment

by:ib1netmon
ID: 12634357
Hey, thanks. Glad you got it straightened out, I was going to suggest reinstalling IE. My guess is that the problem really was NOT in FP, I am sure it was a windows authentication system issue, but reinstalling FP set those windows parameters (whatever they were) correctly.

For future reference, Advanced Registry Tracer is a great tool for finding out what changed in the registry b4 and after, it takes snapshots of your registry & then will generate lists of what items were added,, deleted & changed. Very handy.

It was nice working with you and I am glad YOU fixed the problem.

ib1netmon.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

LinkedIn blogging is great for networking, building up an audience, and expanding your influence as well. However, if you want to achieve these results, you need to work really hard to make your post worth liking and sharing. Here are 4 tips that ca…
If you try to migrate from Elastix to Issabel, you will face a lot of issues. These problems are inevitable but fortunately, you can fix them. In the guide below, I will explain how I performed the migration while keeping all data and successfully t…
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question