PIX 506E, v6.3.3, Port Redirect?

Posted on 2004-11-18
Last Modified: 2013-11-16
Am trying to allow users on the Internet access to a Web based mail server using HTTP & HTTPS.
So far have been unable to access the internal server that is hosting the Web site.
Have one external IP address at my disposal! Can acquire additional IP addresses, if need be.
Below is my config for the PIX. Have using the PDM to configure the firewall and thus far Am not impresed with the interface or the help files. =P Would use the CLI, but Am intimidated by it.
Any assistance would be appreciated!

Thank you,


Building configuration...
: Saved
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password wj4iBMlDvNpAxwiv encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname Anne
clock timezone MST -7
fixup protocol dns maximum-length 1500
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
name First
name Second
name SpookyLabs
name VAB
name DeadWood
name SpookyLabs2
object-group service HTTP tcp
  port-object eq www
  port-object eq https
access-list 101 permit ip any
access-list 201 permit tcp SpookyLabs interface outside eq smtp log
access-list 201 permit tcp any interface outside eq www log
access-list outside_cryptomap_dyn_30 permit ip any
access-list acl_out permit tcp SpookyLabs interface outside eq smtp log
access-list acl_out permit tcp host SpookyLabs2 interface outside eq smtp log
access-list acl_out permit tcp any interface outside object-group HTTP log
access-list acl_out deny tcp any interface outside eq smtp log
access-list inside_access_in permit ip any any log
access-list inside_access_in permit tcp host Second SpookyLabs eq smtp log
access-list inside_access_in permit tcp host Second host SpookyLabs2 eq smtp log
access-list inside_access_in deny tcp any eq smtp any log
pager lines 24
logging on
logging timestamp
logging buffered debugging
logging trap notifications
logging facility 16
logging queue 0
logging host inside
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside 66.*.*.147
ip address inside
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool
pdm location First inside
pdm location Second inside
pdm location SpookyLabs outside
pdm location DeadWood outside
pdm location VAB outside
pdm location inside
pdm location SpookyLabs2 outside
pdm location 66.*.*.144 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0 0
static (inside,outside) tcp interface smtp Second smtp netmask 0 0
static (inside,outside) tcp interface www Second www netmask 0 0
access-group acl_out in interface outside
access-group inside_access_in in interface inside
route outside 66.*.*.145 1
route outside SpookyLabs 66.*.*.145 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:05:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set STRONGBAD esp-3des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set STRONGBAD
crypto dynamic-map dynmap 30 match address outside_cryptomap_dyn_30
crypto dynamic-map dynmap 30 set transform-set STRONGBAD
crypto map EATS 10 ipsec-isakmp dynamic dynmap
crypto map EATS interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh outside
ssh timeout 30
console timeout 0
terminal width 80
banner motd Welcome to the Inner Sanctum.
: end
Question by:keatscon

    Author Comment

    Okay, is it even possible to enable HTTPS to pass through a PIX, from the outside -> in?
    I can find nothing on it in the "PIX Firewall Command Reference" nor in the "PIX Firewall and VPN Configuration Guide".


    LVL 79

    Accepted Solution

    If you want to redirect the interface IP port 443 to an inside host, you must create the port static:

       static (inside,outside) tcp interface https Second https netmask 0 0

    And you must disable the internal http server because it only listens on port 443. You  cannot disable it by interface, and you will lose all ability to manage via the web gui.
       no http server enable

    Then, you need to add acl permissions for inbound traffic to it:
       access-list inside_access_in permit tcp any interface outside eq https


    Author Comment


         Thank you for the incantations, they worked!

         It looks like I will have to dig up a book on CLI Wizardy to learn the "command line".



    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    There are many useful and sometimes not well documented or forgotten IOS or ASA/PIX commands. See IPE article here , there was also one on PacketU and on Cisco Tips & Tricks. Below are my favorites. I give also a few most often used for Cisco IPS an…
    This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
    how to add IIS SMTP to handle application/Scanner relays into office 365.
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    729 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now