Linux-Windows PPP Connection doesn't work

I want to set up a Linux-Windows2000 PPP connection (Linux is Debian 2.4.27 Sarge "testing" of Oct 15 2004).
Both PCs are connected via a crossed serial cable that was veryfied with having "getty" on Linux and a Terminal emulation on Windows. During test of the PPP connection only the SW described below accesses the serial line.

On Linux:
pppd nodetach crtscts local lock noauth connect 'chat -v -f /etc/ppp/scripts/winclient.chat' 192.168.1.1:192.168.1.2 /dev/ttyS0 38400 debug

/etc/ppp/scripts/winclient.chat:
TIMEOUT 3600
CLIENT CLIENTSERVER\c


On Windows:
Using a "Network and Dial-up Connections" entry set up to "communications cable between two computers (COM1) with the same baud rate as given with the pppd call on Linux.
Network type is set to PPP.

Now what happens:
The connection can't be established fully.
I get a pppd debug output of
---------------8<--------------------------------
Serial connection established.
using channel 6
Using interface ppp0
Connect: ppp0 <--> /dev/ttyS0
rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <magic 0x67865974> <pcomp> <accomp> <callback CBCP> <mrru 1614> <endpoint [local:ab.dd.db.35.1c.88.48.65.b4.e4.58.ea.e2.99.eb.cf.00.00.00.00]>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9b9a12cb> <pcomp> <accomp>]
sent [LCP ConfRej id=0x0 <callback CBCP> <mrru 1614>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9b9a12cb> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9b9a12cb> <pcomp> <accomp>
...
LCP: timeout sending Config-Requests
Connection terminated.
---------------8<--------------------------------

-> The Windows PC doesn't seem to answer anymore.

Different baud rates and HW/SW handshake varieties tried. The cable is verified to have RTS-CTS connected in both directions.

What am I doing wrong ?
AlfredHAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeahcimLCommented:
Check the security settings on the windows box. Set password to not encrypted (pap) and the line to not be encrypted and add a username and password to the /etc/ppp/pap-secrets
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AlfredHAuthor Commented:
We found the solution ourselves.
The problem was that Windows (in contrast to Linux) assumes the PC's DSR/DCD line to be connected to the peer's DTR line even when you supply a direct PC-PC connection without a modem being in-between.
So after soldering this non-standard cable and additionally supplying the parameter "modem" on the Linux pppd call to let the Linux computer drive the DTR line, it instantly worked.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.