[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 416
  • Last Modified:

LINUX Server to get Internet on Mixed LAN

My  DSL modem is connected to a Netgear Router/Switch "A".  A cable from that switch connects to another switch, Switch "B". Another cable connects from Switch "B" to th Uplink ofa Linksys Router/Switch. Two short cables connect to two NIC's  Dell Server running under RedHat 9. The other switches connect in other rooms to Windows PC's. They have connectivity to the internet. The Linux box cannot connect.

What should I correct in my configuration to solve this problem?
0
xdale
Asked:
xdale
  • 26
  • 21
1 Solution
 
wesly_chenCommented:
> t wo short cables connect to two NIC's  Dell Server running under RedHat 9.
> The Linux box cannot connect.
What's your network configuration of your RH9 box?
Do
# ifconfig -a
# netstat -rn
# cat /etc/resolv.conf
# cat nsswitch.conf
amd post the output. So people can have more understanding your setting.

Regards,

Wesly
0
 
xdaleAuthor Commented:
These are the details:
cat  nsswitch.conf
cat: nsswitch.conf:  No such file or directory


cat /etc/resolv.conf
nameserver  192.168.1.1


Netstat –rn
Kernel IP routing table
Destination        Gateway     Genmask           Flags    MSS   Window  irtt   Iface
192. 168.0.0       0.0.0.0        255.255.255.0   U         0          0              0    eth0
169. 254.0.0       0.0.0.0        255.255.0    .0   U         0          0              0    eth0
127. 168.0.0       0.0.0.0        255.0. 0.0    .0   U         0          0              0    eth0





Last Login: Thu Nov 18 15:38:52 on tty1
DLL-installd Rd Hat Linux Sun Sp 28 23:47:11  CDT 2003
You hav nw mail.
[root@Riverdalserver root]# ifconfig –a
eth0      Link ncap:Ethernet  HWaddr 00:c0:9F:27:4:C3
inet addr:192.168.0.217  Bcast:192.168.0.255  Mask:255.255.255.0
UP BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:116 errors:0 dropped:0 overruns:0 frame:0
TX packets:116 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:7804 (7.6 Kb)  TX bytes:9581 (9.3 Kb)
Interrupt:10 Base  address:0xecc0  Memory:fe100000-fe120000

Lo      Link encap:Local Loopback
      Inet addr:127.0.0.1  Mask:255.0.0.0
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
RX packets:14371 errors:0 dropped:0 overruns:0 frame:0
TX packets:14371 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes: 1055098 (1.0 Mb)  TX bytes:1055098 (1.0 Mb)


 
0
 
wesly_chenCommented:

>Netstat –rn
> Kernel IP routing table
> Destination        Gateway     Genmask           Flags    MSS   Window  irtt   Iface
> 192. 168.0.0       0.0.0.0        255.255.255.0   U         0          0              0    eth0
> 169. 254.0.0       0.0.0.0        255.255.0    .0   U         0          0              0    eth0
> 127. 168.0.0       0.0.0.0        255.0. 0.0    .0   U         0          0              0    eth0

> Netgear Router/Switch "A".  

Your Linux box is missing "default gateway". Login as "root" then do
# route add default gw <IP of the netgear router>
Then you should be able to connect to internet.

By the way, make sure in /etc/nsswitch.conf you have a line like:
------
hosts:   files dns      <==== need "dns"
-----

Wesly
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
xdaleAuthor Commented:
I did as you instructed.
But now I get a message "Network is unreachable"

So I connected a cat-5 from the modem to the Router. From the switch to the Linux box NIC #1 and another cable from the switch to the Linux box NIC #2

Same message

And yet, the other PC's connected to the same switch have internet access.
0
 
wesly_chenCommented:
> the switch to the Linux box NIC #1 and another cable from the switch to the Linux box NIC #2
From the result of "ifconfig -a", I only see one NIC is up (eth0 with MAC address 00:c0:9F:27:4:C3).
Could you take out one cable (say NIC #2) and ping router's ip? If cannot ping, then change NIC #1.

Besides, could you post the output of "ipconfig /all" on your Windows PC?

Wesly
0
 
xdaleAuthor Commented:
okay:
Wesly, it seems as if you have remote access to my system. If not do you need vnc with a no-ip address?

Anyway, here are more details:I unplugged one of the NIC's. I tried to ping without success.

The other PC has the following config:
Windows IP configuration
Host Name                                          XDALE
Primary dns suffix                                
Node Type                                           Mixd
IP routing enabled                                No
Wins proxy enabled                              No

Ethernet Adapter Local Area Connection 2
Media State                                         Media disconnected
Description                                          Realtek   RTL8139/810x  Family Fast Ethernet

Ethernet NIC
Physical address                                  00-E0-00-C2-8D-4F

Ethernet adapter Local Area Connection 3:
Connection Specific dns suffix:
Description   AMDTek  AN985  10/1000Mbs  Fast Ethernet

.Net Adapter
Physical Address                                  00-09-5B-8A-fB-63
Dhcp Enabled                                       Yes
Autoconfiguration Enabled                     Yes
IPaddress                                            192.168.1.4
Subnet Mask                                        255.255.255.0
Default Gateway                                   192.168.1.20
DHCP Server                                        192.168.1.20
DNS Server                                          151.203.0.84
Lease Obtained                                    Fri Nov 19,2004 ....
Lease Expires                                      Mon Jan 18, 20038 ...
0
 
wesly_chenCommented:
--Linux box--
> ifconfig –a
> eth0     Link ncap:Ethernet  HWaddr 00:c0:9F:27:4:C3
> inet addr:192.168.0.217  Bcast:192.168.0.255  Mask:255.255.255.0

--Windows box
> IPaddress                                            192.168.1.4
> Subnet Mask                                        255.255.255.0
> Default Gateway                                   192.168.1.20

If I understand correctly, the problem is the IP of your Linux box.
You have

 DSL -- Netgear DSL router -- Switch B -- Linksys switch (router ?)
            (192.168.1.20)           |         |                   |
                               Windows PCs    NIC#1-Linux-NIC#2

If eth0 is NIC#1, then your IP for eth0 should be 192.168.1.x ( 192.168.0.217 is not in the same subnet ).

So edit
---/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.1.255
HWADDR=00:c0:9F:27:4:C3
IPADDR=192.168.1.217     <=== modify to fit your network
NETMASK=255.255.255.0
NETWORK=192.168.1.0
ONBOOT=yes
TYPE=Ethernet
---

---/etc/sysconfig/network
NETWORKING=yes
HOSTNAME=xxxxx
GATEWAY=192.168.1.20
-----------

---/etc/resolv.conf
nameserver   151.203.0.84
----

And reboot the Linux box.

Wesly

0
 
xdaleAuthor Commented:
Yikes!

Now I am unable to startx.
Fatal Server Error
could not open default font 'fixed'

XIO: fatal IO error 104 (connection reset by peer) on X server ":0.0" after 0 requests (o known processed) with 0 events remaining.
0
 
xdaleAuthor Commented:
Wes:
Why do I have a nameserver as 151.203.0.84?
0
 
wesly_chenCommented:
> Why do I have a nameserver as 151.203.0.84?
It's from the "ipconfig /all" on your Windows PC.

Wesly
0
 
xdaleAuthor Commented:
What do I do next?
0
 
wesly_chenCommented:
Ctrl+Alt+F1 (or F2, F3) to get a console terminal.
check if you can ping the Netgear router first.
If not, switch the network cable between NIC#1 and NIC#2 and do "ping".

Wesly
0
 
xdaleAuthor Commented:
I did ping 192.168.1.20
It reports:
64 bytes from 192.168.1.20 icmp_seq = n ttl=64  time=0.03x ms

(Note:    'n' and 'x' are sequential digits)

It just keeps scrolling incessantly with this report and I have to reboot to stop it.

Secondly:
I disabled eth1

Thirdly:
I have no X window  when I invoke "Startx"

Finally"
A MAC Address seems to be erroneous
0
 
xdaleAuthor Commented:
I ommitted to report the following message at boot up time:
" Starting NFS daemon: Portmap: server localhost not responding, timed out   [FAILED]

What's the solution
0
 
xdaleAuthor Commented:
What is the config to auto start X windosw?
0
 
wesly_chenCommented:
>It just keeps scrolling incessantly with this report and I have to reboot to stop it.
"Ctrl+C" will kill it and exit.

> I have no X window  when I invoke "Startx"
Ctrl+Alt+F7

> A MAC Address seems to be erroneous
What does this mean?

> " Starting NFS daemon: Portmap: server localhost not responding, timed out   [FAILED]
Do you have
127.0.0.1     localhost.localdomain  localhost
in your /etc/hosts ?
Please make sure this line is exact the same as the one above. ( please "cat /etc/hosts" and post here)

Finally, please "ping www.yahoo.com" .
If this is working, then your internet problem is resolved.

Wesly
0
 
xdaleAuthor Commented:
I did cat /etc/hosts

It reported:

#Do not remove the following line, or various programs
#that require network functionality will fail.
127.0.0.1          Localhost.localdomain  localhost
192.168.0.217   mcmillan1.localdomain   mcmillan1
#Dee's Machine Basement
192.168.0.1     ws001
192.168.0.2     ws002
192.168.0.3     ws003
192.168.0.4     ws004
192.168.0.5     ws005
192.168.0.6     ws006
192.168.0.199  ws007
192.168.0.8     ws008
192.168.0.253 Medmgr
192.168.0.131 Printer
192.168.0.118 Jetdirect1
192.168.0.119 Jetdirect2
68.192.32.70   webmail.geeksinthehood.net
192.168.0.254  jamgate
0
 
wesly_chenCommented:
Can "ping www.yahoo.com" ?

I think internet connection is the main topic.

Wesly
0
 
xdaleAuthor Commented:
Fair Enough!

I just did another ifconfig -a

This is what I got:

eth0     Link encap:Ethernet  HWaddr 00:C0:9F:27:4E:C3
inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0
UP BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:0 (0.0. b)  TX bytes:256 (256.0 b)
Interrupt:10 Base  address:0xecc0  Memory:fe100000-fe120000


eth1     Link encap:Ethernet  HWaddr 00:08:54:D0:9D:50
BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:0 (0.0. b)  TX bytes:0 (0.0 b)
Interrupt:5 Base  address:0x5000


Lo     Link encap:Local Loopback
     Inet addr:192.168.1.20  Mask:255.255.255.0
     UP LOOPBACK RUNNING  MTU:16436  Metric:1
RX packets:427 errors:0 dropped:0 overruns:0 frame:0
TX packets:427 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:0
RX bytes: 43056 (42.0 Kb)  TX bytes:43056 (42.0 Kb)

0
 
wesly_chenCommented:
> eth0     Link encap:Ethernet  HWaddr 00:C0:9F:27:4E:C3
> inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0
So your IP is 192.168.1.20.

What's your default gateway now?
netstat -r

Wesly
0
 
xdaleAuthor Commented:
netstat -r
Kernel IP routing table
Destination    Gateway   Genmask   Flags          MSS   Window   irtt     iface
192.168.1.0      *           255.255.255.0             U        0            0       eth0
192.168.1.0      *           255.255.255.0             U        0            0       eth0
192.168.1.0      *           255.255.255.0             U        0            0       eth0
169.254.0.0      *           255.255.0.0                 U        0            0       eth0
default     192.168.1.20    0.0.0.0                       UG      0            0       lo
0
 
xdaleAuthor Commented:
Hello!
0
 
wesly_chenCommented:
DSL -- Netgear DSL router -- Switch B -- Linksys switch (router ?)
            (192.168.1.20)           |         |                  
                               Windows PCs    NIC#1-Linux-NIC#2

> ifconfig -a
> eth0     Link encap:Ethernet  HWaddr 00:C0:9F:27:4E:C3
> inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0

I got confused, your Netgear DSL router is 192.168.1.20 and your Linux box also has IP 192.168.1.20.
That's IP conflict. That's the problem now.
What's in your /etc/sysconfig/network-scripts-ifcfg-eth0
---
DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.1.255
HWADDR=00:c0:9F:27:4:C3
IPADDR=192.168.1.217   <= What IP here? if "217", then after reboot, it should get "217" as IP instead of "20"
NETMASK=255.255.255.0
NETWORK=192.168.1.0
ONBOOT=yes
TYPE=Ethernet
----

Wesly
0
 
xdaleAuthor Commented:
I changed it to 192.168.1.217

It  still does not connect
0
 
wesly_chenCommented:
> I changed it to 192.168.1.217
Does "ifconfig eth0" show 192.168.1.217? if not, then
ifconfig eth0 down; ifconfig eth0 192.168.1.217 up
to change it immediately.

Then
# ping 192.168.1.20     <=== ping default gateway to test network connection
# ping 151.203.0.84     <=== ping DNS server to test internet connection
# ping www.yahoo.com <=== test DNS resolution
to see fail at which stage.

Wesly
0
 
xdaleAuthor Commented:
Host Unreachable!
0
 
xdaleAuthor Commented:
"ifconfig eth0" does show 192.168.1.217
0
 
wesly_chenCommented:
Hi,

   After so many changes, I'm kind of confused about your HW/SW configuration now. Let me clear it first.

<<Network infrastructure>>
DSL -- Netgear DSL router ------ Switch B
          (192.168.1.20)                   |                        
                                   (192.168.1.217)  NIC#1-Linux

<<Network configuration on Linux>>
--- < IP configuration>--
# ifconfig -a

eth0     Link encap:Ethernet  HWaddr 00:C0:9F:27:4E:C3
inet addr:192.168.1.217  Bcast:192.168.1.255  Mask:255.255.255.0
UP BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:0 (0.0. b)  TX bytes:256 (256.0 b)
Interrupt:10 Base  address:0xecc0  Memory:fe100000-fe120000

eth1     Link encap:Ethernet  HWaddr 00:08:54:D0:9D:50
BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:0 (0.0. b)  TX bytes:0 (0.0 b)
Interrupt:5 Base  address:0x5000

Lo     Link encap:Local Loopback
     Inet addr:192.168.1.20  Mask:255.255.255.0
     UP LOOPBACK RUNNING  MTU:16436  Metric:1
RX packets:427 errors:0 dropped:0 overruns:0 frame:0
TX packets:427 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:0
RX bytes: 43056 (42.0 Kb)  TX bytes:43056 (42.0 Kb)
----< defaultgateway >--
# netstat -r
Destination    Gateway   Genmask   Flags          MSS   Window   irtt     iface
192.168.1.0      *           255.255.255.0             U        0            0       eth0
192.168.1.0      *           255.255.255.0             U        0            0       eth0
192.168.1.0      *           255.255.255.0             U        0            0       eth0
169.254.0.0      *           255.255.0.0                 U        0            0       eth0
default     192.168.1.20    0.0.0.0                       UG      0            0       lo
--- <DNS setting>
# cat /etc/resolv.conf
nameserver   151.203.0.84

# grep "^hosts" /etc/nsswitch.conf
hosts:  files dns

<< test result >>
# ping 192.168.1.20     <=== ping default gateway to test network connection
Host Unreachable!
# ping 151.203.0.84     <=== ping DNS server to test internet connection
Host Unreachable!
# ping www.yahoo.com <=== test DNS resolution
Host Unreachable!

=======================

Please verify those above. Point out where exactly mismatch. More details will help.

Regards,

Wesly
0
 
xdaleAuthor Commented:
I now show this.  Very frustrating


# ifconfig -a

eth0     Link encap:Ethernet  HWaddr 00:C0:9F:27:4E:C3
inet addr:192.168.1.217  Bcast:192.168.1.255
Mask:255.255.255.0
UP BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:67 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:10 (10.0. b)  TX bytes:9067 (8.8 kb)
Interrupt:10 Base  address:0xecc0  Memory:fe100000-fe120000

vmnet1     Link encap:Ethernet  HWaddr 00:50:56:C0:00:01
inet addr:172.16.90.1  Bcast:172.16.90.1
Mask:255.255.255.0
BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:0 (0.0. b)  TX bytes:0 (0.0 b)
Interrupt:5 Base  address:0x5000

vmnet8     Link encap:Ethernet  HWaddr 00:50:56:C0:00:01
inet addr:172.16.229.1  Bcast:172.16.229.255
Mask:255.255.255.0
BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:0 (0.0. b)  TX bytes:0 (0.0 b)
Interrupt:5 Base  address:0x5000

Lo     Link encap:Local Loopback
Inet addr:127.0.0.1  Mask:255.255.255.0
UP LOOPBACK RUNNING  MTU:16436  Metric:1
RX packets:75 errors:0 dropped:0 overruns:0 frame:0
TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:0
RX bytes: 5412 (5.2 Kb)  TX bytes:5412 (5.2 Kb)


# netstat -r
Destination    Gateway   Genmask   Flags          MSS  Window   irtt     iface
172.16.229.0    *           255.255.255.0             U      0            0       eth0
192.168.1.0      *           255.255.255.0             U      0            0       eth0
172.16.90.0      *           255.255.255.0             U      0            0       eth0
169.254.0.0      *           255.255.0.0                 U      0            0       eth0
default     192.168.1.20    0.0.0.0                       UG    0            0       lo
--- <DNS setting>
# cat /etc/resolv.conf
nameserver   151.203.0.84

# grep "^hosts" /etc/nsswitch.conf
hosts:  files dns




            
0
 
wesly_chenCommented:
> vmnet1     Link encap:Ethernet  HWaddr 00:50:56:C0:00:01
> inet addr:172.16.90.1  Bcast:172.16.90.1 Mask:255.255.255.0
It's Linux in VMware. Is this the Linux box (Dell Server) we are talking about?

Wesly
0
 
xdaleAuthor Commented:
yes
0
 
xdaleAuthor Commented:
I  installed vmware. But that is a separate thing.  I think
0
 
wesly_chenCommented:
> I  installed vmware
Ok, is it the VMware in Linux (Linux host, Windows guest) or Linux in VMware?
If it is latter, then it matters.

How many NICs in the Dell server now? Because the "eth1" disappears from your latest "ifconfig -a".

Wesly
0
 
xdaleAuthor Commented:
Linux Host Windows Guest.
There are 2 NIC's in the box, but yesterday I had uninstalled one driver
0
 
wesly_chenCommented:
<< test result >>
# ping 192.168.1.20     <=== ping default gateway to test network connection
Host Unreachable!
# ping 151.203.0.84     <=== ping DNS server to test internet connection
Host Unreachable!
# ping www.yahoo.com <=== test DNS resolution
Host Unreachable!
------
Is this what you got?
You fail to "ping 192.168.1.20"?

Wesly
0
 
xdaleAuthor Commented:
# ping 192.168.1.20     56 (84) bytes of data
From 192.168.1.217 icmp_seq=n Destination Host Unreachable

# ping 151.203.0.84     56 (84) bytes of data
From 192.168.1.217 icmp_seq=n Destination Host Unreachable


# ping www.yahoo.com Unknown Host www.yahoo.com
0
 
xdaleAuthor Commented:
Did I mention that I did cat /etc/hosts

It reported:

#Do not remove the following line, or various programs
#that require network functionality will fail.
127.0.0.1          Localhost.localdomain  localhost
192.168.0.217   mcmillan1.localdomain   mcmillan1
#Dee's Machine Basement
192.168.0.1     ws001
192.168.0.2     ws002
192.168.0.3     ws003
192.168.0.4     ws004
192.168.0.5     ws005
192.168.0.6     ws006
192.168.0.199  ws007
192.168.0.8     ws008
192.168.0.253 Medmgr
192.168.0.131 Printer
192.168.0.118 Jetdirect1
192.168.0.119 Jetdirect2
68.192.32.70   webmail.geeksinthehood.net
192.168.0.254  jamgate
0
 
wesly_chenCommented:
># ping 192.168.1.20     56 (84) bytes of data
> From 192.168.1.217 icmp_seq=n Destination Host Unreachable
Wooo, the network connection are not even up.
Please check the network cable connection:
1. The network switch port, where you connect your Dell server to network switch, is blinking or not?
   if not, thenchange to other switch port.
   Or change the network cable.
   The worst case, change the network card in Dell server.

Assumption:
DSL -- Netgear DSL router ------ Switch B
          (192.168.1.20)                   |                        
                                   (192.168.1.217)  NIC#1-Linux

You need to be able to "ping 192.168.1.20" first.

Wesly
0
 
wesly_chenCommented:
> /etc/hosts
> 192.168.0.217   mcmillan1.localdomain   mcmillan1
              ^^
Change to
192.168.1.217   mcmillan1.localdomain   mcmillan1

Wesly
0
 
xdaleAuthor Commented:
I can ping now. I changed the switch
0
 
xdaleAuthor Commented:
I changed   > /etc/hosts
 192.168.0.217   mcmillan1.localdomain   mcmillan1
              ^^
 to
192.168.1.217   mcmillan1.localdomain   mcmillan1


One trouble seems to be the NFS Daemon which :is not found"
0
 
wesly_chenCommented:
> I can ping now. I changed the switch
Good.
How about
# ping 151.203.0.84     <=== ping DNS server to test internet connection
# ping www.yahoo.com <=== test DNS resolution
Are those 2 ok?

NFS is not the main topic (not related, either). I perfer focus on the internet connection issue.

Regards,

Wesly
0
 
xdaleAuthor Commented:
ok:
It may be a harware issue. How can I reinstall and reconfigure the 2 NIC's?
As you know I connected directly to the Netgear Router/Switch because the switch B was not reporting a ping.
0
 
wesly_chenCommented:
> How can I reinstall and reconfigure the 2 NIC's
Put the second NIC in and boot it up.
Use "netconfig" to config your NIC (eth1) to 192.168.0.x.

For NFS issue, please open another question and provide
1. exact error message
2. chkconfig --list | grep nfs
3. /etc/exports
4. /etc/hosts
5. /etc/fstab

So people in EE can understanding your issue and easy to assist you to resolve the problem.

Wesly
0
 
xdaleAuthor Commented:

My  DSL modem is connected to a Netgear Router/Switch "A".  A cable from that switch connects to a Dell Server running under RedHat 9.  The Linux box cannot connect.

What should I correct in my configuration to solve this problem?

network configuration of your RH9 box:

# ifconfig -a

# ifconfig –a
eth0     Link ncap:Ethernet  HWaddr 00:c0:9F:27:4:C3
inet addr:192.168.0.217  Bcast:192.168.0.255  Mask:255.255.255.0
UP BROADCAST MULTICAST   MTU:1500  Metric:1
RX packets:116 errors:0 dropped:0 overruns:0 frame:0
TX packets:116 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes:7804 (7.6 Kb)  TX bytes:9581 (9.3 Kb)
Interrupt:10 Base  address:0xecc0  Memory:fe100000-fe120000

Lo     Link encap:Local Loopback
     Inet addr:127.0.0.1  Mask:255.0.0.0
     UP LOOPBACK RUNNING  MTU:16436  Metric:1
RX packets:146950 errors:0 dropped:0 overruns:0 frame:0
TX packets:146950 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:0
RX bytes: 10293611 (9.8 Mb)  TX bytes:10293611 (9.8 Mb)


vmnet8     Link encap:Ethernet
     Inet addr:172.16.229.1 Bcast:172.16.229.255 Mask:255.255.255.0
     UP BROADCAST RUNNING  MULTICAST  MTU:15000  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:137 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
RX bytes: 0 (0.0 b)  TX bytes:0  (0.0 b)

# netstat -rn

> Kernel IP routing table
> Destination        Gateway     Genmask           Flags    MSS   Window        irtt   Iface
> 172. 16.229.0       0.0.0.0        255.255.255.0   U         0          0              0    vmnet8
> 169. 254.0.0         0.0.0.0        255.255.0    .0   U         0          0              0    lo
> 127. 0..0.0           0.0.0.0        255.0. 0.0    .0   U         0          0              0    lo


# cat /etc/resolv.conf
   
nameserver 151.203.0.84

# cat nsswitch.conf

cat: nsswitch.conf;  No such  file or directory





 


I have

 DSL -- Netgear DSL router --                      
            (192.168.1.20)                                
                 |              |                     |
 NIC#1-Linux-NIC#2    Windows PCs   Switch B
                                                       |                                |                   |
                                                        Netgear Print server   Windows Pc    Linksys switch  
                                                                                                              |
                                                                                                              Windows Pc
               





 cat /etc/hosts

 reported:

#Do not remove the following line, or various programs
#that require network functionality will fail.
127.0.0.1          Localhost.localdomain  localhost
192.168.0.217   mcmillan1.localdomain   mcmillan1
#Dee's Machine Basement
192.168.1.1     ws001
192.168.1.2     ws002
192.168.1.3     ws003
192.168.1.4     ws004
192.168.1.5     ws005
192.168.1.6     ws006
192.168.1.199  ws007
192.168.1.8     ws008
192.168.0.253 Medmgr
192.168.1.131 Printer
192.168.1.118 Jetdirect1
192.168.1.119 Jetdirect2
68.192.32.70   webmail.geeksinthehood.net
192.168.1.254  jamgate




Then
# ping 192.168.1.20    

Network is Unreachable


# netstat -r

> Kernel IP routing table
> Destination        Gateway     Genmask           Flags    MSS   Window        irtt   Iface
> 172. 16.229.0      *             255.255.255.0     U         0          0              0    vmnet8
> 169. 254.0.0         *            255.255.0   .0      U         0          0              0    lo
> 127. 0..0.0           *             255.0. 0.0  .0      U         0          0              0    lo


# grep "^hosts" /etc/nsswitch.conf

hosts:  files dns



Installed vmware
 (Linux host, Windows guest)

There are 2 NIC's in the box, but yesterday I had uninstalled one driver
unsure of models so uninstalled coflict. they both accesed eth0
      

 So Used "netconfig" to re-config your NIC (eth1) to 192.168.0.x.

For NFS issue:
Did chkconfig --list | grep nfs
nfs         0:off       1:off   2:off      3:off     4:off    5:on    6:off                        
nfslock   0:off       1:off   2:off      3:on     4:on     5:on    6:off

3. /etc/exports

/opt/ltsp/i386               192;168.0.0/255.255.255.0(ro,no_root_squash,syn)
/var/opt/ltsp/swapfiles  192;168.0.0/255.255.255.0(rw,no_root_squash,asyn)


5. /etc/fstab
LABEL=/                                   /                         ext3       defaults                    1  1
LABEL=/boot                            /boot                    ext3       defaults                    1  2
none                                      /dev/pts                devpts   gid=5,mode=620        0   0
LABEL=/home                        / home                   ext3       defaults                    1   2
none                                      /proc                     proc       defaults                    0   0
none                                      /dev/shm              tmpfs       defaults                    0  0
LABEL=/tmp                           /tmp                      ext3       defaults                    1  2
LABEL=/usr                            /usr                        ext3       defaults                    1  2
LABEL=/var                            /var                         ext3       defaults                    1  2
/dev/hdb1                              /mnt/hdb1                ext3       auto,user,rw              1  1
/dev/hdb3                              /mnt/hdb3                ext3       auto,user,rw              1  1
/dev/hdb8                              swapnnnnn              swap       defaults                    0  0
/dev/cdrom                            /mnt/cdrom    udf,iso9660 noauto,owner,kudzu,o      0   0
/dev/fd0                            /mnt/floppy                   auto       noauto,owner,kudzu,     0   0

0
 
wesly_chenCommented:
Hi,

  I don't understand you since the issue is resolved. You could ping Netgear DSL router 192.168.1.20 without problem
> # ifconfig –a
> eth0     Link ncap:Ethernet  HWaddr 00:c0:9F:27:4:C3
> inet addr:192.168.0.217  Bcast:192.168.0.255  Mask:255.255.255.0
And you changed the IP to 192.168.0.217 (previous 192.168.1.217) for what purpose?

  192.168.0.x and 192.168.1.x are in different subnet and can not connect to each other without router.

  All you need to do is change to 192.168.1.217 and everything should be ok.

  For NFS, please open another question since it is unrelated to your topic.

Regards,

Wesly
0
 
wesly_chenCommented:
DSL -- Netgear DSL router --                      
            (192.168.1.20)                                
          |                 |                     |
    NIC#1-Linux    Windows PCs   Switch B
192.168.1.217(eth0)                           |                                |                   |
                                                        Netgear Print server   Windows Pc    Linksys switch  
                                                                                                              |
                                                                                                              Windows Pc

Once your IP on eth0 is 192.168.1.217, then you should be able connect to Netgear router or internet.
From "ifconfig -a" doesn't show the NIC#2 or eth1.
Once you setup NIC #2, then you can assign 192.168.0.217 to eth1 (NIC#2), NOT eth0.

> 3. /etc/exports
> /opt/ltsp/i386               192;168.0.0/255.255.255.0(ro,no_root_squash,syn)
                                         ^^
> /var/opt/ltsp/swapfiles  192;168.0.0/255.255.255.0(rw,no_root_squash,asyn)
                                         ^^
Typo, it should be 192.168.0.0 or 192.168.1.0 (if eth1 is not up).

Regards,

Wesly
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 26
  • 21
Tackle projects and never again get stuck behind a technical roadblock.
Join Now