Invisible DHCP server on Linksys router?

I have set up a home network using a cable modem and a Linksys WRT54G with computer on both the wired and wireless side.  I had DHCP enabled on the router using network, mask, and starting with IP address  Everything was working fine until all the computers renewed their address yesterday.  The computers are now being assigned sequential IP address, starting in the 20's.  An excerpt from "ipconfig /all" follows.

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Dell Wireless WLAN 1450 Dual Band WLAN Mini-PCI Card
        Physical Address. . . . . . . . . : 00-11-F5-05-3A-25
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . :
        Subnet Mask . . . . . . . . . . . :
        Default Gateway . . . . . . . . . :
        DHCP Server . . . . . . . . . . . :
        Lease Obtained. . . . . . . . . . : Wednesday, November 17, 2004 4:32:20 PM
        Lease Expires . . . . . . . . . . : Monday, January 18, 2038 9:14:07 PM

The default gateway is correct, but there are no DNS entries, so the computers effectively access the web.  Also, it says the address was assigned by, but there is no computer there.  If i assign a static IP to a computer and tell it to go to the router for DNS lookup, it work fine.  My first thought was that one of the computers may have been operating as a DHCP server through ICS.  After checking all the computers, none of them had ICS running and all had the same problems with their IP addresses.  I turned off all the other computers on the network and verified that I still had the error, then I turned off this computer and verified the error on one of the previously off computers.  I believe I have now ruled out all the computers on the network leaving only the router as the source of the error.  I upgraded the routers firmware, from v2 to v3, and performed a factory default reset.  Alas, the problem persists.  I have a CCNA certification and manage a small Cisco 800 network at work, but this dilemma is making a fool out of me.  Thank you for your assistance.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

There has got to be something at that is handing out IP addresses. Suggest putting a sniffer on the network to trap th mac address of this rogue DHCP server.
Have you tried disabling the DHSP server on the Linksys and see if you still get an IP?
Does someone have another linksys/soho router under their desk that they are using as a small switch?
adambuttAuthor Commented:
I have tried turning off DHCP on the router, and the problem does not go away.  There are no other routers on the network, and all other computers have been turned off.  I tried running ethereal, but it can't see any of my interfaces.
After the factory reset you had to go back and configure the WRT54G as before, right?
Do you still have the problem if you use a different setup for the router?

Disable all wireless access and settings on the router and check the LAN machines again.
Unplug all LAN connections, enable wireless and try your wireless clients.

Is it possible the wireless network has been compromised?
Assuming your router is then it is not the problem.

As lrmoore said another host on your network ( is running a DHCP service in some form or other.  If you are fairly sure that there are no other devices turned on, on your network then ping it & if it replies then quite obviously you are mistaken.

You can suss out the host a bit - try the following.
 - nbtstat -a (if it is a microsoft host this will tell you the computername & who is logged on)
 - try accessing  If it is another soho router sitting under someone's desk it may have some webadmin listening on port 80.

Tou could PING -t.  You will most likely get replies.  have someone watch the replies whilst ripping each network point out of the patch panel 1 at a time until it times out.  This will make it quite obvious which port it was on the panel's side.  Got a tracer?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
adambuttAuthor Commented:
No ping responce.  As I was following all the cat cables to unplug them from the computers, I found a paralell port print server that had been disconnected from the printer and fallen behind a desk.  It was disconnected for several weeks, and I don't know why it just now started to act as a DHCP server, or why anyone would put a DHCP server on a printer.  Again, thank you all for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.