PCQ Linux , how to boot in console?

hi ,

I installed PCQ linux on my machine alongwith WinXP . When the system boots , the GRUB loader comes and has two options

1. XP
2. PCQ Linux

When i chose Linux , Linux boots up with a graphical interface cause i installed KDE.

The thing is that i am new to the OS and its just been added to my course in college . We started learning it there and so i installed it at home to practice . In college , we telnet into a UNIX server running SCO UNIX i think . The point being that its CUI and no graphics are involved . Learning in a CUI environment in college and using a GUI based LINUX console is confusing me a lot .

Hence , i would like to know if there is any way i could boot up LINUX in a CUI mode just like windows can be boot up in DOS MODE ..

Please Help !

Sameer
Packman123Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lynxlupodianCommented:
Well, you can press ctrl+alt+F2 to ctrl+alt+F6 to get to the CUI. ctrl+alt+F7 would return you to the still running kde.
If you want to completely disable kde(X to be more precise) from starting, you need to look-up how to remove kdm from the relevant boot level in your distribution.
0
jlevieCommented:
You can have both... Simply open a terminal window in KDE and work there.
0
blklineCommented:
Since you are using GRUB you have another option:

At the boot prompt hit the escape key, then hit the "a" key to go into append mode.  Now, add the digit 3 af the end of the kernel arguments and press enter.  You'll be brought up into run level 3, which is the CUI mode.

To make this permanent, edit:

/etc/inittab

and change the line that reads:

id:5:initdefault:

to read:

id:3:initdefault:

and you'll always be booted into CUI mode.  If you want to go into graphical after having already booted into level 3, just log on as root and type:  init 5

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Packman123Author Commented:
Ok one last question before i close this question and award the poionts .... For some strange reason the CC filename command doesnt run on the LINUX console ?? it says
-bash:command not found


Why ??? i cant compile any C programs ive written ... How do i get it ,,, I have my LINUX cd;s ,, can i install it ???

Thanks
0
hoonexpertCommented:
May be its not in the path.

Issue env command and check the path else #<path>/cc and run.

If u dont know where is ur cc command, #locate cc

Hope it helps.

Manish.
Baroda.
India.
0
lynxlupodianCommented:
Well, use the Gnu cc, gcc. Cc isn't on my system either...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.