Lynx browser and SSL Cert acceptance

Using Lynx 2.8.5 to interact with a variety of local machines, I am constantly prompted to accept various self-signed SSL certs. I noticed the option in the configuration to automatically accept the certs, but when I use that, the prompt to accept the cert still appears, and sits there for a second or two before it continues. This actually takes longer than it does to say yes manually. Is there a way to change this behavior?
(Note, I'm not looking for a root cert bundle.)

LVL 19
billmercerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MKraussCommented:
If you're using self made ssl certs then you could import the CA public key into your browser (also known
as TrusedRoot Certification Authority), once you did that you get not prompet for cerst from this CA.

With Lynx you can do that in a simular way but you should be able to turn off prompting for unknown certs anyway.
Have you cheked eg: http://lynx.isc.org/current/README.sslcerts ?
0
billmercerAuthor Commented:
I have read that document. In this case, importing a bunch of arbitrary self-signed CAs is not what I want. What I would like is to be able to have Lynx just accept these arbitrary certificates without any prompt at all, similar to the -k option in curl. The FORCE_SSL_PROMPT option does  automatically say YES to any prompts to trust a certificate, but it doesn't do it silently. It first displays the prompt as usual, then waitis a couple of seconds, then answers yes for you. It's actually faster to hit return yourself than it is to allow the automatic accept to happen.
That short delay while the prompt is displayed is what I would like to do away with.
0
s_oneilCommented:
There is a setting within Lynx's options to force a yes answer to ssl certs.  Hit O to enter Options, then look for "Security and Privacy".  Setting "SSL Prompting" to "force yes-response" should do what you're looking for.

By default, lynx won't save this setting - To do so requires system-wide changes:
Find your lynx.cfg - usually /usr/lib/lynx.cfg or /etc/lynx.cfg (failing that, enter Lynx's options, and you'll spot a link at the very bottom to your lynx.cfg)

Within that file, search for a line reading:
#ENABLE_LYNXRC:force_ssl_prompt:OFF

and replace it with:
ENABLE_LYNXRC:force_ssl_prompt:ON

lynx will now allow you to save that option.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

s_oneilCommented:
A great start here, I managed to entirely miss your comment, so my previous answer is useless.

I can't find anything in lynx's source that accounts for this behaviour - it doesn't appear to be intentional, so I doubt there's a setting to work around it.  I can't for the life of me, however, figure out why it's behaving any differently from the cookie_noprompt option, as they both use the same routine (HTForcedPrompt)
0
billmercerAuthor Commented:
I installed Lynx from a Mandrake RPM. Is it possible this is some fluke of my installation?

0
s_oneilCommented:
I see a noticable delay (certainly more noticable than the cookie prompt), but half a second at the most, not two - from Debian packages and source-built
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.