SUSE and keyboard layout

Hi.

Yet Another Stupid Question (YASQ):

I run a few machines running SUSE 9.1 Pro and all is well with them - in principle. However, I feel that the SUSE KDE is somewhat heavy and even a >2 GHz machine w 512 M RAM struggles a bit during startup. So, i tried using WindowMaker, which is one of my favourites, on my personal machine. As expected startup was much quicker. The PROBLEM is that I lose the swedish keyboard layout....

The question is: Is there a way to set a global KB layout in SUSE, one that will permeate through to whicever desktop I choose?

Or, if that is not possible: Does someone know how I tell WindowMaker that I want a swedish KB layout?

Cheers
/RID
LVL 31
ridAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Do you have a keyboard file in /etc/sysconfig? Is the definition set to swedish there (Do you have a swedish layout when not starting X)?

Do you have a keyboard setting in /etc/X11/XF86Config or whichever name your particular config file has.

Mine has the following entry:

Section "InputDevice"
...
...
...
   Option           "XkbLayout" "de_CH"

for my swiss keyboard.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ridAuthor Commented:
I'll most certainly check this. I'm out of office for a few days but I'll get back to you as soon as possible. Thanks!
/RID
0
ridAuthor Commented:
Sorry for the delay.
When I run without X (runlevel 3) I have swedish KB layout, but when I start WM I lose it to the US layout.

The entry in XF86Config is "se-latin1".

A pity. WM is so much quicker...
/RID
0
ridAuthor Commented:
I got this solved, with the aid of your input. It turned out that KDE (default desktop) seems to use its own keymap setting and other GUI's rely on sysconfig - that's what it looks like from my point of veiw, anyway. AND the swedish eymap seems broken, so I had to set it to finnish to get the åäö working. Now all is well... Thanks
/RID
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.