Help with setting up a wireless home network

Hi all,
I've got 3 computers, 2xWin98SE & 1xWinXP with wireless lan cards and a wireless router SMC2804WBRP-G connected to a dsl modem and I want to set up a home network so that I can share files across the 3 computers.
So far, I've been able to set up the router so that all 3 computers can access the internet via the router and the router has assigned the ip addresses 192.168.2.101 - 103 to the 3 computers. Now my problem is that each computer cannot access each other. I've enables file sharing on all 3 and shared the My Documents folder. Computers ending in 101 & 102 can ping each other but not 103. However 103 can ping the other 2 computers. When I click on network neighbourhood on the Win98SE computers I get an error message saying "unable to browse network".
Any ideas on where to go from here. Is it settings on the computer or on the router or on both. Secondly in the interest of security, how do I configure the router to only allow access from the 3 computers. I've enabled the firewall setting on the router but thats all there is. A bit lost on this part. Any help greatly appreciated. Cheers
Shav

shavAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

smiffy13Commented:
Is 103 the XP PC? If so, is the XP firewall on?

Double/triple check that you don't have a firewall on any of your PC's until you get them all communicating.

Workgroups: all your PC's must be configured to be i the same workgroup. W/98 default name is WORKGROUP, XP default name is MSHOME, assuming that you've relied on the defaults, change the XP PC to use WORKGROUP, to change this - right click My Computer, click system properties, click Computer Name tab, if Workgroup = MSHOME then click change and enter WORKGROUP as the workgroup name.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BabalooInternetCommented:
Hi shav

The quickest way I used to set up so that only the three computers on your network can access your router, is to set up MAC Filtering in your router.

First get all mac addresses from your wireless network cards.
Run cmd/command
type: ipconfig /all

this will give you the all network setting for your netwrok adaptors.  The Physicle Address is you mac address.

Go into you router configuration.  Go to Firewall-->Mac Filter.
Enable mac address control
Enter the three mac addresses of your wireless cards into the filter.
save setings and restart your router.
This will allow only your three computers to connect to your router.  All other mac addresses will be denied access.  Be sure you get the mac address of your wireless adaptor and not of any other netwrok adaptors.  To add more computers you'll have to access the router through one of the computers allready added on the router and add the mac address of it's wireless adaptor.

Then turn off firewall and see if you can share files.  If you can, turn it on again and make sure your correct ports are open for file sharing(21).  Also make sure no firewall is turned on on your computers.
0
lyle-grangerCommented:
Hello shav,

You need to make sure that all of the comptuers are part of the same workgroup.  It sounds like you have already enabled file and print sharing and shared the files.  Rather than re-invent the wheel, check out this link it explains workgrouping very well:

http://support.microsoft.com/kb/q258717/

Hope this is helpful.

Lyle
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.