Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

extremely slow opening "windows explorer" issue

Posted on 2004-11-20
31
Medium Priority
?
17,000 Views
Last Modified: 2011-08-18
Here is something that has been driving me crazy for a while.  

When I "explore" my computer by right clicking on the start bar and going to "explore" (or if i click on my computer and try to access my drives) it can take a really long time to show me the drive list.  It actually freezes the windows explorer box (whole thing turns white like it crashed) for 30 seconds or more before showing the drive list.  Then when I click on the drive list, it also can take 5 or 10 seconds to bring up the subdirectory lists.  I have tried to determine if it is only the first time I access a drive after starting my computer, but this is not the case.  I am not connected to a home/office network.  I can't imaging that windows directories should load this slow - this is a major drain on productivity for me.  I do run a defrag from time to time, doesn't help this.

Here is a quick blueprint of my operating environment:

hp laptop 2.66 ghz
windows xp pro
office xp pro
visual studio dot net
wireless internet connection
not connected to a network
Windows SP1

Thank you in advance for the help.
0
Comment
Question by:krose777
  • 9
  • 7
  • 3
  • +9
31 Comments
 
LVL 65

Accepted Solution

by:
SheharyaarSaahil earned 1000 total points
ID: 12633669
Hello krose777 =)

Goto Start>Run>msconfig>Servcies
and untick Windows Image Acquisition (WIA) service
restart and now check if same problem ??

If yes then boot your system in safemode to check for the issue there,
if it doesn't happen there, then come back in Normal mode and do this,
Goto Start>Run>msconfig>Startup, and click on Disable All
now goto Services section, and tick Hide Microsoft Services
and now untick all those third party services
restart and now check if the same problem ??
if NO then u can re-enable each application\service at a time to trace out the culprit one !!
0
 
LVL 93

Expert Comment

by:nobus
ID: 12633672
first suspect = virus if yes, run those (all)

     Spybot :        http://www.download.com/3000-8022-10122137.html
     adaware :      http://www.lavasoftusa.com/
     STINGER  :   http://vil.nai.com/vil/stinger/   
http://housecall.trendmicro.com/                                           online scan for trojans
http://www.ravantivirus.com/scan/
http://www.spychecker.com/program/coolwebshredder.html            CWshredder
http://www.spychecker.com/program/hijackthis.html                           download
http://www.hijackthis.de/index.php?langselect=english                            check the log

if this is not the cause, you can look for big files and folders, they can slow down your system; eg a zip file of 4Gb could cause this; so check the folders and delete the temp folders
0
 
LVL 2

Author Comment

by:krose777
ID: 12634317
Disabling WIA does not help. I still have this issue in SAFE mode.  I already run sybot and adaware and have norton installed for virus.  I will try other utlities as suggested but I dont really suspect a virus or adware.
0
Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12634341
IE can be related to Windows Explorer also..... so Try this, goto IE>Tools>Internet Options>Advanced and under Browsing untick Enable Third Party Browser Extensions(requires restart)
Restart and now check if same problem, if NO then it was becoz of a corrupted or bad BHO, try using BHODemon to
disable the BHOs and trace out the culprit one, BHODemon >> http://www.softpedia.com/public/cat/10/17/10-17-71.shtml
0
 
LVL 93

Expert Comment

by:nobus
ID: 12634367
you can also disable the upstart of programs with msconfig, in the differen tabs you can disable all kind of software
0
 
LVL 2

Author Comment

by:krose777
ID: 12634408
removed third party browser extensions, that doesnt help.  

nobus - already tried booting to safe mode with no startup programs loaded and still have the issue.
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12634419
ok now if im not mistaken,,,, this is not a Newly Generated Problem on your system... but is a common issue ever since you have got the system....... is it ??
0
 
LVL 2

Author Comment

by:krose777
ID: 12634472
I dont remember when it started.   It is not something that happened this week or this month, but I dont remember this being an issue when I originally purchased my system.  

My guesses are either:

1. Something to do with my setup where it is checking for network places or something along those lines, which I have seen slow down systems before.  I am not connected to any network, however, except for the wireless internet connection.

2. Some issue with the way windows is loading the directory/file structure.  For instance, I notice that not only is it slow opening c: drive, but it is slow opening subdirectories that have a lot of files or subdirectories in it.  My feeling is it is unreasonably slow based on the actual amount of data we are talking about - ie: a directory with 15 sub directories and maybe 30 or 40 files.  It shouldnt take long time to display that content - its not like im reading every file in the directory, just displaying the names.

I supposed I should also try disabling norton in case that has any effect.  I will try that now.

0
 
LVL 2

Author Comment

by:krose777
ID: 12634486
Disabling Norton does not help.
0
 
LVL 2

Author Comment

by:krose777
ID: 12634494
I also have NTFS file system, dont know if that has anything to do with anything.
0
 
LVL 93

Expert Comment

by:nobus
ID: 12634598
Well, if you do not see a way out, you can still do a clean installn after a complete backup.
That should take care of it if it 's software related
0
 

Expert Comment

by:capile
ID: 12634645
Try these:

to avoid checking for network resources, try:
  - under windows explorer > tools... > folder options... > [view tab]
  - untick the "Automatically search for network folders and printers"

Another problem could be related to the amount of free space available on the disk, but this would make all apps to slow down (even if you defrag frequantly) not only Explorer.

If you are suspicious about any hidden app stealing your memory or processor, hit Ctrl + Alt + Del and take a look on "Processes" to see what is consuming most of your memory or CPU.
0
 
LVL 16

Assisted Solution

by:Sohel Rana
Sohel Rana earned 500 total points
ID: 12634658
Hi:

You can install tune up utilities trial version and run "The 1-Click Maintenance" feature. Hope you will see some change :

http://www.tune-up.com/products/tuneup-utilities/

rsdn
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12634772
and Chkdsk C: /f /r doesn't report any error also ??

Dont know if you will agree or not.... but its a common occurence that with a fresh install..... we face a very super performance while working with the system..... and as gradually the installation gets old and we install more and more programs and devices.... the performance decreases gradually also.... atleast i have seen this thing from the last two years in working with XP.... :)
0
 
LVL 2

Author Comment

by:krose777
ID: 12634941
Already have automatically search for network folders unchecked.  Cant find anything suspicious in processes.
0
 
LVL 16

Expert Comment

by:Sohel Rana
ID: 12634960
Hi:

Did you try with the photoshop batch conversion option?

rsdn
0
 
LVL 16

Expert Comment

by:Sohel Rana
ID: 12634965
oh sorry wrong posting, please ignore my last post.

rsdn
0
 
LVL 1

Expert Comment

by:jodyglidden
ID: 12635164
Try disabling your floppy drive.  I've seen some floppy drives take a long time to report back whether they've got media in them or not.
0
 
LVL 2

Author Comment

by:krose777
ID: 12636034
Disabled floppy drive but doesnt help.

SheharyaarSaahil  - I am in complete agreement about XP performance seeming to degrade over time and as you install more programs.

0
 

Assisted Solution

by:wojciech_czyz
wojciech_czyz earned 500 total points
ID: 12636189
Hello,
I had exactly the same problem in my work computer. I understand that your computer is currently not networked, and that you do not have automatic search of network resources activated. Still, the shortcuts stored on your computer and pointing to unaccessible paths can slow your PC. Now, in my case I solved the problem by removing all shortucts to nonconestable places.

I do not remember exactly how I traced it back (6 months ago), I can advice you now to clear all histories: Internet Explorer (> Tools > Internet Options > Clear History, Tools > Content > Autocomplete > Clear Forms), history of all opened documents (Right click on the task bar, Start Menu> Customize > Advanced > Clear List), and last but not least run tool like Norton System Works to check all the shortcuts your computer have and correct them.

You can also open some document, close it, and afterwards search for all documents containing it's name. Now the folder containing the files that you just found will probably contain other ancient shortcuts that you want to remove. When you do right click on the founf document, you can open "parent folder".


0
 
LVL 1

Expert Comment

by:Kubrik
ID: 12636291
Have you some shared folder connected with offline feature?
If yes try to disable the offline feature.

To have a list of these folder type run -start - mobsync
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12636305
>> SheharyaarSaahil  - I am in complete agreement about XP performance seeming to degrade over time and as you install more programs.

hmmmmmm so how old is your installation :-?
0
 
LVL 2

Author Comment

by:krose777
ID: 12636396
Installation is pretty old - I would say close to two years.  

I have been working on trying everything in this long series of suggestions, and I think I have made some progress optimizing.  So far, the tune-up utilities suggested by RSDN have had the biggest effect and actually seem to make some very good suggestions.

Right now, everything is starting to function better exept one thing.  When I explore by right clicking on the start bar, it is taking me to a "Start Menu".  I believe this is where it is jamming now, and other directory navigation seems to work much better and faster.

It appears that it is "looking" for something in this start menu.  It starts by showing

Local Disk (C:)
..
Documents And Settings
Owner
Start Menu
..

- and freezes, and then after a long pause, a bunch of other directories come up.  If I immediately close and re-open it, it is opening fast now.  Is there some special process associated with exploring from the START bar as compared to MY COMPUTER?  When I explore from MY COMPUTER, the drives come up fast now and it doesnt try to open up some far embedded subdirectory like exploring from the start bar does.

I suppose I could stop using the explore from the start bar, and just use the My Computer icon.  The only reason I got in the habit of using the "right click, explore" from the start bar is because if I have a lot of applications open, I don't have to minimize them all (or use show desktop) to FIND the my computer icon.

Anyway, if there are any additional suggestions about fixing the start bar - explore option let me know, otherwise I'll figure out how to divide up the points - the rest of the directory navigation is definitely much improved now.

0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12636449
you are facing slowness usign Explore option from start button
what if you use Open ??
0
 
LVL 2

Author Comment

by:krose777
ID: 12636460
If i use open it opens immediately and i can click on my computer and access my files from there.  It is three clicks to get to the drive, though it avoids the long pause...  I definitely have some viable options - still curious if anyone knows why the explore option is like a trip to FreezeVille.
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12636468
well what can i say.... the Explorer option takes around 10-15 seconds on my system also with the user account which i normally use..... but if i boot in safemode to use the Administrator account which has few programs.... it takes around 3-5 seconds!! :-?
0
 

Expert Comment

by:heliax
ID: 12737592
Agree, XP performance degrades heavily over time
0
 
LVL 1

Expert Comment

by:Prambo
ID: 12818929
I've had this problem for a while and just discovered the solution, at least in my case.
First I noticed that unplugging the network cable solved the problem and this suggested that Windows tries to resolve network paths every single time you right-click (go figure).
Anyway, because of this I looked at 'My Network places' and saw that there were a lot of mappings to other computers, even computers that weren't on the network anymore, I deleted these mappings and solved the problem. I guess the computers that weren't on anymore were the source to the problem, all these computers were automatically mapped by Windows by the way, I didn't add them myself.
Does anybody have a good answer to why explorer goes out on the network and tries to resolve paths when the path isn't even asked for?
0
 

Expert Comment

by:fmrsystems
ID: 13694029
I have the same problem with Windows Explorer opening very slow when using shortcuts to access it or even the explorer.exe.  2 intresting querks:
i can open IE and type c:\ and it access the file list immediatly and i can right click the start button select explore and it is immediate also.

i have no network drives mapped and no "My Network Places" set.  I have Adobe suite and Nero, i found comments that both of these can cause this problem but i couldn't solve it.

still looking...
0
 

Expert Comment

by:DouglasHolt
ID: 14177841
All,

  I have the exact same problem on my WinXP Pro box.  The problem ONLY happens when viewing the Folders tree.  As far as I can tell, it is due to the tree attempting to list all ZIP files as well as sub-directories.

  For whatever reason, Microsoft decided that ZIP files should be treated just like directories.  That's ok sometimes, but mostly very problematic.  Does anyone know how to disable this "feature"?  If so, I would bet good money that the slow directory listing problem would be resolved.

  Currently, as a work-around, I turn off the Folders view and then I can whip around through the directories using the Up button to go up, and double-clicking on the folder to drill down.  However, if I open the tree combo-box, the same problem shows up, for the same reason.

  Any ideas how to disable this feature would be awesome!!!
0
 

Expert Comment

by:DouglasHolt
ID: 14178950
Here's how to get rid of the real problem:  Prevent Windows Explorer from displaying zip files in the tree:

In the command prompt windows type regsvr32 /u zipfldr.dll and press [ENTER] Restart the computer. You'll no longer see .zip files show up as folders.
If you want the .zip files to show up as folders again, go back to the command prompt and type regsvr32 zipfldr.dll and press [ENTER]. Restart the computer. Your .zip files appear as folders again! "
'd this from a winxpnews article
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

One of the biggest challenges facing freelancers is balancing multiple projects and deadlines. Organizational skills and time management are key to keeping up with projects and staying on track. Luckily, we’ve curated seven tools to help you focus o…
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
Articles on a wide range of technology and professional topics are available on Experts Exchange. These resources are written by members, for members, and can be written about any topic you feel passionate about. Learn how to best write an article t…
Where to go on the main page to find the job listings. How to apply to a job that you are interested in from the list that is featured on our Careers page.
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question