[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 554
  • Last Modified:

3D Mark 05 Pro Won't Run

Hey! I just got 3DMark05 Proffessional, and I ran it, only to find this error message:

lDirect3DDevice9::CreatePixelShader failed: Invalid call (D3DERR_INVALIDCALL)

I have the newest graphics drivers and version of DirectX, as well. My system specs are as follows:

Manufacturer   Intel    
Family   Intel(R) Pentium(R) 4 CPU 2.80GHz    
Architecture   32-bit    
Internal Clock   2.8 GHz      
 Internal Clock Maximum   2.8 GHz      
External Clock   133.0 MHz      
Socket Designation   PGA 478    
Type   Central    
 Upgrade   ZIF Socket    
HyperThreadingTechnology   Available - Disabled    
Capabilities   MMX, CMov, RDTSC, SSE, SSE2, PAE    
Version   Intel(R) Pentium(R) 4 CPU 2.80GHz    
 Caches
Level 1    8 KB      
Level 2    512 KB      
 
 

DirectX Info
Version   9.0c    
 Long Version   4.09.00.0904    
 

--------------------------------------------------------------------------------

DirectDraw
Version   5.3.0000001.0904    
 Primary Device   NVIDIA GeForce4 Ti 4600    
 
Display Device 1/1
NVIDIA GeForce4 Ti 4600        Driver 6.6.9.3
 
Description   NVIDIA GeForce4 Ti 4600    
Manufacturer   NVIDIA    
Total Local Video Memory   128 MB      
Total Local Texture Memory   128 MB      
Total AGP Memory   128 MB      
Driver File   nv4_disp.dll    
Driver Version   6.6.9.3    
Driver Date   10-29-2004    
Driver WHQL Certified   true    
Max Texture Width   4096 px    
Max Texture Height   4096 px    
 Max User Clipping Planes   0      
Max Active Hardware Lights   8      
Max Texture Blending Stages   8      
Fixed Function Textures In Single Pass   4      
Vertex Shader Version   1.1    
Pixel Shader Version   1.3    
Max Vertex Blend Matrices   0      
Max Texture Coordinates   8      
VGA Memory Clock   661.5 MHz      
VGA Core Clock   300.4 MHz      
 
 
0
photon9
Asked:
photon9
1 Solution
 
photon9Author Commented:
(Although this is probably obvious, I forgot to say it) :)

Does anyone know what the problem is and how to fix it? Thanks :)
0
 
fennyrulesCommented:
You need a dx9 graphics card, which you do not have. It doesn't support the required pixel shader modes (and others) for 3dmark 05.

Fenny
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now