CDRom locks PC up

When I insert a games CDRoms into my CDRom player, my computer just locks up and I have to reset each time.
If I boot up with CDRom disc in the CDRom drive, it locks at first screen, if there is no CDRom disc inserted then it boots up fine. I have disabled boot up from CDRom in BIOS aswell.
No keys or mouse work.
All hardware is brand new in last few months.

Windows XP Professional (SP2 not installed)
Pentium 4 3.0GHz
512 Mb Ram
MSI  MS-7043 Motherboard
Maxtor DiamondMax Plus 9 120Gb 7200rpm
Saphire Radeon 7500
Creative Labs Audigy 2ZS Platinum Pro
MSI DVDRW
Samsung 52x CDRom

Someone suggested "Try going into the control panel, system, device manager, and unchecking the box marked DMA in the properties area for the cdrom...." but my resources tab is not available, or even there!

I have tried every configuration of DVD burner and CDRom in both Master and slave. I am down to HDD IDE 1 Master and CDRom IDE 2 Master, being the most basic option.
Still have the same problem of CDs freezing.
If I boot up with CDRom disc in the CDRom drive, it locks at first screen, if there is no CDRom disc inserted then it boots up fine. I have disabled boot up from CDRom in BIOS aswell.

One thing I have noticed is that in Device Manager, I have something called USB 2.0 Enhanced  Host Controller with a yellow warning.
I have tried uninstalling this device, and re-installing, but still the same.
I have updated my VIA chipset drivers aswell.

This is now becoming very frustrating indeed.
Swn-Y-MorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:
first : have you installed all the motherboard drivers?
Second : check the jumpers on the drives : are they set eg Disk = master, DVD = slave or Cable select? Do not mix those settings, set harddisk = master, dvd to slave. if you use 2 IDE cables, it does not matter if the dvd is master or slave. (you tried this so: skip it)
then :try to test the dvd drive on another system
it could be that you have more than 1 issue, so you can try to diagnose as much as you can :
memory :   try memtest86+ :    http://www.memtest.org/      
rest : try burnintest :   http://www.passmark.com/download/      
0
nobusCommented:
It could be a bad motherboard though, but still : success with the testing !
0
nobusCommented:
A last question : did it work normally for some time before this started? then probably it would be the dvd drive, or your mobo, which i do not wish you.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Swn-Y-MorAuthor Commented:
Yes, I checked the jumpers - OK.
Cannot test DVD drive in another system as I have no facility to do so. These issues were present right from day one. I put all the bits together myself!
I went over to memtest site, and to be honest - it didn't mean an awful lot to me??
0
Swn-Y-MorAuthor Commented:
It doesn't matter whether or not i use the CDRom on its own, or exchange it for DVD Drive - both freeze.
I suppose that proves that it isn't a particular drive.
0
Swn-Y-MorAuthor Commented:
How do I know if i have installed all the motherboard drivers?
0
nobusCommented:
Normally, the drivers come with the motherboard, but you can download the latest tdrivers at the manufacturers site also.
But in your case, here is what i would do :
start with this config :
mobo, harddisk as master on ide 0, cd rom os master or slave on ide 1 (other cable, other slot)
If this does not work, (cd rom locks up) try  this setup :
harddisk set as master, and cd-rom on the same cable as slave. If not working, swap with DVD RW drive set as slave.
this should work, or both your drives are bad, which is not logic.
As for the memtest, you have to download the program to  your disk, unzip it, and put it on a floppy, then BOOT FROM THE FLOPPY
0
Danny ChildIT ManagerCommented:
when you load the disk, before you close the drawer, hold down the SHIFT key on the left of the keyboard.  Then, close the drawer.  Don't release the key till the drawer has been closed for about 10 sec.  This bypasses the autoplay.  

If the disks work ok from this point, ie you can launch EXE's from Explorer, something's messed with your autoplay settings.  

Do you also get the same thing with music CDs?
0
rajeev_niceCommented:
Probably there is some problem with the BIOS Settings as well... check whether u have both IDE channels "ENABLED" and all ur Drives are detected properly in setup itself.

Secondly try to see if u have disbaled onboard USB Controller. The yello warning maybe coz of it.

try to load the default/optimal settings for ur board. I wud suggest u to reformat the drive if thats not much hassle to u and u have a backup of all ur data. After installing Win XP try to load the drivers as provided by the mobo vendor. The manual will sugest u how to load the drivers.

Since u mentioned that the Resources tab is not available... so it suggest some problem with ur mobo or IDE Drivers. One more thing... ensure that u have enabled "ACPI" in ur BIOS Setup and Device Manager.shows ACPI entries.

HTH

Rajeev
0
Swn-Y-MorAuthor Commented:
I tried the variations suggested by Nobus, (harddisk set as master, and DVD Burner on the same cable as slave.)
The disc worked for a couple of times. I then put CDRom on its own on IDE2, but lock up and freezing yet again.
I removed CDRom and still system locks up as it did originally.
I will investigate the BIOS settings suggested by Rajeev next.
Thanks so far.
0
Swn-Y-MorAuthor Commented:
Tried reseting BIOS to Default settings - No change.

BIOS settings checked - this is it basically :-

ONboard PATA - Enabled
USB Controller - Enabled
USB Device Legacy Support - Disabled
Internal SATA Controlloer - Disabled
OnBoard LAN Controller - Enabled
OnBoard LAN P.M.E. - Enabled
BootROM Function - Enabled

Set Super I/O

Floppy Controller - auto
Serial PortA Auto
Parrallel port - Auto
Parallel Port Mode - ECP

--------------------------------------------------------------------------------

Still cannot find drivers for USB 2.0 Enhanced  Host Controller - it says this :-

This device cannot start. (Code 10)

How do I carry out a 'hardware refresh' without rebooting?

0
Swn-Y-MorAuthor Commented:
Rajeev,

Checked BIOS for ACPI, but could not find a mention of this anywhere.
There are entries in device manager -

ACPI Multiprocessor PC - This device is working properly

Microsoft ACPI-Compliant System - This device is working properly
driver details - \System32\DRIVERS\acpi.sys
0
Swn-Y-MorAuthor Commented:
Yes, that's my board. Downloaded the drivers as suggested, but they are the same version as the ones on my disc.
I have now downloaded Windows XP SP2, and this hasn't made any difference either.
0
nobusCommented:
you could hook the disk drives on ide 0 connector, and the cd drive to the ide 1 connector and test
0
Swn-Y-MorAuthor Commented:
Tried that, with no joy.
I will reformat HDD now I think.
0
Swn-Y-MorAuthor Commented:
Sorry Nobus,
what is a Zero Fill Utility?
0
nobusCommented:
that is a utility supplied by the manufacturer of the drive, which can test the drive, and restores it to its "new" state by writing zeros all over the drive (takes time though)
If you post the drive modeln i can point you to it, now i gave all the links to the different manufacturers
0
Swn-Y-MorAuthor Commented:
Thanks,
My HDD is a Maxtor DiamondMax Plus 9 120Gb 7200rpm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Swn-Y-MorAuthor Commented:
Hi, I'm back again.
Just to fill you in with the details.
I formatted my HDD and reinstalled everything.
Drives no longer lock up - however - my DVDRW doesn't burn CDRs or DVDs - it plays CDRoms fine.
Everything looks OK in device manager.
tried reinstalling the driver, but Windows says it is using the best one.
0
Danny ChildIT ManagerCommented:
any problems in the event log relating to the IMAPI burning service?

have you tried this drive in a different machine?  Often, failing drives complain about DVDs and CDRs first...
Danny
0
nobusCommented:
so, th USB problem is solved? and what software are you using for the burner? Nero or Roxio?
0
Swn-Y-MorAuthor Commented:
Software I am using is Nero.
In Task manager it sometimes shows 2 istances of imapi burning process in operation.

No, USB is still the same in Device Manager (Yellow Triangle) although the ports appear to be working fine - not sure at what speed though?
0
Swn-Y-MorAuthor Commented:
Danny - I wouldn't know how to obtain an event log relating to the IMAPI burning service.
0
nobusCommented:
did you install the motherboard drivers? if not, get them here and instalml them:

http://www.msi.com.tw/program/support/driver/dvr/spt_dvr_list.php?part=1
0
Swn-Y-MorAuthor Commented:
Thanks for the link.
I installed drivers as suggested, but it has made no difference at all.
0
nobusCommented:
a last thing to try : connect the disc to IDE 1 and the DVD to IDE 0 and test
0
rindiCommented:
Swn-Y-Mor,

No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
Accept: nobus

Any objections should be posted here in the next 4 days. After that time, the question will be closed.


Rindi
EE Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.