[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3915
  • Last Modified:

Prob w outbound SMTP via DirecPC to EarthLink mail server from Outlook mail client

Gentlemen,

I have a customer who is recently having problems sending email using MSFT Outlook, starting on 17-Nov-04.  Her connection to the internet is via DirecPC, but her email account is with EarthLink.

Up until recently, she has been able to send mail through this mailhost swimmingly, regardless of whether she was using a wired or wireless network over DirecPC, or using dialup networking into EarthLink central.

More recent history has been a different and undesirable experience. The symptom is a timeout.

I've done some problem isolation.  The smtp port at the EarthLink mailhost can be connected to using either Outlook or Telnet.  Using Telnet, I do get a greeting from the EarthLink mailhost, so the SMTP protocol does indeed flow unencumbered.  Also, I've been sending email from her computer to my email address via this path, and one message made it through (although the response was that all sent messages had failed).

I've chatted with a technical support representative of EarthLink about what possible changes there may have been with the EarthLink network or mailhost.  He or she said (typed) that the problem is with DirecPC, not with their mailserver, and that we'll need to (re)configure outbound email to go through the DirecPC mailhost.  This conclusion was supported by the fact that the sending of mail when connected via dialup does work.

Does anyone have any thoughts on any of this, or am I just barking up the wrong tree?


0
ChrisEddy
Asked:
ChrisEddy
1 Solution
 
Ron MalmsteadInformation Services ManagerCommented:
During the setup process (POP3 mail wizard)...on the screen where you put in the mail server address and username and password...> there is a button (more settings)....click it.....then click (outgoing server) tab...check the box that says "my outgoing server requires authentication".......

good luck.
0
 
ChrisEddyAuthor Commented:
Thank you for responding!

I've done that.  A correct userid and password is entered for the outgoing SMTP email server, SPA is not enabled, and ssh is not enabled.  All proper according to the EarthLink email configuration specs.

Next ...


0
 
SembeeCommented:
Pretty sure that the resolution you were given about using the ISPs SMTP server is the correct one. More and more of the ISPs are no longer allowing residential users to connect to other SMTP servers. Even with authentication and other tricks.
I would simply switch the SMTP server for outbound email to the SMTP server of DirecPC. If the email still doesn't go then it is an issue that you need to take up with DirecPC. Perhaps they don't allow email to be send through their server unless it is coming from an email address they recognise. While a particularly harsh way to operate an email system, not uncommon.

Simon.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
ChrisEddyAuthor Commented:
Here's the results of a telnet to port 25 of the earthlink mail server:

  telnet mail.earthlink.net 25
  Trying 207.217.121.217 ...
  Connected to pop07.earthlink.net (207.217.121.217)
  Escape character is '^]'
  220-pop-a065d23.pas.sa.earthlink.net ESMTP Exim 3.33 #1 Sun, 21 Nov 2004 11:35:31 -0800
  220-NO UCE.  EarthLink does not authorize the use of it's computers or network
  220 equipment to deliver, accept, transmit, or distribute unsolicited e-mail.
  EHLO [my email address]
  250-pop-a065d23.pas.sa.earthlink.net Hello [my reverse resolved host name] [my ip address]
  250-SIZE 10485760
  250-PIPELINING
  250 HELP

This is a positive indication that I've reached the mail server, duplicating my initial test.  

However it isn't necessarily an indication that an email message can be sent.  The symptom I'm getting from Outlook is a timeout, suggesting that there is some sort of time delay at end-of-the-message time that exceeds a number, which is the failure.  

Next is to bone up on my SMTP and hand craft a message typed into the EarthLink mail server, and seeing what happens.  


0
 
SembeeCommented:
Getting the connection isn't enough as you have guessed. If they are only allowing messages through that meet their requirements, then it will allow the connection, it is only when you actually try to send a complete message that you will see if that is the problem. I am surprised they aren't NDR the emails though.

Google for SMTP Telnet test to find the commands that you need. I can never remember them either so will usually just look someone else who has them already.

Simon.
0
 
ChrisEddyAuthor Commented:
Gentlemen,

Thank you for the pointer to a very useful shortcut!

I have completed the telnet test as directed, and the results indicate the reason why EarthLink is declining the email: relaying a message from outside the EarthLink network is declined.

Here *are* the results of the telnet test to port 25 of the EarthLink email server:


telnet mail.earthlink.net 25
  Trying 207.217.121.209...
  connected to pop14.earthlink.net (207.217.121.209).
  Escape character is '^]'.
  220-pop-a065c05.pas.sa.earthlink.net ESMTP Exim 3.33 #1 Sun, 21 Nov 2004 17:18:32 -0800
  220-NO USE.  Earthlink does not authorize the use of its computers or network
  220 equipment to deliver, accept, transmit, or disribute unsolicited e-mail.
ehlo earthlink.net
  250-pop-a065c05.pas.sa.earthlink.net Hello [my reverse resolved host name] [my ip address]
  250-SIZE 10485760
  250-PIPELINING
  250 HELP
mail from:[my email address within earthlink]
  250 <[my email address within earthlink]> is syntactically correct
rcpt to: [my target email address]
  550-EarthLink does not recognize your computer ([my ip address]) as connecting from an EarthLink conneciton.  If this is in error, please contact technical support.
  550 relaying to <[my target email address]> prohibited by administrator
data
  503 Valid RCPT TP <recipient> must precede DATA

  421 pop-a065c05.pas.sa.earthlink.net: SMTP command timeout - closing connection
  Connection closed by foreign host.


As can be seen by the test results above, the root of the problem is a relay denied error currently being reported by EarthLink.  Whether this was a recent change on the part of EarthLink or not is irrelevant, but unfortunately apparently coincident with the fact that I recently configured a new wireless network for my customer, and now she's reporting email sending failures.  The fact that Outlook does not return the actual error text, but instead reports some unhandled error and number is unfortunately misleading, and may be due to the fact that the mail server does eventually timeout because Outlook doesn't handle enough of the failure cases - such as this one.

Thank you all for your suggestions and guidance!  I now have real data on which to base a recommendation.  


0
 
willyjd1Commented:
Configure your clients mail program to use outbound SMTP authentication.  Earthlink will not accept mail from hosts that are not directly connected to their network without the authentication.  The username would be your customers email address and the password would be the same as the POP3 authentication.

I fought this problem before with Earthlink.  Took a couple of live support chats to get them to cough up the info about the authentication.

The fact that you were able to test via telnet proves that DirecPC is not doing anything that would affect your connection.

Will
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now