Apache not recognizing httpd.conf commands

I have just upgraded from apache 1.3.28 to apache 1.3.33 with mod_ssl. When I try to start the new apache, I get errors like this:

Syntax error on line 333 of /www/conf/httpd.conf:
Invalid command 'Order', perhaps mis-spelled or defined by a module not included in the server configuration
/www/bin/apachectl start: httpd could not be started

And this happens for a variety of commands in httpd.conf like Order, Allow, LogFileFormat, etc that all worked fine in 1.3.28.

I configure apache from the mod_ssl source directory using this command:
./configure --with-apache=/usr/local/src/apache_1.3.33 --with-ssl=/usr/local/src/openssl-0.9.7e --prefix=/www --enable-module=ssl --enable-module=all --enable-shared=max --enable-rule=EAPI
 
Then, I do a "make" then "make install" in the apache source directory. Then I try to start it with "/www/bin/apachectl start" and I get that error.
beckledeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

periwinkleCommented:
Check to see if there is a closing brace from before that line....
0
beckledeAuthor Commented:
httpd.conf is fine. It works with the older apache, and errors occur on a variety of lines with the new apache.
0
periwinkleCommented:
If you are receiving those errors, it would seem that the new version of apache is unhappy with something that the old one was able to deal with...

Did you run apachectl configtest to see if you get anymore information?
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

periwinkleCommented:
FWIW, from the error, it sounds like support for a certain module hasn't been created in the new version that was in the old one, or that you have compiled for static module support when dymanic is called for (or vice versa).  Try commenting out modules 1 by 1 to see which one is the one that is in error.  Is there any more information in the error_log?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
beckledeAuthor Commented:
Thanks. Nothing new from configtest or error_log. I've tried misc. module removal, with no luck.Any other ideas? It would seem that a module is missing.
0
Alex EneCommented:
could you paste the lines from 320 to 340 from /www/conf/httpd.conf ?
we have to see what exactly apache doesn't like from that file.

Regards,

Alex.
0
periwinkleCommented:
Alex - I agree.
0
beckledeAuthor Commented:
I think I got it fixed. --enable-sharing=max during config was screwing it up. Here's the line that ultimately worked:
./configure --with-apache=/usr/local/src/apache_1.3.33 --with-ssl=/usr/local/src/openssl-0.9.7e --prefix=/www --enable-module=ssl --enable-module=most --enable-shared=so --enable-rule=EAPI

Thanks for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.