Exchange users cannot login to OWA

Hi All.

I'm setting up exchange at home before I set it up at work. OWA works for me. I am the domain administrator. However for the 2 users I've set it up for, they cannot login to OWA. The prompt comes up for the usersname and password, when I enter it it just pops up again and again, until i hit cancel. I am using the default clear text authentication.

I thought it might have something to do with the users not having the rights to login locally, but now that i think about it, i think it will login with the IIS account anyway.

Anyone have any ideas or pointers?

Thanks,
Justin
LVL 1
justinm99Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Exchange_AdminCommented:
I think the users need to have the "Log on Locally" right to access OWA.

Try this to see if it works.
0
justinm99Author Commented:
Yes, I have allready done this. Still no luck.
0
justinm99Author Commented:
Some more info: I have a front end and back end configuration. I have given the logon locally rights to the front end server, and I have just given it to the back end server.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

justinm99Author Commented:
Just to test it out, I logged into the front and and back end servers locally with the user. The user logged in successfully on both servers.
0
David WilhoitSenior Consultant, ExchangeCommented:
what message are you getting when  you login with the user? It sounds like something else, like the everyone group got removed or the RUS isn't stamping the user objects with a proxy address. HAve you checked to see that the user objects have an email address?

D
0
justinm99Author Commented:
here is the message i get after trying to login 3 times:
HTTP/1.1 401 Unauthorized

I do not use a proxy server, but I have the front end and back end servers behind an openbsd firewall. The firewall isn't the problem from what I can tell because I can login from outside.

When you say the everyone group got removed can you be a bit more specific?

Also the front end is win2k3 and the back end is win2k, will this cause problems?

Thanks for commenting kidego!
0
justinm99Author Commented:
oh yea, the user accounts all have email addresses.
0
justinm99Author Commented:
I think it may have something to do with the fact that my front end server is on windows 2003, and my back end server is on windows 2000. I can't think of much else. I may just format the front end server and put win2k on it. The back end server is also a windows 2000 domain controller.
0
David WilhoitSenior Consultant, ExchangeCommented:
as long as win2k is sp4, e2k3 should be fine, the FE is exchange 2003 too, yes? I don't see an exchange version here...

D

0
justinm99Author Commented:
yes, they are all exchange 2003 enterprise. win2k is SP4 as well.

what should I do?
0
justinm99Author Commented:
Most interesting, I tried adding a user to the domain admins group, then logging in to OWA.

It still doesn't work! This must mean it isn't a permissions issue. There must be something wrong with the user account.
0
justinm99Author Commented:
Ok I created a new account called jtest, with the default email account. It worked!

OWA won't work for user jared, who has an email address of cbr@n0de.ws. I will create a secondary address as jared@n0de.ws and see if that works right now.

it did not work.

I tried for user renny, who has an email address of renny@n0de.int (n0de.int is my internal domain, n0de.ws the external) and it worked.

The problem has something to do with email addresses.
0
justinm99Author Commented:
Ok so the problem was with aliases, I created a user named cbr with the same alias, and it worked fine.

My one question now is how can i change a users alias?
0
David WilhoitSenior Consultant, ExchangeCommented:
do you have the domain n0de.ws listed in the recipient policy, and is it your primary SMTP address?

d
0
justinm99Author Commented:
Yes to both.
0
David WilhoitSenior Consultant, ExchangeCommented:
ok, that's good. Have you checked the policy on the FE server? And have you tried to access OWA directly to the backend server, without going thru the FE? link internally would be http://server/exchange , no secure HTTP on the backend server. If you enabled 443 on the backend server, take it off, it should only be on the front end.

d
0
justinm99Author Commented:
Kidego, thank you for your suggestions.

Maybe you should read my comments. I indicated that I got it all working, except I don't know how to change aliases. for example create a username called Justin, with an alias of justin. Then after I create justin and his mailbox, how can i Change the alias? (maybe I want his email address to be jsmith@n0de.ws).
0
David WilhoitSenior Consultant, ExchangeCommented:
ok then, the alias is the UPN that gets created, and that's not the email address. The email address will be stamped by the RP once the RUS updates itself. So, a UPN of justin@domain.local, would not be the same as jsmith@n0de.ws. The latter gets stamped on when you mail enable the user and the RUS updates.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
justinm99Author Commented:
I think this is a separate question. It seems I figured this out on my own, but since you all helped i will split the points.

Thanks!
0
justinm99Author Commented:
Just gave it to kidego because he spent more time trying to solve it, thanks again guys.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.