WebReports recompilation uder iAS Linux

Hello,

I am in the process of deploying my Forms/Reports Oracle 9i application over Forms/Reports Services 10g running on my Linux Server.

During the development on my Oracle 9i iDS under Windows XP Pro, my Parameter Forms appear normal. In other words, I can invoke my WebReports from my WebForms through the Parameter Forms without problem.

Migrating my Forms/Reports application over the Web on my Linux server and running my application under Oracle Forms/Reports Services 10g on a LInux server , I noticed that my Parameter Form are missing some fields (???)

The parameter names appear on the left hand side, but the fields and values on the right side are missing for most parameters.
   
During the Linux Migration to the Web, I recompile my forms from fmb to fmx and run them on them Web.
However, my WebReports, I run the *.rdf files. I did not recompile my Reports on Linux. On the iDS, I run the Report *.rdf files. Reading Oracle documentation, all the given examples use/run the *.rdf files.

I recompiled my forms using the f90gem.sh utility.

1) Should I recompile my reports as *.rep files ?
2) Why is only the last Parameter Form Field appear on the WebReport and not all other fields ?

PT
ptrevesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

makhanCommented:
Hi,

There might be problems due to font size / screen size mismatch.

Regards,

makhan
0
ptrevesAuthor Commented:
Hello,

How can I go about resolving these issues ?

Paolo

PS: I deployed my Forms/Reports 9i application on Forms/Reports Services 10g on my Linux Red Hat Enterprise 3 (ES) server.
0
ptrevesAuthor Commented:
Hello again,

Let me just add, that when I press the Parameter Form 'Submit' button, I cannot invoke my corresponding WebReport. I get a Page cannot be displayed and a URL making reference to the setauth attibute/parameter.

1) How can I go about invoking my WebReports ?

Paolo
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

makhanCommented:
Sorry,

I do not have any more suggestions right now. will post if I get something.

Regards,

Makhan.
0
ptrevesAuthor Commented:
Hello,

Only one of the controls appears on the right hand side and is a combodox with 2 line entries not one. Looking at the source code under iDS, I find that it is a Parameter Form Field of type Number. All other controls are of type Character.

1) Can this be the cause of the problem ?

PT

PS: How can I adjust my font/screen settings on my secondary WebReports Browser windows to have a valid Parameter Form/Report (on Windows 98SE) ? (like on Windows XP Pro iDS)
0
makhanCommented:

>> I get a Page cannot be displayed and a URL making reference to the setauth attibute/parameter.

Could u post the exact error message.

>> PS: How can I adjust my font/screen settings on my secondary WebReports Browser windows to have a valid
>>       Parameter Form/Report (on Windows 98SE)

Please check out formsweb.cfg in your ORACLE_HOME/forms90/server.
0
makhanCommented:
Hi!

Check out registry.dat
Location: formsxx/java/oracle/forms/registry

This file allows you to change the default font, font mappings, and icons that Forms Services uses

Regrds!
0
ptrevesAuthor Commented:
Hello,

Well, I get a logon screen prompting me for the username/password/database information with a 'Submit' / 'Cancel' buttons. At the botton of that logon screen is an error message:

REP-51018

Pressing 'Submit' after entering valid values, I get a new Browser windows saying "Page Cannot be displayed" with the following URL:

http://linux2005.katz.qc.ca:7780/reports/rwservlet/setauth

=====
I realised that the environment variable REPORTS_CLASSPATH was not set on my Application Control environment file (default.env). I tried rerunning my application over the web and adjusting my Width/Heigh to default values (width=650, height=500) with the same results.

Any ideas ?

PT
0
ptrevesAuthor Commented:
Hello,

On my logon screen this is the exact error mesage that I get:

REP-51018: Need database user authentication

PT

PS: Hope this helps....
0
ptrevesAuthor Commented:
Hello,

Are there any particular parameters I should be looking at in the Registry.dat and the formsweb.cfg file with regards to the missing Paper Parameter Form Fields ?

PT
0
makhanCommented:
PT!

I do not have any more suggestions as I do not have access to 9ias right now.

Regards!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ptrevesAuthor Commented:
Hello,

Actually, it it Forms/Reports Services 10g.

PT
0
makhanCommented:
Yes! I understand.

I was on 9i a few months ago and things are quite similar... It is just that I am too busy to get the whole thing re-installed and help u out. Sorry!

Regards!


0
ptrevesAuthor Commented:
Hello,

I reinstalled Forms/reports services 10g with the required JVM 1.4.2.2 instead of JVM 1.3.1.1 and this has resolve my missing fields under the Web Parameter Forms.

However, I cannot invoke my WebReports from my WebForms ?

PT
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.