startx results in "Cannot find a free VT" on my Virtual Dedicated Server from my home machine

Posted on 2004-11-21
Last Modified: 2013-12-27
hi !

I have a Virtual Dedicated Server with root access, based on Redhat 9.0.
I installed Xfree86 without problems.

Now, using X11 on my home machine (an apple OS X), i open an ssh session with X11 forwarding (ssh -X to my VDS. It works fine : xclock, xemacs, X applications work correctly on my screen.

But when i try to use 'startx' to be able to use e.g. the Gnome environment , i get the following errors
Fatal server error:
xf86OpenConsole: Cannot find a free VT

I have tried with the root user, and with other users. I have played with /etc/inittab to no avail. Here is a portion of :etc/inittab
x:5:respawn:/etc/X11/prefdm -nodaemon
0:2345:respawn:/sbin/mingetty ttys/0
1:2345:respawn:/sbin/mingetty ttys/1
2:2345:respawn:/sbin/mingetty ttys/2
3:2345:respawn:/sbin/mingetty ttys/3

And here is ls -l on /dev
crw-r--r--    1 root     root       1,  10 jan  1  1970 anon
crw-------    1 root     root       5,   1 nov 22 04:04 console
drwxr-xr-x    1 root     root            0 jan  1  1970 discs
crw-rw-rw-    1 root     root       1,   7 jan  1  1970 full
prw-------    1 root     root            0 nov 22 03:48 initctl
crw-r-----    1 root     root       1,   2 jan  1  1970 kmem
srw-rw-rw-    1 root     root            0 nov 22 03:48 log
crw-r-----    1 root     root       1,   1 jan  1  1970 mem
drwxr-xr-x    1 root     root            0 jan  1  1970 misc
drwxr-xr-x    1 root     root            0 jan  1  1970 net
crw-rw-rw-    1 root     root       1,   3 jan  1  1970 null
crw-r-----    1 root     root       1,   4 jan  1  1970 port
crw-------    1 root     root     108,   0 jan  1  1970 ppp
crw-rw-rw-    1 root     root       5,   2 nov 22 04:07 ptmx
drwxr-xr-x    2 root     root            0 nov 22 03:48 pts
drwxr-xr-x    1 root     root            0 jan  1  1970 pty
crw-r--r--    1 root     root       1,   8 jan  1  1970 random
lr-xr-xr-x    1 root     root            5 nov 22 03:48 root -> ubd/0
lr-xr-xr-x    1 root     root            3 jan  1  1970 serial -> tts
drwxrwxrwt    2 root     root           40 nov 22 03:48 shm
drwxr-xr-x    1 root     root            0 jan  1  1970 tts
crw-rw-rw-    1 root     root       5,   0 jan  1  1970 tty
lr-xr-xr-x    1 root     root            2 jan  1  1970 ttys -> vc
drwxr-xr-x    1 root     root            0 jan  1  1970 ubd
crw-r--r--    1 root     root       1,   9 nov 22 03:48 urandom
drwxr-xr-x    1 root     root            0 jan  1  1970 vc
crw-rw-rw-    1 root     root       1,   5 jan  1  1970 zero

And ls -l on /dev/ttys
crw-------    1 root     root       4,   0 nov 22 03:49 0
crw-------    1 root     root       4,   1 nov 22 03:49 1
crw-------    1 root     root       4,   2 nov 22 03:49 2
crw-------    1 root     root       4,   3 nov 22 03:49 3
crw-------    1 root     root       4,   4 jan  1  1970 4
crw-------    1 root     root       4,   5 jan  1  1970 5
crw-------    1 root     root       4,   6 jan  1  1970 6
crw-------    1 root     root       4,   7 nov 22 03:49 7

 Please help me find a way to have this work !

Thank you

Question by:safarlebus
    LVL 38

    Expert Comment

    > using X11 on my home machine (an apple OS X), i open an ssh session with X11 forwarding (ssh -X
       to my VDS
    >  i try to use 'startx' to be able to use e.g. the Gnome environment
    You mean you run "startx" inside X-window?
    You won't get the Gnome-seesion running inside X-window
    (Gnome is kind of X-window manager which X-window run inside it).

    If you want to get "the Gnome which runs on RedHat Linux 9 box" to you Mac OS X, then "vnc" is the one.
    Run vncserver on the RedHat Linux 9.0 box, then use vncviewer on the Mac OS X to connect it.
    Say, ssh into RedHat 9 box and run
    -- RedHat 9 ---
    $ vncserver    <---- first time will ask you to type in password twice
    .... display :1   <--- may be :2, :3 or other number

    ---- Mac OS X --- (with VPN connection first)
    $ vncviewer <IP or hostname of RedHat 9>:1  <--- the display number you get when you run vncserver above

    Then you will see the Gnome in vnc.



    Author Comment

    thank you for your suggestion.
    I did as you suggested : downloaded, compiled and started vncserver, and use Vncthing (a Mac OS X aqua standard vnc client) to connect to the vncserver on my redhat box.

    Everything worked ok... but what i see in my vnc client is just another terminal window, which gives the exact same error message when i try to have it run 'startx'
    LVL 38

    Expert Comment

    > in my vnc client is just another terminal window, which gives the exact same error message when i try to have it run 'startx'
    Do you see "Gnome" in your vncviewer? If not, then ssh into the Linux box and
    # cd ~/.vnc
    # vi xstartup
    then replace "twm" with "gnome-session"
    # vncserver
    And connect vnc again.

    What your vnc client see is a X-window manger, you can not start another X-window manager (startx) in it (this X-window

    However, you should be able to install vncserver from RedHat 9 CDs which use "gnome-session" by default.


    Author Comment

    well actually, trying "gnome-session", i just realised i did not have Gnome installed. How could i install it ? I have a VDS, not a home machine : i have no access to cds, etc..., and my disk space is limited to 4 GB

    LVL 38

    Accepted Solution

    Go the the following URL and download all the gnome rpm files (search keyword gnome, not just start with "gnome"):
    You can skip the "devel" rpm files to save space.

    The do as root
    # cd /tmp/gnome   <--- assume you download to /tmp/gnome
    # rpm -ivh *.rpm
    If missing any package, then download from the same URL and then try again.


    Author Comment

    thank you... i understand better. I have spent a lot of time, and have decided not to use Gnome because it would be so heavy (i have only 4 GIG)


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    In tuning file systems on the Solaris Operating System, changing some parameters of a file system usually destroys the data on it. For instance, changing the cache segment block size in the volume of a T3 requires that you delete the existing volu…
    Introduction Regular patching is part of a system administrator's tasks. However, many patches require that the system be in single-user mode before they can be installed. A cluster patch in particular can take quite a while to apply if the machine…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    This tutorial goes over how to archive and restore FreeBSD jails that are managed by ezjail.

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now