• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 197
  • Last Modified:

FTP or HTTP: Neither Works!

Hello, I have a website I created in FrontPage. It includes a link bar and form submissions. When I upload via. FTP, the link bar works fine, but I'm told FP extensions aren't installed properly when I try to submit a form. On the other hand, if I upload via. HTTP, I can submit a form fine, but my link bar becomes text instead of icons.

I have tried reinstalling extensions and completely deleting all files and re-uploading, but nothing seems to work. Any ideas would be greatly appreciated.
0
yardgames
Asked:
yardgames
  • 17
  • 15
1 Solution
 
hhammashCommented:
Don't use FTP if you want Frontpage to work properly.  Use Frontpage's Publish.

File > Publish

Publish knows what to send to the web server,  specially if you have something that needs server extensions to be sent to the web server.

hh
0
 
yardgamesAuthor Commented:
I specifically said in my question I've tried it both ways. When I publish via. FrontPage, the forms, as I stated, do work fine, but the navigation bar displays as text instead of the image bar I have chosen. That was why I originally decided to try via. FTP.
0
 
hhammashCommented:
Hi,

It is not a big deal, don't get angry,  I don't refer to Frontpage Publishing as HTTP publishing,  this is why I mentioned Publish.

You mentioned reinstalling extensions.  Did you uninstall first?  You have to uninstall the extensions then reinstall them after that.

hh





0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
yardgamesAuthor Commented:
Sorry for the ange rin my last post. I have a bad cold and I'm a bit frustrated.

Anyway, ironically the extensions weren't installed in the first place, so when I went to re-install them, I was actually installing them for the first time. I thought that may have been my problem, but it was after that that I completely deleted everything and re-published via. FrontPage. That's when, of course, the forms worked, but the link bar didn't. I then proceeded to publish just the needed HTML pages with FTP, and then of course, the link bar worked, but the forms didn't.

Thanks for your help.
0
 
hhammashCommented:
Hi,

Since you did FTP to publish just the needed HTML there is a possibility that you FTP corrupted the extensions.  You might need to uninstall and reinstall anyway before trying anything else.

This is really Strange,
You have your Webiste locally and working fine
You have a server with FPSE installed
You published the site
All these should ensure a proper working website.

When you say that the link bar did not work.
- It is disappeared
- You do not see the theme features (pictures and background)
- It is appearing but is not functioning

Try this first:
--------------
After you publis your website,  open your website live, then try the forms and make sure that the forms are working. Then:
- Delete the Link bar
- Save the web
- Close the web
- Open the web Live again
- Redo the Linkbar Live

Or
----
- Make sure that the website witht he link bar works perfectly locally
- Delete all files from the web
- Uninstall the server extensions
- Reinstall the server extensions
- Publish the website completely

Do not FTP at all.

Let me know what happens.

0
 
yardgamesAuthor Commented:
Thanks for the ideas. I'll be trying each of them very soon. I just want to let you know that you can expect a reply in the next day or so, I really appreciate one post with many suggestions for me to try, that makes my life a lot easier.

I mean, the link bar is displayed, but not with the theme, instead it's text.

Thanks again for your help, I'll get back to you soon.
0
 
hhammashCommented:
Ah,  OK,

Do the hyperlinks work anyway?  Even though the theme is not appearing?

This guy had the same problem.  Check it out in his last post.

http://www.frontpagewebmaster.com/m-229156/tm.htm


Regards
hh
0
 
yardgamesAuthor Commented:
Hello,

I tried the second option, in which I deleted all files, then uninstalled and reinstalled the extensions, as the first option kept causing my connection to time out.

Unfortunately, I'm still having the same problem. I'm about to take a look at the hyperlink you supplied me with to see if that can help me.

Yes, the links themselves work, although the theme is not appearing. You can see for yourself if you'd like:
www.futuretechnologiesinc.com

Thanks for your help, I'll be in touch after I have a look at that link.
0
 
yardgamesAuthor Commented:
Thanks for the idea, but I'd rather use FP navigation. I've never had a problem with it before, I'm sure there's a way to make it work right and I don't want to mess around with the includes.
0
 
hhammashCommented:
OK,

Which type of link bar did you create?  I think that you link bars lose the correct hyperlink to the picture when published to the web.

Did you use:
- Bar with custome links
- Bar with back and next links
- Bar based on navigation structure

Thank you

0
 
yardgamesAuthor Commented:
I used a bar based on the navigation structure; Child Pages Under Home, plus the home page.
0
 
hhammashCommented:
When you published the website,  did you see pages called top_old.htm,  left_old.htm in _borders folder.  If yes,  delete top.htm, left.htm, bottom.htm and rename those ones by removing _old,  i.e rename them to left.htm, top.htm and bottom.htm.

If you do not see the _border folder:

- Tools
- Web settings
- Advanced

Then check View Hidden Files and Folders

If you did that and it did not appear,  activate the shared borders.

Thanks
0
 
yardgamesAuthor Commented:
I see the folder, but there is just one copy of each shared border, bottom.htm, left.htm, and top.htm and some other graphic files, and a Thumbs.db file and that's all that's that folder.
0
 
hhammashCommented:
OK,

When you try your web locally you can see the pictures right?

Now try this:

- Open the web live
- Rename the files that are in Borders from left.htm to Aleft.htm ...etc.
- Rename _borders to _bordersback
- Do not create any new page now
- Close the web
- Go to your computer and publish your web
- Then try.

Let me know what happens.

hh
0
 
yardgamesAuthor Commented:
Ok, what that did was change my top and left borders to text, and eliminate my bottom one completely. For all pages except the home page, it takes all my links in the left border and moves them to the top of the page.
0
 
hhammashCommented:
did you rename top and bottom too?

Let us try this:

On your local computer add a new page called Testing.htm to _borders folder.  Then publish your web.  I want to see if your local _border folder is being published.

Then open your web live and see if Testing.htm is there

hh

0
 
yardgamesAuthor Commented:
Yes, the testing page was uploaded, and yes I renamed the top and bottom, in addition to the left.
0
 
yardgamesAuthor Commented:
I'ved upped the point value on this question, can someone else please assist me?
0
 
hhammashCommented:
Hi,

Since your link bar works fine locally with picuters and works  fine  live without pictures,  I am sure that the path to the pictures is changed when you published your website.  This happens somtime.  This is why the pictures are not visible.

Try this:
----------
- Open your website live
- Open _borders folder
- Delete all pages in it
- File > Import > Add file and  import the pages from your local _border folder
- File > Import > Add file and select the one of the .htm ,  let it be the index.htm or default.htm and try it

hh



hh
0
 
yardgamesAuthor Commented:
No, unfortunately that idea didn't work either. Just for laughs, I tried doing the same thing with the _themes folder, and that didn't help either.
0
 
hhammashCommented:
Hi,

Do you have _themes folder in your live web?

hh
0
 
hhammashCommented:
Hi,

What does your LinkBar WebBot says,  in your page?

I selected the barcode theme and I am getting this:

<!--webbot bot="Navigation" S-Orientation="horizontal" S-Rendering="graphics" S-Theme="barcode" S-Type="children" B-Include-Home="FALSE" B-Include-Up="TRUE" -->



hh
0
 
hhammashCommented:
Do you have the _overlay folder?
0
 
yardgamesAuthor Commented:
Hello,

Yes, I have the _themes and _overlay folders in my live web.

The linkbar webbot says:

<!--webbot bot="Navigation" s-orientation="vertical" s-rendering="graphics" s-theme="Journal 0110" s-type="top" b-include-home="TRUE" b-include-up="FALSE" --></p>

I should mention that's the local version, the live version says the same thing.
0
 
hhammashCommented:
Hi,

Did you get the theme from Outside Frontpage?

hh
0
 
yardgamesAuthor Commented:
I'm not familiar with Outside Frontpage...so I guess not!
0
 
hhammashCommented:
Hi,

Which version of Frontpage are you using?

I have Frontpage XP but I do not have the theme that you have "Journal 0110".  Did you modify a theme and renamed it?

Thanks
0
 
yardgamesAuthor Commented:
I have Frontpage 2003, the theme I used came with the product.
0
 
hhammashCommented:
Ok,

I'll try it on my laptop and see.  I am positive that the path to the pictures is lost.

hh
0
 
hhammashCommented:
Hi,

Try and select child level and see what happens.

hh
0
 
yardgamesAuthor Commented:
You're right! That fixed it, so that must have been the problem. I was then able to put it back to child pages under home and everything displayed properly.

Thanks so much for your help, everything's working great now.
0
 
hhammashCommented:
Ahhh,

At last,  I am happy it worked.

Glad I could help.

0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 17
  • 15
Tackle projects and never again get stuck behind a technical roadblock.
Join Now