FDISK

I am trying to partition a slave hard drive in my desktop. It is 160mb in size. When I run FDSIK and go to change to disk 2. I notice that the availbale space is 69%. Is this normal?
sufaboomaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

griesshCommented:
Hi sufabooma,

If you are running Win98 this might be your problem: http://support.microsoft.com/default.aspx?scid=kb;en-us;263044

=====
Werner
0
sufaboomaAuthor Commented:
I am not runnung WIndows 98 i am running XP Pro.
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Can you clarify - 160 Megabytes or 160 GIGAbytes?  What Operating system?  If 160 GB, then it's possible there's a BIOS problem recognizing the full capacity of the drive.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

sufaboomaAuthor Commented:
160gb. Windows XP Pro. How do I confirm that it is a BIOS problem? The PC is about 4 years old DELL P3 866mhz.
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
almost certainly a BIOS problem - 4 year old PCs have no idea how to talk to drives over 160 GB.  Go to Dell's support site and look for a BIOS upgrade for your computer.  Upgrade your BIOS and that MAY solve the problem.  XP also has a 128 GB limitation that is SUPPOSED to be resolved by SP1.  I'll post the link to that shortly.

Also, how are you running FDISK - it's not included with XP - XP uses it's own tools for configuring the disk.  (FDISK may have a problem as well).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Lee W, MVPTechnology and Business Process AdvisorCommented:
Sorry, meant to say:
 4 year old PCs have no idea how to talk to drives over 128 GB

Here's the link for XP - you MAY not have to do this, but I've instances where even with SP1 or 2, you do.
http://support.microsoft.com/default.aspx?scid=kb;en-us;303013
0
smiffy13Commented:
While a BIOS update is likely to fix your problem, I also suggest that you check the website of the disk manufacturer. Many (all?) provide disk management tools for their products that I've found to be extremely good at resolving a great many disk formatting problems.
0
Cyber-DudeCommented:
In Windows XP it is not reccomended to use FDISK but the 'DiskPart' utility. It is a much more flexable and powerful utility than the FDISK utility.

To initiate the diskpart utility do the following:
Click 'Start' => Choose 'Run...' => type 'diskpart' and press 'OK'.

Than type:
list disk <To view the list of disks>
select disk <the disk number you want to check>
list volume <and see exactly what is the situation of your drives. Post the results here and we can help you better>.

Cyber
0
Daniel Van Der WerkenIndependent ConsultantCommented:
Why are you using FDISK at all?  You already have WinXP Pro installed?

Just right-click on My Computer | Manage, and then select Disk Management.  From there, you can do whatever you want to the drive.  

If you still can't recognize more than 69%, you may be able to split the drive into two separate drives or like we've suggested above, update the BIOS and see where that leads you.

0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Cyber-Dude - I'd forgotten about diskpart, but I have to concur with Dan7el - why not just use computer management/Disk Management?
0
rindiCommented:
Windows XP won't get the correct size of disks which are larger than 130 GB in size (this was a restriction with windows XP). This got resolved from SP1 upwards. I suggest you install SP2, and your disk will show up correctly (SP2 includes the updates of SP1).
0
icemanwolCommented:
It may be a good idea to mention also that if there is not a bios update that will solve this issue, there it a way around this problem that is not too expensive.  You can get anouther IDE controller that supports drives beyond the 137GB limit of your current computer.  These controllers also alow you to support the full speed of the ATA133 drives, as your computer is most likely running at ATA100.  If you do decide to go this route, it would be best to plug in all your IDE devices into this card and disable the internel IDE channels from the bios.  Here are a few cards under $50 that will work.  If you get anouther controller from somewhere else, make sure it says it supports harddrives large then 137GB or it says it has 48-bit LBA
http://www.newegg.com/app/ViewProductDesc.asp?description=16-123-107&depa=1
http://www.pricegrabber.com/search_techspecs_full.php/masterid=534542#description
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.