Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 179
  • Last Modified:

By Passing the logon box in IE

Hi,


I am using Windows Authentication with IE. If the user is logged on in the network then IE doesn't show me the logon box, and the user is authenticated automatically. But if the user is not logged on, then IE shows the logon box prompting for a user name and pswd...so if the user is not logged on to the network., how do i bypass this logon box and prevent it from appearing.

Please suggest me.\

Regards,
Prerak
0
PPPimpact
Asked:
PPPimpact
1 Solution
 
bbaoIT ConsultantCommented:
umm... try this: open IE, goto menu Tools/Internet Options/Security, click Internet logo, click Custom Level button, under User Authentication, choose your desired option.
0
 
PPPimpactAuthor Commented:
Hi,

That might work for me..But if somebody else is trying to access the page, I cannot have all of them to change the settings.

Regards,
Prerak
0
 
bbaoIT ConsultantCommented:
you may use group policy to deploy the settings automatically.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
PPPimpactAuthor Commented:
I am sorry, but I fairly new to all this so i dont know how do i do it.Please suggest me.

Regards,
Prerak
0
 
swinterbornCommented:
There is no way to do this at the client side. When a user is logged on to the network, IE is automatically providing the details of the logged on user to the website, when the user is not logged on to hte network, there are no network credentials present so IE can only bring up the logon box. In both cases the user is logging on to the website, just by different methods. This is because of the configuration of the website, not IE. For some reason, I would presume by design, the web server is configured to request authentication from anyone accessing the relevant pages. The only option available to you would be to either turn off authentication or build a separate site for anonymous users. This is because browsers always request pages anonymously first, so if you want to use authentication, the server is configured to reply to the anonymous request with a refusal and a request for credentials. You would not be able to authenticate some users and allow others anonymous access to the same site.

HTH
0
 
kev1006Commented:
An easy fix for this might be to change the authentication method on the webserver. If you change it from NT Challenge Response / NTLM to anonymous, then a user would never have to logon. You can make this change through the Internet Information Services admin console (START --> Administrative Tools).
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now