Compaq Evo Notebook N115 Dead battery - can't charge or boot.

3 identical units. They had been left idle for several months without being used. Batteries are now dead. When AC adapter is connected to computer, there is no charge or power indicator on the computer (power light is on on the actual AC power supply), and the power button does nothing. How can we get the batteries to charge? Can the computers be operated without the battery packs?

Are these designed so that the CPU controls the charging circuit, and the CPU won't run at all without some battery power? Would an external stand-alone charger bring the batteries and therefore the laptops back to life? Is such a charger available?
LVL 1
exactjbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ChrisSchumannCommented:
I have two ThinkPads. The batteries were getting less and less useful each charge. I estimate they had about 40% of their original capacity left.

I bought new batteries and started using them. Just this weekend, I was wondering how useful the old batteries were, so I tried to run a battery rundown test. One pack lasted for six minutes. The other one would not even begin to charge.

The battery packs each have their own charging circuit and do not use the CPU to control charging.

You should be able to use the machines without batteries.

External chargers are available, and may be able to get some useful life from your battery packs, but new batteries will work much better and they'll be more reliable too.
0
exactjbAuthor Commented:
Based on ChrisSchumann's advice that it should run with no battery installed and just the AC Adapter, I tried that. Still won't boot. I also noticed something new. The LED on the AC Adapter glows steadily, until I connect it to the computer. Then it starts flickering; disconnect it then it glows steady again. This happened with 2 different adapters on two different N115's, both with main battery in or out.

The machines have not had any abuse or thermal shock, so now I wonder what the issue is. Would a dead Real Time Clock battery cause this?
0
ChrisSchumannCommented:
Your RTC batteries could be dead, based on the knowledge that these are PIII machines that haven't been used in a while.

That should NOT stop the machines from booting.

Do all three of your AC adapters behave the same way?

Here's a list of documents for your machine: http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&locale=en_US&docIndexId=179111&taskId=101&prodTypeId=321957&prodSeriesId=96309

The service manual is in there, and may include good information on diagnosing your problem.
The User Guide is of no help with this.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

exactjbAuthor Commented:
Based on ChrisSchumann's advice,, I have the following info:

All three AC Adapters behave the same way with any of my three N115's both with batteries in and batteries out. The Service manual is not much help.

The flickering LED on the power adapter kind of concerns me. The only thing that brings to mind is that somehow the laptops are drawing too much current causing the Adapter to cycle on and off continually.

It looks like replacing the RTC Battery might be an option, but only because I can't think of what else to do. It seems to entail about an hour or more of labor on each machine to get to the RTC Battery.

I am still open to other ideas!

John
0
ridCommented:
So, if I get this straight, you get a flashing LED on the power bricks when you connect them to any of these laptops, irrespective batteries being attached or removed?

I think I'd try leving the AC adapter (power brick) attached overnight, with batteries attached, and see if that makes a difference. (not starting up the laptops)

Also there is a remote possibility that the power bricks are bad; can you check with new/other adapters?
/RID
0
exactjbAuthor Commented:
I will be closing this question. We ended up giving the units back to the client who owned them as they were, so I never found the answer. I suspect that replacing the RTC batteries would have been the best stategy.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.