2 Servers running FC2 and 1 Static IP Address

I have 2 servers running on my network. I have 1 static IP Address (Router is a Linksys WRT54GS)

1) Web Server
2) Mail Server (Qmail)

DNS is supplied by Zone Edit

Both servers have apache installed listening on port 80.

My problem is that I cannot get the Mail server to be recognised from the Internet. (apache, ssh, pop3)
It works fine on my internal network but there is no access from the outside.
I have all the necessary ports on my firewall open for the mail server.

I think it is some kind of routing problem but i cannot figure it out.

LVL 3
ricbaxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arantiusCommented:
Hi ricbax,
That makes perfect sense, if you have two computers running two different things both on port 80, but only one external address, then only one of them can use port 80 on that one address.
Your router should have a way to re-map ports to internal addresses.  You can point external port 80 to one computer, and external port 8080 or 888 or whatever to the other computer.

I hope this is helpful!
0
ricbaxAuthor Commented:
I forgot to mention that I have the router remapping ports from external to internal IPs assigned to both servers.

You say to use port 8080 or 888. Would these Ports have to be expressed in the URL if accessing from the Internet?

For Example

http://mail.mydomain.com:8080/

If so, it is not the solution i am looking for.
0
wesly_chenCommented:
> My problem is that I cannot get the Mail server to be recognised from the Internet. (apache, ssh, pop3)
> It works fine on my internal network but there is no access from the outside.
You need the MX record pointing to your mail server's WAN IP (in your case, point to your Linksys router's static IP).
Register to you ISP or register.com for a domain name (i.e. yourdomain.com) and ask then to point the MX record of
your domain to your Linksys router's static IP.

Wesly
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

ricbaxAuthor Commented:
Ok I set the MX record and mail.mydomain.com and www.mydomain.com are pointing to my  WAN IP.

The problem I still have is that the web server is recognized on the Internet but the mail server.

If I try to access the webmail feature on the mail server I get a 404 error from the web server which means external access is not reaching the mail server.
0
wesly_chenCommented:
> I try to access the webmail feature on the mail server
You mean
http://<WAN IP>:<port number>/
for webmail? Did you have squirrelmail or some sort of webmail software install on your mail server?
For POPs, do you enable it on mail server and do the port 110 mapping on Linksys router?
How did you map the port on your Linksys router?

Wesly
0
arantiusCommented:
> You say to use port 8080 or 888. Would these Ports have to be expressed in the URL if accessing from the Internet?
> For Example
> http://mail.mydomain.com:8080/
> If so, it is not the solution i am looking for.

Yes, that is so.  That is the only solution.

To address a specific service on a specific computer, you need a combination of IP address and port.
You have one IP address.  You must use different ports.  Period, unless you buy another IP from your ISP.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ricbaxAuthor Commented:
After researching this headache all this morning and early afternoon I have come to the same answer as arantius has provided.
Wesly you have also provided some information that I will require once i get this IP problem fixed.

So I will divide the points with fairness to solution provided.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.