• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 313
  • Last Modified:

Point to Point T1 Config

I need a sample config of 2 Cisco 1721's with Serial Interfaces that are connected to DSU/CSU.
I pretty new at this and need some guidance.  This is for a simple point to point T1 line that has some channels already dedicated to data only.  The other channels are for voice.
Thanks
0
tinoss
Asked:
tinoss
  • 5
  • 4
1 Solution
 
Dr-IPCommented:
Here are sample configs for the two routers assuming they both have the serial interface in slot 0.

! Hostname: Cisco1721B
! Model: 1721
! ******************************************************************
!
service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Cisco1721B
!
enable password enable
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
!
interface FastEthernet 0
 no shutdown
 description connected to EthernetLAN_1
 ip address 10.10.1.1 255.255.255.0
 keepalive 10
!
interface Serial 0
 no shutdown
 description connected to Cisco1721A
 ip address 10.0.0.1 255.255.255.252
 encapsulation hdlc
!
router eigrp 10
 redistribute connected
 redistribute static
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
!
!
ip classless
no ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
!
line console 0
 exec-timeout 0 0
 password cisco
 login
!
line vty 0 4
 password cisco
 login
!
end


! Hostname: Cisco1721A
! Model: 1721
! ******************************************************************
!
service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Cisco1721A
!
enable password enable
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
!
interface FastEthernet 0
 no shutdown
 description connected to EthernetLAN
 ip address 10.10.2.1 255.255.255.0
 keepalive 10
!
interface Serial 0
 no shutdown
 description connected to Cisco1721B
 ip address 10.0.0.2 255.255.255.252
 encapsulation hdlc
!
router eigrp 10
 redistribute connected
 redistribute static
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary!
!
ip classless
no ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
!
line console 0
 exec-timeout 0 0
 password cisco
 login
!
line vty 0 4
 password cisco
 login
!
end

0
 
tinossAuthor Commented:
I have the encapsulation set at ppp not hdlc.  May that be the problem...
I used Cisco Config Maker and it gave me just about the same settings.  Except for the PPP part.
0
 
Dr-IPCommented:
PPP will work just fine too, so that is not the issue since either one will work. Do a show “interface serial 0” and see if you get something like this.

Serial 0 is up, line protocol is up

If that is what you got try adding the EIGRP config which I put in place of RIP.

router eigrp 10
 redistribute connected
 redistribute static
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary

If get something like

Serial 0 is down, line protocol is down

It’s probably and issue with the cable to the CSU/DSU, and if you get something like this.

Serial 0 is up, line protocol is down

You are probably looking at some kind of configuration issue.









0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
tinossAuthor Commented:
Serial 0 is up, line protocol is down

That's what I'm getting here is a config  of one of the routers.


Whippany#show config                    
Using 781 out of 29688 bytes                            
!
version 12.2            
service timestamps debug uptime                              
service timestamps log uptime                            
service password-encryption                          
!
hostname Whippany                
!
enable password 7 01071411481F0800701E45                                        
!
ip subnet-zero              
no ip domain-lookup                  
!
!
!
!
!
interface FastEthernet0                      
 description connected to EthernetLAN                                    
 ip address 192.168.10.250 255.255.255.0                                        
 speed auto          
!
interface Serial0                
 description connected to Hillboro                                  
 ip address 10.10.10.10 255.255.255.252                                      
!
router rip          
 version 2          
 network 10.0.0.0
 network 192.168.10.0
 no auto-summary
!
ip classless
ip route 172.16.10.0 255.255.255.0 10.10.10.9
no ip http server
!
!
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 password 7 105A1B0C16031C045D
 login
line aux 0
line vty 0 4
 password 7 09585C1C0A11191D5A
 login
!
no scheduler allocate
end
0
 
Dr-IPCommented:
The problem you have is somewhere between the two routers. It could be an issue with the time slot assignments in the CSU/DSU, or the T1, are the voice channels working? If they are I’d say it’s in the CSU/DSU condig, if not it could be the T1, but it also could be in the CSU, DSU config too. So I’d take a hard look at the CSU/DSU configuration first, and make sure that the same timeslots are being used on both ends for the data channel.
0
 
tinossAuthor Commented:
The voice channels are working.  We also ran local loopback tests and the line protocol comes up.  Also ran a remote loopback on the DSU/CSU and the line protocol comes up again.  
We checked the timeslots on the DSU/CSU and the match 13-24 64K (768K).

I spoke with Cisco and they are sending me new routers.  But I'm still not sure that's going to work either.
T1 shows up as clean no errors.  Like I said above the voice channels are working perfect.

Any more thoughts on what else I can try?
Thanks
0
 
Dr-IPCommented:
Are the CSU/DSU the same brand, I once ran across one that had the timeslots numbered backward? One last thing you could try to narrow it down is try loop backs from the far end sites and see if that brings up the protocol. I’d use a hard loop directly in the T1 jack at the demark for that testing as it would eliminate the far ends CSU/DSU from the picture. As for Cisco sending you replacement routers, I concur that it’s not likely to fix the issue, as I don’t see it as the likely problem. As I am pretty sure it's in the CSU/DSU or T1 configuration, or maybe a bad CSU/DSU.
0
 
tinossAuthor Commented:
Same brand...
We did loopbacks from the far ends and the line protocol does come up when ran.
We also swapped out both CSU/DSU's  already.

0
 
Dr-IPCommented:
Very strange to say the least, the only other thing I can think of is to get everything in one place, and connect the two DSU/CSU’s together with a 1T cross over cable and see if the protocol comes up, and if the routers can ping each others serial interface. If they, it’s probably in the line, and if they can’t something there isn’t right, but it isn’t clear what since it looks like everything by it’s self tests OK.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now