compile problem

I am trying to compile the latest stable PHP source file, but i am having some problems.

First i typed the command: tar -xzf php-......tar.gz

then i changed to the directory created due the above command

within this directory i typed:

./configure
make
make install

the system responds in the folowing way:

creating cache ./config.cache
checking host sytem type i686-pc-linux-gnu
checking gcc... no
checking cc... no
configure: error: no acceptable cc found in $path

Looks like something in $path (whatever this means) is wrong.

what can i do about this?

plz help me
wigmanwAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

liddlerCommented:
To search for gcc
type
find / -name gcc
and then add the path of gcc into your PATH
i.e.
if gcc is in /usr/local/bin
PATH=$PATH:/usr/local/bin
export PATH

if gcc is not found, you'll have to install it
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tomvergoteCommented:
replace
find / -name gcc
with
locate gcc | grep bin

it'll be much faster
0
wesly_chenCommented:
> configure: error: no acceptable cc found in $path
I guess the gcc is not installed on your system.
You can install gcc from the Linux CD.
By the way, which Linux you have? RedHat/Fedora, SuSE, or Mandrake?

Wesly
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

wigmanwAuthor Commented:
@ Wesley_chen

I use Suse 9.1 prof at the moment

wilco
0
wigmanwAuthor Commented:
Indeed there is no gcc on my system, ill have to install it.

Thx ppl for ya help
0
wigmanwAuthor Commented:
it is looking for flex -- lex now

whatever this is
0
liddlerCommented:
lex is a c syntax tool http://unixhelp.ed.ac.uk/CGI/man-cgi?lex
again search for it or downoad / install it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.