Installing Ethernet Card on Linux 9.0

Hi,

I have a Realtek RTL 8139D Ethernet Card attached in my system. I have installed it on my Windows2000 prof. I also have linux 9.0 installed on another partition. Please let me know how to install the ethernet card in it.

Thnks
Shoeb
shoeb_akAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ddunleaCommented:
Hi shoeb_ak,

The Realtek NIC is about the most common NIC around and is definitely fully compatible with Linux.

I guess the big question, is what exactly do you mean by "Linux 9.0"? Linux refers to the kernel, which is currently at around 2.6
0
shoeb_akAuthor Commented:
Actually I meant Redhat Linux 9 ,  installed using GRUB.

0
wesly_chenCommented:
Hi,

   Please login to RHL 9 (through Grub and select Linux) as root.
Then do
# dmesg | grep -i eth0
and see if the Realtek driver is loaded or not. (Please post the output here).
   If yes, then do
   # ifconfig eth0
    to see the interface is up or not (any IP assigned to eth0 ?)

   If not, then do
   # insmod 8139too
   the do "ifconfig eth0" to check the interface again.

Wesly

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

shoeb_akAuthor Commented:
Hi Wesly_chen,
I logged into Linux root, and at the prompt,I typed

[root@localuser root]#dmesg | grep -i eth0

and pressed "enter", but nothing happened, it simply went to the next line of the prompt.

[root@localuser root]#

Then I typed  

[root@localuser root]#ifconfig eth0

This is the message I got :

[root@localuser root]# ifconfig eth0
eth0     Link encap: Ethernet HWaddr 00:A1:B0:09:AF:BP BROADCAST MULTICAST MTU:1500 Metric:1 Interrupt:11 Base address:0xc000

Then I typed insmod 8139too and pressed "enter", this is what I got

[root@localuser root]#insmod 8139 too
Using /lib/modules/2.4.20-6/kernel/drivers/net/8139too.o
/lib/modules/2.4.20-6/kernel/drivers/net/8139oo.o : init_module : No such dvice

Hint:insmod errors can be caused by incorrect mdule parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg.


I am not able to understand what the problem is. Pls let me know if you could understand anything out of it.
0
wesly_chenCommented:
> # dmesg | grep -i eth0
> and pressed "enter", but nothing happened, it simply went to the next line of the prompt.
So the ethernet driver is not loaded during boot up.
Maybe the kernel version you have (2.4.20-6) don't have the driver.

Please download the follow RPMs:
http://download.fedoralegacy.org/redhat/9/updates/i386/kernel-2.4.20-37.9.legacy.i686.rpm
http://download.fedoralegacy.org/redhat/9/updates/i386/kernel-source-2.4.20-37.9.legacy.i386.rpm
Then
# rpm -ivh kernel-2.4.20-37.9.legacy.i686.rpm kernel-source-2.4.20-37.9.legacy.i386.rpm
And boot with the latest kernel (2.4.20-37.9), which you can select in Grub.

And then do the following commands again
# dmesg | grep -i eth0  <==see if the Realtek driver is loaded or not. (Please post the output here).
   If yes, then do
# ifconfig eth0

Wesly
0
shoeb_akAuthor Commented:
ok
I will download these two files now
presently I am working in Windows
I have both Windows & Linux installed in my pc
and I can access internet only in Windows
after I download these two files, should I transfer them in Linux into a specified directory only, or can I save them anywhere, and run the command u mentioned
Is there a way in which I can transfer them from Windows to Linux ?
As one file is of 13.3MB and the other is of 37MB, I would either have to write them to a disc, or find some utility which would allow me to transfer files from Windows to Linux
0
wesly_chenCommented:
Hi,

  You can use USB flash drive. For Windows XP it's PnP.
For Linux, as root,
# mkdir /mnt/usb; mount -t vfat /dev/sda1 /mnt/usb
# cp /mnt/usb/*.rpm /tmp
# cd /tmp; rpm -ivh *.rpm

Wesly
0
shoeb_akAuthor Commented:
Hi Wesley

I'm sorry I have'nt been able to write since a long time.
I downloaded the kernels, and installed them using the commands u mentioned. Then I ran the two commands u mentioned earlier, and the output was as below:

[root@localhost root]# dmesg |grep -i eth0
[root@localhost root]# ifconfig eth0
eth0  Linkencap:Ethernet HWaddr 00:A1:B0:09:AF:B9
        BROADCAST MULTICAST MTU:1500 Metric:1
        Interrupt:11 Baseaddress:0xc000
[root@localhost root]#

Does it mean that the Lan card is installed already ?

0
wesly_chenCommented:
> I downloaded the kernels, and installed them using the commands u mentioned
What kernel did you boot?
What's the result of
# uname -a

Wesly

0
wesly_chenCommented:
Hi,

Make sure your uname -a look like
Linux <hostname> 2.4.20-37.9.legacy #1 Tue Apr 13 17:38:16 EDT 2004 i686 i386 GNU/Linux

Then as root, do
insmod 8139too

Wesly
0
shoeb_akAuthor Commented:
Hi,

I had booted into the 2.4.20-37.9 kernel. When I ran the uname -a command, I got the output which was almost identical to the one you have printed in your message above. Only the date seemed to be different.

When I ran the insmod 8139too command, this is what I got :

Using /lib/modules/2.4.20-37.9.legacy/kernel/drivers/net/8139too.o/lib/modules/2.4.20-37.9.legacy/kernel/drivers/net/8139too.o:unresolved symbol mii_link_ok_R563eadc6

In the output, there were about 4-5 lines similar to the one above.

Is this a problem ?
0
wesly_chenCommented:
As root
modprobe 8139too

Wesly
0
shoeb_akAuthor Commented:
Hi

This was the result

#modprobe 8139too
/lib/modules/2.4.20-37.9.legacy/kernel/drivers/net/8139too.o:init_module:no such device
Hint:insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters

You may find more iinformation in syslog or the output from dmesg/lib/modules/2.4.20-37.9.legacy/kernel/drivers/net/8139too.o:insmod/lib/modules/2.4.20-37.9.legacy/kernel/drivers/net/8139too.o failed

/lib/modules/2.4.20-37.9.legacy

Thanks
0
wesly_chenCommented:
Mmm, it seems like the 8139too.o doesn't be recognized as the driver for
Realtek RTL 8139D Ethernet Card. Could you check the chip on the Ethernet card?
I suspect it is not the real 8139D chip.

If it still not work for RedHat 9, then you might need to try Fedora Core 3 which have more netowork
driver built-in.
http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/iso/

Wesly
0
shoeb_akAuthor Commented:
Yeah
The chip does have RTL 8139D written on it.

Could you tell me what Fedora is,


I saw on the link u sent above
there were many downloadable links in it
Which one should I go for
0
wesly_chenCommented:
Fedora is the next version of RedHat Linux 9 (free compared to RedHat Enterprise Linux).
Now the latest version is Fedora Core 3.
You can download the 3 iso files (for default installation) and burn into to 3 CDs.
http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/iso/FC3-i386-disc1.iso
http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/iso/FC3-i386-disc2.iso
http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/iso/FC3-i386-disc3.iso

If you choose installation everything, then you need the forth CD.
http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/iso/FC3-i386-disc4.iso

Wesly
0
shoeb_akAuthor Commented:
So it is'nt possible to install the Lan Card in my present version of Red Hat Linux 9 ??
0
wesly_chenCommented:
> it is'nt possible to install the Lan Card
Unless you can find the right driver.
You can change the NIC (LAN card), too.

By the way, do you have other modem card or there is a jumper on the LAN card.
As my experience, Linux kernel can not relocate the IRQ very well (it rely on BIOS to do the job).
So something the IRQ conflict with Linux default IRQ assignment will cause the NIC malfunction.
Take out the modem card or set the jumper on the NIC card to force it to use other IRQ will fix
the problem. As this case, its not the driver issue.

Wesly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.