Trouble installing netatalk on Mandrake 10 - configure can't find Berkeley DB

I'm trying to get netatalk 2.01  running on a Mandrake 10.0 server, but I keep getting configure errors related to the Berkeley DB, saying it couldn't find the bdb files, even when I had specified the correct path using the --with-bdb option.

After some Googling, I found a reference to a problem with RedHat caused by the use of libpthread (whatever that is), so I tried the suggestion of recompiling Berkeley DB with the --with-mutex="x86/gcc-assembly" option. Doing this changed one of the "no" responses to a "yes", but the configure still fails. Other things I've tried include adding  /usr/local/bdb/lib to my /etc/lib.so.conf file, and creating links to the libdb4.3.so file in various other /lib directories.

Here's the output I'm getting.

checking for Berkeley DB headers in /usr/local/bdb/include/db4.2... no
checking for Berkeley DB headers in /usr/local/bdb/include/db42... no
checking for Berkeley DB headers in /usr/local/bdb/include/db4.1... no
checking for Berkeley DB headers in /usr/local/bdb/include/db41... no
checking for Berkeley DB headers in /usr/local/bdb/include/db4... no
checking for Berkeley DB headers in /usr/local/bdb/include/... yes
checking /usr/local/bdb/include//db.h version >= 4.1.0... 4.3.21, yes
checking for Berkeley DB link (-ldb-4.2)... no
checking for Berkeley DB link (-ldb42)... no
checking for Berkeley DB link (-ldb-42)... no
checking for Berkeley DB link (-ldb-4-2)... no
checking for Berkeley DB link (-ldb-4.1)... yes
checking Berkeley DB library version >= 4.1.0... header/library version mismatch (4.3.21/4.1.25), no
checking for Berkeley DB headers in /usr/local/bdb/db4.2... no
checking for Berkeley DB headers in /usr/local/bdb/db42... no
checking for Berkeley DB headers in /usr/local/bdb/db4.1... no
checking for Berkeley DB headers in /usr/local/bdb/db41... no
checking for Berkeley DB headers in /usr/local/bdb/db4... no
checking for Berkeley DB headers in /usr/local/bdb/... no

Make sure you have the required Berkeley DB libraries AND headers installed.
You can download the latest version from http://www.sleepycat.com.
If you have installed BDB in a non standard location use the
--with-bdb=/path/to/bdb configure option and make sure
your linker is configured to check for libraries there.
configure: error: Berkeley DB library required but not found!

LVL 19
billmercerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
Are you trying to use BerkeleyDB 4.3.x? That version will require changes to the netatalk code since some of the API's have changed from previous versions. Any 4.2 version should work.
0
billmercerAuthor Commented:
I tried bdb 4.2.52 both and without the --with-mutex option, but Netatalk still won't configure. Same error message as before.


 



0
jlevieCommented:
What does 'rpm -qa | grep db' show?
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

pablouruguayCommented:
you need to install Bdb from sources or install bdb_headers if you install from RPM package

try using bdbxx.tar.gz to install it please
0
billmercerAuthor Commented:
pablouruguay, I did compile from source (note my original posting about recompiling bdb with the mutex option).

Here's my RPM query output for db.

libpwdb0-0.61.2-3mdk
libgdbm2-1.8.0-24mdk
pwdb-conf-0.61.2-3mdk
libdbcxx4.1-4.1.25-4mdk
libdb4.1-4.1.25-4mdk
foomatic-db-engine-3.0.1-0.20040302.3mdk
gdb-6.0-2mdk
libdbtcl4.1-4.1.25-4mdk

0
jlevieCommented:
Okay, that's what I thought you might find. There's a copy of BerkeleyDB installed to support rpm, but only the runtime support is there. I believe there's a libdb devel package in your distribution. Install that and don't specify a --with-bdb at configure of netatalk.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
billmercerAuthor Commented:
Thank you, that did the trick. Everything compiled perfectly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.