2 Nics and setting preferred route to net

Hi,

I've got a machine with two NICs.

I'd like to set a preferred route to the Internet via one of the NICs and for the machine to only use the other route when the first one is unavailable.

I've set the Route Metric for the 'Backup' Route to 2 and after a reboot the machine appears to do the right thing and packets travel via the correct NIC.  However after a few days the 'Backup Route' gets used.

How can I force the Primary Route?

C:\Documents and Settings\Administrator>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 02 e3 03 e3 ba ...... NETGEAR FA311/312 PCI Adapter
0x3 ...00 a0 c9 c8 08 27 ...... Intel(R) PRO Adapter
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       10.10.80.1      10.10.80.2       1
          0.0.0.0          0.0.0.0      192.168.0.1     192.168.0.6       1
         10.0.0.0        255.0.0.0       10.10.80.2      10.10.80.2       2
       10.10.80.2  255.255.255.255        127.0.0.1       127.0.0.1       2
   10.255.255.255  255.255.255.255       10.10.80.2      10.10.80.2       2
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.0.0    255.255.255.0      192.168.0.6     192.168.0.6       1
      192.168.0.6  255.255.255.255        127.0.0.1       127.0.0.1       1
    192.168.0.255  255.255.255.255      192.168.0.6     192.168.0.6       1
        224.0.0.0        224.0.0.0       10.10.80.2      10.10.80.2       2
        224.0.0.0        224.0.0.0      192.168.0.6     192.168.0.6       1
  255.255.255.255  255.255.255.255      192.168.0.6     192.168.0.6       1
Default Gateway:        10.10.80.1
===========================================================================
Persistent Routes:
  None

Thanks
LVL 1
bendeckoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

muterobertCommented:
These are your two default routes:

0.0.0.0          0.0.0.0       10.10.80.1      10.10.80.2       1
0.0.0.0          0.0.0.0      192.168.0.1     192.168.0.6       1

They both have the same metric. Surely your backup should be set at a higher metric than you primary?

You can adjust the metric for the gateway in the network connection property page (under tcp/ip settings/advanced)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bendeckoAuthor Commented:
Wonderful Muterobert!

I'd fixed the 'Interface Metic' to 2 - but I needed to change the dialogue above - the 'gateway metric' to 2.

Works great now.

Thank you

Bendecko
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.