Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cannot backup Exchange 2003 at store level

Posted on 2004-11-22
11
Medium Priority
?
1,297 Views
Last Modified: 2008-02-20
We have an Exchange 2003 Enterprise (SP1) Server running on Windows 2003 Server on a Windows 2003 domain. Our company's main storage group has 4 mailbox stores in it, and I back them up every night at store level. 3 of them are backing up fine and one is failing.

I am using Veritas Backup Exec 9.1 and I have also tried using NT Backup and I get the same problem - it gets all the way through and then fails with this entry in the Exchange Server's event log:

Source: ESE
Event ID: 217

Information Store (3020) VSS Storage Group: Error (-4001) during backup of a database (file E:\Program Files\Exchsrvr\VSS Storage Group\Associates and Analysts.edb). The database will be unable to restore.

I have tried backing up the store at mailbox level and that works fine. There seems to be a couple of KB articles about error 217 but nothing with Error 4001, so I am at a loss here....anybody have any ideas?
Thanks
0
Comment
Question by:chrisherbert
  • 4
  • 4
  • 3
11 Comments
 
LVL 23

Expert Comment

by:rhandels
ID: 12649212
This might help??

 As per Microsoft: "This problem may occur when you use a Web Distributed Authoring and Versioning (WebDAV) client to send messages to distribution lists and the distribution lists have one of the following options selected on the Exchange Advanced tab:
1.Send delivery reports to group owner
2.Do not send delivery reports". See Q814891, Q318429, and Q840013 for additional information.
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 12652230
Can you back the SG by itself, no other SGs or files selected in the backup job?

D
0
 

Author Comment

by:chrisherbert
ID: 12655104
Thanks for the two posts -

rhandels: I had already seen this particular KB article. Not quite the problem I'm having. So far I have seen quite a few KB articles related to error -613 but I am getting error -4000. Nothing about that anywhere....thanks though.

Kidego: We have 4 stores inside the SG and one of them is failing to back up so if I try and back up the whole SG it fails. I tried creating a job (using both Veritas and NTBackup) just to back up this one store and it failed also. The only way I have been able to succesfully back up data is to create a job backing up at mailbox level - the exact same mailboxes that are in the store - and that works.

So - I can back up the other 3 stores no problem, I can back up the mailboxes in the failing store no problem, I just can't back up the store itself. The funny thing is that it does actually get backed up - NTbackup creates a 9GB .bkf file - but I still get an error.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 23

Expert Comment

by:rhandels
ID: 12655423
Hi,

Maybe your.edb file of this store is corrupted.. Did you check using the isinteg and eseutil tools??
0
 
LVL 24

Accepted Solution

by:
David Wilhoit earned 1000 total points
ID: 12656480
Since this is 2003, create a Recovery Storage group, if you have the space, and restore the database in question, and see if it mounts. At least you'll find out if the error message is for real, or just misinformation.
I couldn't find the -4000 or 4001 JET error anywhere, not sure what that's about. What kind of 3rd party apps are installed on this server?

D
0
 

Author Comment

by:chrisherbert
ID: 12656568
There are no 3rd party apps on the server at all - no virus software either. We do use Legato email Xtender but so far I haven't used it on any of the mailboxes in this store.
We are a pretty small organisation (100 users total) and we only have 15 mailboxes in this store so I have actually created a new store and I am moving the mailboxes over right now. I am backing up the new store to disk after each move to make sure that no individual mailbox is causing the problem, and so far so good.
I know that this probably seems like a laborious way of doing it but I really cant bring down the IS service which is what ESEUTIL needs.
 
0
 
LVL 23

Assisted Solution

by:rhandels
rhandels earned 1000 total points
ID: 12656604
>>I know that this probably seems like a laborious way of doing it but I really cant bring down the IS service which is what ESEUTIL needs.<<

Indeed, but i don't think it's a very laborious way, as long as it works.. And be glad to only have those few users, else it would be pizza and a late night working again.. ;)
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 12656756
You don't have to bring anything down to restore to the RSG, it can be mounted without connecting to the users objects. It's a viable test to see if your backup worked or not. Where did eseutil come in to play?
D
0
 
LVL 23

Expert Comment

by:rhandels
ID: 12659642
Hi D,

It came from my post.. Maybe the store is corrupt, so i asked chris to check the store...
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 12661211
ahhh, didn't see that part :) thought I missed something, and I did....

D
0
 

Author Comment

by:chrisherbert
ID: 12719158
So moving the mailboxes into the new store worked - I did restore the old store to a RSG and it mounted fine so I really don't know what the problem was. I have split the points 50/50 as you both helped me along....thanks
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes Top 9 Exchange troubleshooting utilities that every Exchange Administrator should know. Most of the utilities are available free of cost. List of tools that I am going to explain in this article are:   Microsoft Remote Con…
Steps to fix “Unable to mount database. (hr=0x80004005, ec=1108)”.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Suggested Courses
Course of the Month15 days, 13 hours left to enroll

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question