Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 753
  • Last Modified:

RedHat Linux sendmail problem involving domain name

Hello,

I am using a Dell laptop running RedHat Linux 9.0. I send mail using Emacs, which in turn uses sendmail.

At home, I have no problems sending mail this way. The laptop is connected to cable modem which provides DHCP to the laptop.

When I take the computer to work, I connect to the local network which also provides DHCP address to the laptop. However,  sendmail fails - there are error messages in /var/log/maillog, and the mail does not get delivered. My guess is this is due to domain name setting on the laptop, but I could be wrong.

Here are typical error messages directly from the log file.

 Nov 22 14:31:10 basel sendmail[5794]: iAMMV9ti005794: from=ljubomir, size=7074, class=0, nrcpts=2, msgid=<16802.26797.724700.594163@basel.vectorsciences.com>, relay=ljubomir@localhost
Nov 22 14:31:40 basel sendmail[5798]: iAMMVASL005798: from=<ljubomir@basel.vectorsciences.com>, size=7191, class=0, nrcpts=2, msgid=<16802.26797.724700.594163@basel.vectorsciences.com>, proto=ESMTP, daemon=MTA, relay=basel [127.0.0.1]
Nov 22 14:31:40 basel sendmail[5797]: iAMMV9ti005794: to=ljubomir@sfsu.edu,mmilan@etf.bg.ac.yu, ctladdr=ljubomir (500/500), delay=00:00:31, xdelay=00:00:30, mailer=relay, pri=60702, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (iAMMVASL005798 Message accepted for delivery)
Nov 22 14:31:57 basel sendmail[5835]: iAMMVASL005798: to=<mmilan@etf.bg.ac.yu>, ctladdr=<ljubomir@basel.vectorsciences.com> (500/500), delay=00:00:27, xdelay=00:00:17, mailer=esmtp, pri=60819, relay=zmaj.etf.bg.ac.yu. [147.91.8.62], dsn=4.2.0, stat=Deferred: 450 <ljubomir@basel.vectorsciences.com>: Sender address rejected: Domain not found
Nov 22 14:31:57 basel sendmail[5835]: iAMMVASL005798: to=<ljubomir@sfsu.edu>, ctladdr=<ljubomir@basel.vectorsciences.com> (500/500), delay=00:00:27, xdelay=00:00:00, mailer=esmtp, pri=60819, relay=mailgw2.sfsu.edu. [130.212.10.32], dsn=5.6.0, stat=Data format error
Nov 22 14:31:57 basel sendmail[5835]: iAMMVASL005798: iAMMVvSL005835: DSN: Data format error
Nov 22 14:31:57 basel sendmail[5835]: iAMMVvSL005835: to=<ljubomir@basel.vectorsciences.com>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=38215, dsn=2.0.0, stat=Sent
Nov 22 14:34:23 basel sendmail[5841]: iAMMYNWq005841: from=ljubomir, size=163, class=0, nrcpts=2, msgid=<200411222234.iAMMYNWq005841@basel.vectorsciences.com>, relay=ljubomir@localhost
Nov 22 14:34:38 basel sendmail[5845]: iAMMYNSL005845: from=<ljubomir@basel.vectorsciences.com>, size=385, class=0, nrcpts=2, msgid=<200411222234.iAMMYNWq005841@basel.vectorsciences.com>, proto=ESMTP, daemon=MTA, relay=basel [127.0.0.1]
Nov 22 14:34:38 basel sendmail[5844]: iAMMYNWq005841: to=ljubomir@sfsu.edu,ljubomir@gmail.com, ctladdr=ljubomir (500/500), delay=00:00:15, xdelay=00:00:15, mailer=relay, pri=60162, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (iAMMYNSL005845 Message accepted for delivery)
Nov 22 14:34:52 basel sendmail[5847]: iAMMYNSL005845: to=<ljubomir@gmail.com>, ctladdr=<ljubomir@basel.vectorsciences.com> (500/500), delay=00:00:24, xdelay=00:00:14, mailer=esmtp, pri=60384, relay=gsmtp171.google.com. [64.233.171.27], dsn=2.0.0, stat=Sent (OK 1101162890)
Nov 22 14:34:52 basel sendmail[5847]: iAMMYNSL005845: to=<ljubomir@sfsu.edu>, ctladdr=<ljubomir@basel.vectorsciences.com> (500/500), delay=00:00:24, xdelay=00:00:00, mailer=esmtp, pri=60384, relay=mailgw.sfsu.edu. [130.212.10.33], dsn=5.6.0, stat=Data format error
Nov 22 14:34:52 basel sendmail[5847]: iAMMYNSL005845: iAMMYqSL005847: DSN: Data format error
Nov 22 14:34:52 basel sendmail[5847]: iAMMYqSL005847: to=<ljubomir@basel.vectorsciences.com>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31409, dsn=2.0.0, stat=Sent

Notice the 'Data format error' and 'domain not found' error messages.

I could set the domain name if I knew how. 'man domainname' reveals five different domain name settings, I'm not sure which applies in this situation.

Thanks,

Ljubomir
0
ljubomir_buturovic
Asked:
ljubomir_buturovic
  • 2
1 Solution
 
jlevieCommented:
Your mail is being sent from  ljubomir@basel.vectorsciences.com and the MTA at zmaj.etf.bg.ac.yu appears to be attempting a DNS lookup on basel.vectorsciences.com, which fails. That's partly a problem with the DNS for your domain (vectorsciences.com) and partly a problem with the remote MTA. The remote should be trying a lookup on the domain (usually an MX) lookup, which would work. I suspect that a similar error is occuring at mailgw2.sfsu.edu although it isn't being reported as such.

While there is a solution to this sort of problem, namely configuring Sendmail to use the local mail server as a SMART HOST, that solution would require changing the Sendmail configuration each time you move the laptop from one network to another. An easier solution is to use Evolution as a mail client and configure it with two email accounts, one for work and one for home. As a part of that config you'd specify the appropriate SMTP server for each account.
0
 
ljubomir_buturovicAuthor Commented:
Thanks for your comment. It is helpful, but there is still something I don't understand.

Here is what I don't understand: when I send mail to exact same users from home, there is no problem. How is it that the same MTA at zmaj.etf.bg.ac.yu does not have the DNS lookup problem on basel.vectorsciences.com when my laptop is attached to my home LAN?

Regards,

Ljubomir


0
 
jlevieCommented:
I should have mentioned that it also could be that the remote MTA is doing a reverse lookup of your IP. That might not resolve to a fully qualified domain name at work but does at home. There's no way to tell how zmaj.etf.bg.ac.yu is checking for a valid sender domain without asking them.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now