• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 294
  • Last Modified:

slow airport speed on network

When my clients going through the airport on my small business network to access the internet, the performance speeds are up to 10 times slower than those clients connected to a switch on the same subnet as the router and cable modem.
Here's the setup:
I have the Airport setup so that it's LAN interface has an ip of 10.0.1.1 and it's wan interface is 172.0.1.2 with default g'way of 172.0.1.1 (i.e the router). My cisco 1700 router then has LAN interface of 172.0.1.1 and then it's wan interface as the public wan ip address connected to the dsl/cable modem. Airports WAN interface and router LAN interface are connected to the same switch.
However the clients on the 10.0.1 subnet have a slow internet connection.
I have tested having a client connected directly to the switch on the 172.0.1 subnet and it's internet connection is almost 10 times quicker.
Therefore it seems like the bottleneck is the airport. Are there any config settings on the airport that I could tweak, or is there a quicker, more optimized setup that I could have?
0
jimburdon
Asked:
jimburdon
  • 4
  • 4
1 Solution
 
lyle-grangerCommented:
I would recommend making the airport a passive device.  Simply disconnect the wan interface on the airport letting the clients connected to the airport recieve their addresses from the LAN's router.  That way the computers will be part of the same subnet  as the lan (172.0.1.x) and access the internet much quicker.  

Hope this helps.

Lyle
0
 
jimburdonAuthor Commented:
That does sound like the way to go. However I am unsure of the exact setup to do. Do you mean that the router acts as a dhcp server or is this still the airport?
Do I set the default gateway for the clients to then be the router's ip address?
0
 
lyle-grangerCommented:
The router will act as the DHCP server now and the clients on the airport will get all of their information from the router, including address, subnet mask and default gateway.  

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
jimburdonAuthor Commented:
I tried to have the router act as a dhcp server but the clients failed to get an ip  address. I then also lost the connection to the airport and had to reset it back to defaults and then re-configure. I'm now back to where I was before.

Here's what I tried:
On the router:
ip dhcp excluded-address 172.16.1.1 10.10.10.6
ip dhcp pool CLIENT
 network 172.16.1.0 255.255.255.0
 default-router 172.16.1.1
 dns-server <ip address of dns server>

I'm really  confused on how to set the airport. It's ip address is 10.0.1.1, it was distributing ip addresses on this subnet (when I switched this off I got disconnected to the airport - not surprisingly - I guess I can manually set an ip address on this subnet for a client so that I can still see it?). Under internet connection what should I have here?
0
 
lyle-grangerCommented:
I have two network diagrams I would like to get to you.  It shows your current config as you have described and my suggested changes.  If I have everything correct...they should make things clearer.

A similar problem was previously posted on EE:
http://www.experts-exchange.com/Networking/Q_21201461.html

Hope this helps.

Lyle
0
 
jimburdonAuthor Commented:
Will try it again tonight. Would like to get hold of those network diagrams you mention: please email to james@lostball.com
I think last night the reason it failed was that I had the airport still connected to the WAN interface rather than the LAN interface - I overlooked this part.
So my plan now is:
have the router act as dhcp server, and lan interface connected to switch on 172.16.1 subnet
have the airport lan interface connect to switch on 172.16.1 subnet
switch off distribute ip addresses on airport and disconnect the WAN interface (so that it acts as just an AP), and set under internet tab the ip address to be 172.16.1.2, with def g'way to be 172.16.1.1 (the router) - is this the correct place to set the ip address of the airport?????
I think this should work but won't know until later..
Thanks for all your help so far!

0
 
lyle-grangerCommented:
That is exactly what my diagrams show and the other EE post also suggests.  

Good Luck =)
0
 
jimburdonAuthor Commented:
Thanks Lyle, your tips helped and it's all setup now.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now