• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 807
  • Last Modified:

PHP Upload Files Settings

I have installed PHP 4.3.9 and MySQL 4.1.7 on my Windows XP system using an IIS5.1 server.
I am using an upload program using PHP code called SLMan. I am uploading 16MB mp3 files and these are my php.ini settings.

upload_max_filesize = 30M
post_max_filesize = 32M
max_input_time = 1800
max_execution_time = 1800

I cannot upload files of more than 1MB without getting a 'MySQL server has gone away' error message. I wanted to make sure I have all my PHP settings correct before asking the Experts about the MySQL message. Are these settings all I need to set in the php.ini file ?
Thanks,
0
mhoggatt1
Asked:
mhoggatt1
1 Solution
 
gruntarCommented:
Settings are fine. Problem is in mysql timeout. I don't recommend storing large files in your database. Use filesystem instead and store only path info in your database.

Cheers

Tip: Moving large database to a different host can be frustrating experience if you don't have root access to your server. That is not the case when using filesystem and you can use FTP to move them to annother server.
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now