WinXP Home and Win2000 machines don't communicate

Hi!

I'm setting up a small home, peer-to-peer network for some friends. The new machine has XP Home for the OS, and the old system has Windows 2K. I've got both systems set for the same workgroup names, sharing on, and connected through an AOpen router. The lights indicate communication (including blinking while searching for another computer), but neither computer sees the other. All firewalls are off, both systems are set to autodetect IP Addresses, the DHCP is enabled, everything else looks like it should work.

But it doesn't, even after several reboots.

I've set up WinXP Pro/98 systems, XP Home/98se systems, and WinXP Pro/Windows 2000 systems before, all without major difficulty, but never Home and W2K.

Any suggestions?

Thanks!
ksiegelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

imnajamCommented:
Hi ksiegel,

I don't know if there is any specific issue with XP HOME (but I assume that there wouldn't be any problem) have tried a ping command thorough computer name aswell as computer IP address? n make sure the builtin firewall of XP is turned of in network conenction properties.

Cheers!
0
SoHandyCommented:
Hello there

Dont know if you know but for networking XP Home is not the best for.
Well in a business but for home it should work on a little network but can have problems.
Firstly have you checked that both pc's are getting an ip address.if you are not sure how to do this go to start, run, and type cmd
from dos prompt type ipconfig /all
you should see in there your ip address.just make sure both pc's are in the same ip range.
eg: 192.168.0.1
first 3 numbers should be same on both with last number changing.
it should be the same range as the router.if they are not something wrong with your dhcp settings.
are you logging on both pc's with same username and password.if not this is a problem with xp.
if you log both pc's with same username and password if this is the problem it should sort it.
or if you want to log on to both pc's with seperate username's just add in control panel and user accounts just add in the username of other pc in here on both pc's.
sure if anything you dont understand just let me know
0
ksiegelAuthor Commented:
Hmmm... I never thougnt to run ipconfig, or try a ping... I'll check them both today.

Neither system is password protected at this time - I wanted to get them connected first; and both machine names are different.

I shall return! ("I'll be back" sounded so...so... gubernatorial!)

      -Kurt
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

SoHandyCommented:
Hello Kurt

Apologies if i misunderstand you but when you say machine names.do you mean the actual name of the pc or what you are logging on as.
Both pc's should have a different pc name that is ok.
just when you are logging on the username that you are using.try the same username on both and see what happens.
0
imnajamCommented:
from my side I am waiting for your feedback about ping n ipconfig /all
let me know if you can ping each computer with either their IP addresses or with their netbios/computer name.
good luck
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
crissandCommented:
The level of security is different on Windows 2000 and Windows XP Home. You should always access Windows XP Home Workstations from Windows 2000 Pro. For reverse, you must enable Guest account on the W2k Wks.
0
ksiegelAuthor Commented:
Okay, here's the deal:

Before I read the responses today, I went to my friends place, enabled NetBios on the W2K machine, and ... Voila!

They saw each other just fine.

Now, to be fair, AFTER I enabled NetBios, and the computers immediately saw each other, I did the PING dance and ipconfig (which had totally slipped my mind yesterday).....

So we solved the problem BEFORE anyone had mentioned NetBios, but then imnajam mentioned it without knowing that I'd done so. However, I used SoHandy's information to verify that the router worked, just that the AOL for Broadband/Toshiba PCX1000 modem wouldn't communicate with the system through the router (a seperate issue, but one I would have probably menioned next.)

And Crissand, I didn't have to enable the guest account on the W2K machine - it had never been disabled by the user.

So we need to replace the router with a Linksys, Netgear, or Actiontec (according to AOL), but that's another story...

Can I split the points between SoHandy and imnajam??

     -kurt
0
imnajamCommented:
no objection from my side:) I was just willing to make sure of the problem before recommending you about netbios:) anyways good luck:)
0
SoHandyCommented:
No problem on my end

Good luck
0
ksiegelAuthor Commented:
Oay, I gave Imnajam the accepted answer(because you mentioned NetBios), and the assist to SoHandy for everything else. Grade of B, 125 points each.

Thanks again, folks, and have a Happy Turkey (or substitute commestible of your choice) Day!

      -Kurt
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.