copy tftp run - "File does not exist"

I'm using SolarWinds TFTP server and will "copy run tftp" to the tftp server and sucessfully copy my running config.  I can see the file in the tftp-root folder.

If I try to "copy tftp run" both the router and SolarWinds show an error of "file does not exist"

I can sucessfully upload and download the IOS but not the config file.  "Send and recieve" is checked for security and no IP's are blocked.

If I upload the config from routerA and download it back in, it will work.  If I upload the RouterA config and try to download it to RouterB, it will not.  Both run the same exact IOS and have the same resources. IOS will transfer from routerA to routerB OK as well.

These are both 2620 cisco routers.
LVL 1
zenportafinoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

piersonmCommented:
RouterA#copy run tftp
Address or name of remote host []? 10.0.0.1
Destination filename [RouterA-confg]? --> accept the default name
.....

RouterB#copy tftp run
Address or name of remote host []? 10.0.0.1
Source filename []? RouterA-confg --> enter the default name used in copy run tftp
Destination filename [running-config]?
Accessing tftp://10.0.0.1/RouterA-confg...

Note: After this you will have two routers named Router A with the same config
         Change the hostname of 2nd RouterA to RouterB
   
Let me know how this goes.  Also, what is the byte count on the file after you upload it to the tftp server.  
If it shows zero then the upload did not work correctly.  

-MP
0
ccie4526Commented:
I'm not sure how SolarWinds TFTP handles upper and lower cases. I use a linux server for all my tftp transfers, and filenames are extremely case sensitive. You may wish to check the case of your config filename, and possibly even use an all-lower-case filename as well.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zenportafinoAuthor Commented:
I got it first thing this morning.  The file name was RouterSB-Config.  I matched case exactly and still no love.  I copied the file and renamed it to "a" (no quotation marks) and tried the - copy tftp run - with a as the file name and it took first try!

Thanks piersonm and ccie4526 for your quick replies.  I do appreciate it!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.