?
Solved

Wireless Networking Setup

Posted on 2004-11-23
11
Medium Priority
?
468 Views
Last Modified: 2013-11-09
I use to have a Wireless Network between my Laptop and Desktop but since I had to change my mobo and reinstall XP Pro, the network isn't working.

I have Win XP Pro on both computers.
The Wireless Cards have connected with each other and show good strength.

I have run the Network Wizard on both computers but still no joy.
On my Desktop, when I click on "My NEtwork Places" and then click on "View Workgroup Computers", nothing shows up. Not even the desktop computer itself. At least on the the laptop, it shows itself.

I went into CMD Prompt and tried pinging the laptop. It could not find the other host.
I also typed ipconfig /all and this is what I got:

Windows IP Configuration

        Host Name . . . . . . . . . . . . : lentrica
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : Yes
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : D-Link AirPlus Xtreme G DWL-G520 Ada
pter
        Physical Address. . . . . . . . . : 00-80-C8-1E-61-A6
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 0.0.0.0
        Subnet Mask . . . . . . . . . . . : 0.0.0.0
        Default Gateway . . . . . . . . . :
        DHCP Server . . . . . . . . . . . : 255.255.255.255

PPP adapter My ISP:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
        Physical Address. . . . . . . . . : 00-53-45-00-00-00
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 213.78.126.173
        Subnet Mask . . . . . . . . . . . : 255.255.255.255
        Default Gateway . . . . . . . . . : 213.78.126.173
        DNS Servers . . . . . . . . . . . : 212.67.96.129
                                            212.67.120.148

Any ideas on what I can do?
0
Comment
Question by:Jetheat
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 1

Expert Comment

by:BabalooInternet
ID: 12652810
You can set up a AdHoc on both adaptors.


Setting up Ad-Hoc  
Configure the adapter in Ad Hoc mode when you are not using an Access Point or Wireless Router on your network. Ad Hoc mode is for peer-to-peer wireless networking.

Step 1 Log into the your wireless adaptor utility by double clicking on the Bar Graph icon in the system tray.

Step 2 Select the Configuration link on the left hand side of the menu. Type in the SSID of your wireless network and change the Network mode to Ad Hoc.

Step 3 Click on the Apply button to apply the settings.

Step 4 Go to your second wireless card and verify you have the same wireless settings on the card.

If using Windows XP:

Step 1 Right-click on the two computer monitor icons in the system tray and select View Available Wireless Networks.

Step 2 Click on the Advanced button, uncheck the Use Windows to configure my wireless card and click on the OK button.

Step 3 Follow Steps 1-4 above.

Then, in your IP configuration,  set one adaptor to 192.168.0.1 and the other to 192.168.0.2. Both on subnet 255.255.255.0
Go to the advance tab of your network connection that connects to the internet and share the connection.
If your have still problems, and the data rate is on auto, selct the same speed in both adaptors.
0
 
LVL 1

Expert Comment

by:Ben-Higgins
ID: 12652842
Hiya

You have no IP address on the wireless adapter, hence cannot talk to the other PC... Try the following;

Run IPconfig on the other machine and see what IP it has... depending on whether you want to just connect the two PC's for file sharing or share the internet connection on the desktop there are two approaches..

For pure file sharing...

1. Go to network connections, right click on the wireless adapter and select properties. Go to TCP/IP.
2. Manually input an IP address and subnet mask... I suggest 192.168.0.1 for the desktop and 192.168.0.2 for the laptop. It will automatically calculate the subnet for you.
3. Now go to my computer, right click and select properties. Go to computer name and ensure both machines have the same workgroup name.
4. Reboot both machines and it should work ok.

For internet connection sharing....

1. Rerun the network wizad on the desktop, but select "this computer connects directly to the internet and the other computers connect through this one" when it asks you about your internet connection.
2. Select the appropriate adapter for your internet connection when asked.
3. Go through the rest of the wizards, noting the workgroup name you enter.
4. Reboot both machines at this point, the desktop first, then the laptop.
Keep going if this still doesn't work.............
5. On the laptop, assuming it was working ok before on the network, check the workgroup name (as described above) and run ipconfig. The desktop should give it an IP address (most likely something like 192.168.1.2). If this doesn't work then check in connection properties/ TCP/IP that "obtain an IP address automatically" is selected. Go to a command line and type ipconfig/release and ipconfig/renew to obtain an IP from the desktop.

Let me know if you have any problems

Cheers

0
 

Author Comment

by:Jetheat
ID: 12653160
ok, I put 192.168.0.1 on the Desktop and 192.168.0.2 on the laptop.
However, when I left the "Use Windows to configure my wireless card " unchecked, the computers didn't see each other, so I rechecked it on both computers.

I wish to share files and also use the net from the Laptop by connecting thru the desktop.
Even though I have input the above, it's still the same.

When I typed ipconfig and ipconfig/all on my laptop, I got some weird readings.

C:\>ipconfig

Windows IP Configuration


Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.0.2
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected

C:\>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : FA
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Mixed
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Intel(R) PRO/Wireless LAN 2100 3B Mi
ni PCI Adapter
        Physical Address. . . . . . . . . : 00-04-23-49-33-0C
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.0.2
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
        Physical Address. . . . . . . . . : 08-00-46-A2-CF-57

What do i do next?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:Jetheat
ID: 12653238
Some additional Information.

On my desktop, when I ping the desktop name itself, it says Timeout. But if I ping 127.0.0.1 its ok.
In "My Network Places", when I click on "view Workgroup computers" it comes up with an error saying "MSHOME is not accessible. You might not have permission to use this network resource. Contact the admin blah blah.. The list of servers for this workgroup is not currently available"

So If I can't connect to myself, surely it has nothing to do with the network. There must be some setting or some service which is turned off.

What can I do?
0
 
LVL 1

Expert Comment

by:Ben-Higgins
ID: 12653528
IP config on the laptop looks fine.... did you do all the stuff in my last post?? Try using a workgroup name other than MSHOME. Make sure you have the networking wizard run on both machines. If you can ping the other machine then there is no issue with the wireless settings. The issue appears to be with the windows networking stuff. Can you paste IPconfig/all from the desktop after the changes I suggested have been made in please??
0
 
LVL 1

Expert Comment

by:Ben-Higgins
ID: 12653544
If the desktop is on 127.0.0.1 ans the laptop on 192.168.0.2 as suggested it will not work. Run the changes on the desktop also
0
 
LVL 4

Accepted Solution

by:
piersonm earned 150 total points
ID: 12653773
Jetheat

Try the following link, it has some options you can try especially near the bottom to troubleshoot the Network Wizard installation.

http://support.microsoft.com/default.aspx?scid=kb;en-us;318030

-MP
0
 

Author Comment

by:Jetheat
ID: 12653776
I did everything you said but when I tried ipconfig on the laptop, it said it could not do it coz the LAN media was disconnected. That's why I posted those results above. Since "the media" is discnnected, I can't do a ipconfig/release or renew.
I haven't changed the Workgroup name yet but I will do that now, although MSHOME worked fine last time. Even though the reslts from pinging 127.0.0.1 came out fine, my ip in the properties of Internet Protocol (TCP/IP) have been set to 192.168.0.1. So I didn't set 127.0.0.1 anywhere. Do you think this could be because of the check mark left in "Use Windows to configure my wireless card? "

I will post the Ipconfig /all when I have changed the workgroup name on both computers.
0
 
LVL 1

Assisted Solution

by:BabalooInternet
BabalooInternet earned 75 total points
ID: 12654015
Media disconnected

Did you setup the adhoc? Did you set the data rate the same?

Try another thing: Bridge the two connections on your pc, and DHCP enable your laptop.

0
 

Author Comment

by:Jetheat
ID: 12654230
I have AdHoc set on both. There is no way to select the data rate, especially on the laptop. I went to configure the Wireless Card on both computers and tehre is no option for Data Rate. There are 8 options on the Desktop and only 2 on the Laptop.

When you say DHCP enable the laptop. I don't know how but what I did do is go to services (on laptop) and restarted the DHCP Client as it was already started.
Bridging, I tried that but it just said that I needed 2 network connections that were not being used by the Internet. However, I didn't use Bridging last time and it worked fine.

Please remember, my desktop can't see itself so I really think there is a problem within windows.
0
 

Author Comment

by:Jetheat
ID: 12654768
It's done. I did say that it was a Windows problem.
Piersonm provided the link which I followed.
Enable Netbios etc...
Then I could see my computers in the Network Places and then I could connect to each other.

I'll split the point with most going to Piersonm,
Thanks to all,

JH
0

Featured Post

What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question