smtp / smart host routing between exchange 2000 and exchange 2003

My situation

There is a Exchange 2000 on site 1 in Holland that has been working for about a year.  It recieves email for about 7 domains.  In the SMTP delivery advanced it has a smart host entry which is an ISA 2000 server.  On ISA it secures OWA and runs the SMTP queues as well each domain is listed in there.  The domians have a smart host entry back to the exchange 2000 server.

I have a exchange 2003 server which receives for another domain name (the MX points to me) and works fine.  In the same organisation and routing group.  

The problem I have is that some of the people (mailboxes) on my server have alias (smtp) for some of the domain names on the other server.  They are not getting mail or having it delivered 30 after it is sent.

It would seem that due to the smart host entry Exchange has lost the ability to look at the recipient policy which has all domains in and make the necesaary routing decsions.  The senders are not getting a ndr so in effect I have been loosing interna, and external mail for the last week.

Any help to resolve this would be appreciated.

Benjamin
LVL 2
benjaminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
You need to remove the smart host entry from the SMTP virtual server. This is overriding the routing that Exchange needs to use. Instead of sending the messages to the other server, it sends them to the smart host.
Instead, create SMTP Connectors to send the messages to the smart host. Exchange can then route the messages in the correct way.

Simon.
0
benjaminAuthor Commented:
Simon

You are saying that I should remove the smart host entry for both servers in the smtp vserver delery advanced options, ok.

I have two connectors are present both smtp * cost of 1.  1 labelled for each server containing that server as a bridgehead.  do i leave these two?

All so what are the exact details I need to enter to create the connector do I enter all domain names @.....com etc and select forward to smart host?  Then do i need to restart exchange or anything for it to pick up the new connector I suspected the answer lay i th econnector but I have not created one before.
0
benjaminAuthor Commented:
As a though if I have mx record pointing to the two server do all domain names need to be in the new connector.

Can I leave the old connectore but gice them a high routing value?

Does the SMTP queue on the ISA server (smart host) it has the domains names entered and the smart host of one or the other server what do i do with them.

Thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SembeeCommented:
You need to remove all the Smart Host entries on the virtual servers. Once you get to more than one server they MUST be removed. I personally feel it is bad practise to use them for configuration and will start with SMTP connectors to start with.

What are the existing connectors doing? Exchange is quite capable of delivering email on its own, without the need for the connector. Therefore if the connector does NOT have smart hosts entered in it then they can be added. A SMTP connector is used to send email in a direction that the Exchange server cannot work out for itself (usually to go via another server). On this site most of the time we are recommending use of a connector is to send email via the ISPs mail server.

Exchange will know what is internal email and will not use it for internal messages. Therefore if all outbound email needs to be routed via another machine then you just leave the * in place. Adding domain names to the list on the connector will actually stop them from working - as you are telling Exchange what domains to use the connector for.  

The MX record and the connector are not related. MX is for inbound email and SMTP is for outbound.

As for ISA, I cannot help. I personally prefer to use a real firewall to protect my network.

Simon.
0
benjaminAuthor Commented:
The two existing connectors are one for each server. with just the one server as a bridgehead i.e the connector it releates to.  They are both internet mail connectors by lable and the address space contains * 1 for the domains and cost.

As a though where is the mail going that looks ike it is delivered but never seems to get there, the bad mail etc seemd clean?
0
benjaminAuthor Commented:
As a second thought I am having the MX reocrd transfered to my server as I know it is te ISA that is causing the problem I have removed the snart host entries.  Do i need any connectors or can i delete them ?
0
SembeeCommented:
If you are sending the email directly then you don't need any connectors. Connectors are usually used for sending email in a direction other than what Exchange can find itself.

Simon.
0
benjaminAuthor Commented:
mmm i used the mail conection wizard which created the conector! is that a bad idea?
0
SembeeCommented:
I have never used the wizards when setting up an Exchange server, mainly because I like to work things out for myself. While it wasn't a bad idea, I am at a loss as to why MS have added the connector - unless it is to give you something that you can easily adjust with alternative SMART HOSTs or DNS servers if required.

Simon.
0
benjaminAuthor Commented:
Ok

I have checked recipient policy and global address list the are correct and rebuilt.

I have deleted both connectors that I mentioned.

On the server that is 2003 it sends internal mail fine to the 2000 but the 2000 does not send internal mail to 2003.

Tha smart host entries are gone and both server have been rebooted.  Between them is a open PIX firewall and a 2mb link.

When I look at the 2000 smto queues I see the mail in there that simply sits in the que (labelled for my server, 2003) but the mail does not leave.

I dont see how the ISA is in the picture any more due to the removal of the smart host.

ANy more ideas? all so do I need WINS the analyser check tool for 2003 has suggested it is need for short name look up.  I run DNS only and al machines are 2000 or above?

Thanks Benjamin
0
SembeeCommented:
You need to verify whether the two servers can connect to each other.

Ping the other server (from both) by IP address, name and FQDN.

Then try a telnet test. Again from each server to the other

telnet server 25

Replace server with the IP address, name and FQDN in turn.
This will confirm connectivity between the servers. If it fails, then there is an issue with the connectivity.

As for WINS, Microsoft seem to be very reluctant to let go of it. I run a number of Exchange installations without WINS and they have no problems - except failures within Microsoft tests.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
benjaminAuthor Commented:
Simon

It turned out to be port 25 through the PIX that caused the conectivity issues.  The network guy who tested it still can not believe he missed it.  I tested it myself and saw straight away that that I could not telnet.  

However you supplied some very good info and pointed me to self test in effect with your last comment. SO you get the points.  

As a side question can you offer any advice on the receipient policy.

2 server, 7 domain names coming in.  I assume I should create seperate policies for each gourp of people who want a given set of addresses?

Thanks
0
SembeeCommented:
I tend to just add the domain names to the default policy. This makes life easy. The only thing with adding the domains to the same policy is that all users get email addresses on all the domains - you then have to adjust the addresses by hand to control which address is default and thus goes out on all email messages.

Simon.
0
benjaminAuthor Commented:
Ok thanks for all the above Simon.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.