Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 634
  • Last Modified:

ARITHABORT Error

When i run a DTS package- which was correctly working earlier, I get the following error.
INSERT failed because the following SET options have incorrect settings:'ARITHABORT'
All that this package is doing is loading a flat file to a table.

I had created an indexed view based on the table. After which i truncated the table.

Since I was getting this error, I deleted the indexed view.

However, the error still persists- what should I do to fix it?
0
aswam1975
Asked:
aswam1975
  • 4
1 Solution
 
aswam1975Author Commented:
I tried that- i still get the same thing
0
 
aswam1975Author Commented:
I think the problem is that i created an indexed view with a table, then truncated the table and I am now again trying to load the table with new data.
I tried SET ARITHABORT OFF from query analyzer- and then tried running the package but i still get the same error
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
aswam1975Author Commented:
would like to delete the question - as i solved it by removing the indexes on the view
thanks
0
 
Anthony PerkinsCommented:
>>I think the problem is that i created an indexed view with a table<<
Yep that is it.

>>as i solved it by removing the indexes on the view<<
There is a better approach: You can
SET ARITHABORT ON
in your DTS package. See here for more details:
SET Options That Affect Results
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/createdb/cm_8_des_05_1ng3.asp

>>I tried SET ARITHABORT OFF from query analyzer- and then tried running the package but i still get the same error<<
Right, they are different connections.

>>would like to delete the question<<
If you still want to delete the question, see here:
I answered my question myself. What do I do?
http://www.experts-exchange.com/Databases/Microsoft_SQL_Server/help.jsp#hi70
0
 
aswam1975Author Commented:
thanks for the useful links
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now