• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8921
  • Last Modified:

Windows Installer hangs

Whether I am installing or uninstalling certain programs, such as .Net 1.1, msiexec hangs and I have to kill the task eventually (I have waited over 2 hours before) - I tried to install Service Pack 2 again and it hanged on the last part, starting services.  I am at a loss and know I probably haven't given enough info yet, but am at wits end.  This is my last stop prior to reformatting and starting over.
0
britchey
Asked:
britchey
  • 11
  • 9
  • 5
  • +2
2 Solutions
 
LeeTutorretiredCommented:
0
 
britcheyAuthor Commented:
Tried that - did not fix.  
0
 
britcheyAuthor Commented:
The problem, I think, is a corrupt installer - but I don't know how to uninstall or repair it
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
SheharyaarSaahilCommented:
Hello britchey =)

>> The problem, I think, is a corrupt installer - but I don't know how to uninstall or repair it
This MSKB article has the Instructions to Re-register and Reinstall for Windows Installer >> http://support.microsoft.com/?kbid=324516
Good Luck :)
0
 
sunray_2003Commented:
Hi britchey,

So do you have only Sp1 now ?

Not sure if this version cleanup utility is same as what Lee had suggested. Download this and run
http://support.microsoft.com/default.aspx?scid=kb;en-us;290301

0
 
sunray_2003Commented:
Other than installing programs , is your system working normally.

you might want to try this too

boot to normal mode
go to start --> run--> msconfig

go to startup tab and disable all applications except anti-virus and firewall
go to services tab and check "hide microsoft services" and then uncheck all services there

restart and check how it goes in normal mode ..

Also make sure you are free of virus and spyware in the system
0
 
AraxCommented:
I would be curious what all is running in the background. Have you cleaned out any spyware/virus's that may be resident in memory?

I would boot into safe mode with networking before trying the following.

Try using http://housecall.antivirus.com for a free online virus scan, it will detect worms and such. I have seen several here lately that block many of the windows updates from installing.

Then download spybot search and destroy and clean out anything left over in the way of spyware/malware. You can get it from cnet at
http://www.download.com/Spybot-Search-Destroy/3000-8022-10122137.html?part=dl-spybot&subj=dl&
Just be sure to do the updates before you run it. this will usually clean everything up enough to get the service packs and updates in. Since sp2 is hanging at starting services, in spybot after everything is cleaned up, go into advanced mode, choose tools, and choose system internals, then have it run a check and clean all of that up. all of this and one more trip through sp2 should fix it.
0
 
britcheyAuthor Commented:
No virii, no malware, no spyware.  I keep very close tabs on what is on my computer.  This could have been a leftover result of reinstalling of the os without reformating.  I wanted to keep my apps and settings.  Everything else works fine.  I am trying the methods above and will get back with my results.
0
 
britcheyAuthor Commented:
Had some success with what  SheharyaarSaahil suggested - however, still can't update or uninstall .Net 1.1 - hangs when attempting to update.  Maybe it isn't Windows installer?
0
 
sunray_2003Commented:
have you tried to uninstall .net going to safe mode.. make sure to login as admin in safe mode and try uninstalling..
0
 
SheharyaarSaahilCommented:
Disconnect from internet and Disable the AV and Firewall software and then try ??
0
 
SheharyaarSaahilCommented:
Also you should try running Disk Cleanup on your hard drive to cleanup the temp and junk file and then delete the files from C:\Windows\Temp folder
a Chkdsk /r will also be a good thing to do :)
0
 
britcheyAuthor Commented:
Can't uninstall in safe mode - tried disabling AV and firewall, no effect - deleted temp folder from c:\windows as well as under my profile under documents and settings, no effect.
0
 
SheharyaarSaahilCommented:
hmmmm have you tried running a SFC scan yet ??
Goto START>RUN and type, cmd  (hit enter)
now type, sfc /scannow  (hit enter)
SFC scan will start scanning ur system
u will need ur WinXP CD in order to fix the corrupted windows system files, if found by scan.
0
 
sunray_2003Commented:
Do you have a different admin account in the same machine.
can you login to that account and see if you can remove framework .
If you donot have another admin account , create one and test in it
0
 
britcheyAuthor Commented:
Tried both of those - neither worked - I am now trying to just get into my pre-boot menu to reinstall the OS (I have an IBM Thinkpad T40p) - I posed another open question dealing with the "NTLDR COMPRESSED" error I get when attempting to get in that pre-boot menu.
0
 
SheharyaarSaahilCommented:
hmmmm i have posted there..... let's see what will happen! :-\
0
 
britcheyAuthor Commented:
Gave you the points there - but this one is still a quandary.  If someone can figure out before I get the recovery CD, I will award them all the points.  Otherwise, I will share them with the ones from which I have gained the most information :)
0
 
sunray_2003Commented:
britchey,

So you are going to work on the reinstallation of the OS ?
0
 
SheharyaarSaahilCommented:
brit.... your windows installer service is started and running in start>Run>services.msc..... right ??
0
 
britcheyAuthor Commented:
I am resigned to reinstall if I can't resolve this.  However, the recovery cd won't come in until Tuesday or Wednesday, so I am just hedging.  

The installer runs, but hangs at different times - sometimes while "gathering information", sometimes when installing or uninstalling an app.  I also notice that there are multiple msiexec.exe's running - usually 4 instances.  Before I installed SP2, .Net 1.1 was installed.  I then (for a reason I can't remember off-hand) did a repair with a different Windows XP disk than the original (it was preinstalled) - the repair was with a CD with SP2 included.  Since then, the msi problem has been constant - Windows update thinks that I need to update to .Net 1.1 again, but, again, hangs when attempting to install.
0
 
britcheyAuthor Commented:
SheharyaarSaahil:  Windows Installer is set to "Manual" under services - should it be automatic?  It does start when I do something to trigger it - installing or uninstalling.  And - it still hangs when it is started.
0
 
SheharyaarSaahilCommented:
>> I also notice that there are multiple msiexec.exe's running
that's the problem.... why multiple files, there should be only one msiexec.exe at one time....!!
hmmmmm ok when in services.msc the Windows Installer service should be stopped when you will view it..... try to hit on Start...... does it start or hangs ??
0
 
britcheyAuthor Commented:
It starts when I hit start
0
 
SheharyaarSaahilCommented:
brit is the problem solved or what..... ??
0
 
britcheyAuthor Commented:
Solved in the sense that I reinstalled and the problem is no longer.  :)  Gave points based on worth of answer (I got some information that will help me in the future)
0
 
SheharyaarSaahilCommented:
hmmmmmm :)
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 11
  • 9
  • 5
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now