cannot install .msi file

Hi,

I got a strange problem that I could not install .msi file which I downloaded from microsoft web site. The file is OK, not corrupted, I tried to install on another WIN2K machine, it's OK. But not my machine.

The file is ASP.NET Commerce (CSVS) Installer v1.0.msi. I checked the installer service, it's running, and the version is 2.0. I tried to install a msnmessger.msi, and it's no problem.

ASP.NET Commerce (CSVS) Installer v1.0.msi needs to talk to SQL server and IIS server, both servers are running OK. Could anyone help me?

The error is:
Installation incomplete
The installer was interrupted before ASP.NET commerce could be installed. You need to restart the installer to try again.

Thanks.

LVL 11
lijunguoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KaliKoderCommented:
Hello lijunguo,

Try clearing your temp files etc and running this again.

- Boot into Safe Mode
- Clear your temporary internet files
- Clear your profile temp directory (Click Start -> run -> type "%temp%" (without quotes) and clean this directory
- Clear your system temp directory (Click Start -> run -> type %SystemRoot%\temp" (without quotes) and clean this directory
- Boot back into Normal mode, try installing again

Thanks and Good Luck!
0
tidydaveCommented:
Hey dude,

   I experienced similar installation problems last night.  
   I couldn't install MSN Messenger or NetDiag.  It was coming back with some Windows
   Installer error & yes the service was running.

   The solution was to go START > RUN
   Then enter "msiexec /unreg" then click ok

   Wait a couple of seconds.

   Then go START > RUN
   Then enter "msiexec /regserver" then click ok

   This must force some configuration to occur.  Because after I did this both programs were
   able to be installed.

   Hope this helps :)

   Tidydave.
 
 
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

lijunguoAuthor Commented:
Hi,

I tried both ways and it's still not working. Sql server TCP/IP protocol is enabled. I register windows installer it's still the same. But I could install MSN Messenger. Still trying hard to find the problem. Thanks! Any ideas?

Lee
0
KaliKoderCommented:
Hello lijunguo,

Can you tell me what service pack are you running on your OS. Is it SP 4 ? I would recommend you redo Service Pack 4 on your machine, and then go to http://windowsupdate.microsoft.com and do all the critical updates. You should definitely redo SP4.

Windows SP4 is available from http://www.microsoft.com/windows2000/downloads/servicepacks/sp4/  . Once you have done all the updates, reboot the machine and try the installation again

Thanks and Good Luck!
0
lijunguoAuthor Commented:
Hi KaliKoder,
Yes, I am running SP4. I'll try to reinstall SP4. I've applied for all latest critical updates.

Thanks !
0
KaliKoderCommented:
Thanks Lijunguo, please do reinstall SP4, and then go to the windows update site again and see if you need any more patches, and then reboot and try the install again

Good Luck!
0
lijunguoAuthor Commented:
Tried everything, still no luck.
0
lijunguoAuthor Commented:
Well, after a hard trying and I found the problem, I run the .msi file in a shared folder, even though I have Adminstor right, which caused this problem. After I make a copy and install from another new created file folder and it's running OK. I don't know why. I could install other .msi(not deployed by .NET) file from shared folder and it's running no problem. When I run the .msi file deployed by .NET in shared folder, it gives me that error, I tried from different machines, the result is the same. It took me days  to find it.

I hope any of you could give me explaination, and I will award the points. I don't want to delete this question, someone may have similar problems which they could reference from here.

Thanks!


Lijunguo
0
KaliKoderCommented:
Hi Lijunguo,

Thats weird, can you check on the share permissions on the shared folder that you were trying to run .msi from ? Does it have Everyone Full Control ? What about the NTFS permissions of the file itself ? Does those have anything weird in it ? You should have a thorough look at it, by clicking on the advanced button, and checking if there is an explicit deny for anything or if there are any special permissions. Basically, I would be inclined to compare permissions on both locations and see what makes the msi run in one location and not all. Do you also have some sort of GPO at domain level which says .msi files can be run, but only from a "specific" location ?

Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lijunguoAuthor Commented:
<<Does it have Everyone Full Control
For the shared file folder, I deleted Everyone from "security". I only allow a few users can access to that shared file folder.

That's the point. For non shared file folder, there is Everyone Full Control and it's no problem to install the file.

Thanks a lot!
0
KaliKoderCommented:
You are welcome! glad it worked out :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.