Communication Error When Printing

Hello Experts!

I am installing a printer(EPSON 6200L) on a server machine and setting it as a shared printer for network purposes.  I do a test print on it and it works fine.  

On a client machine, I added that shared printer.  Then I do a test print but it will just keep on spooling for 1-2 minutes then print the document but a popup message will appear stating that "Communication Error... ".  I wonder why this error comes up.  In fact the document has been successfully printed.

Do you have an idea why this popup message appear???

Any help is highly appreciated...


Regards!
eNTRANCE2002 :-)
LVL 14
Renante EnteraSenior PHP DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

smiffy13Commented:
maybe the client PC has a firewall installed which is preventing the server PC from successfully sending a message that the page printed. Can you ping the client PC from the server PC? Is communication between the 2 PC's good? can you try and transfer a file both ways?

Another thing you could try - reinstall the printer driver on the client PC from the printer driver PC.
0
jonoakleyCommented:
You don't mention the OS of the server and you didn't state the form of network connection.
So I will hazard a guess of Server NT/2k/2K3 and the printer connected to the PC acting as a server.

If this is the case open the properties page for the printer in question at the server. Click the Ports tab and near the bottom you will see a box labeled Enable bidirectional support. Remove the check if it exist.

Some USB Print Servers handle this feature. If you have a Print Server device, please list the device name and model.
0
Renante EnteraSenior PHP DeveloperAuthor Commented:
Ooooppppsss...  I forgot to mention additional information.

Actually, there are other network printers installed but haven't encountered the same problem with what I've specified above.  Some network printers are EPSON C-65 and HP Deskjet 670C.  In addition to that, all machines are running on Windows 2000 PRO.

---------------
To smiffy13 :
---------------
  -  NO firewall installed
  > Can you ping the client PC from the server PC?
     -  I can ping the client PC from the server
  > Is communication between the 2 PC's good?
     -  Since, can ping so no communication problem.
  > can you try and transfer a file both ways?
     -  NO problem on file transfer
  -  I have already reinstall printer driver.  In fact, I have reviewed the installation guide.

----------------
To jonoakley :
----------------
  -  I apologize for the delay on posting the additional information.
  -  NETWORK CONNECTION is just basic.  ONE hub and all workstations are connected on it.
  -  I will try what you have suggested regarding "Enable bidirectional support".
  -  What do you mean about this ???
     > Some USB Print Servers handle this feature. If you have a Print Server device, please list the device name and model.


Thanks!
eNTRANCE2002 :-)
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

wyliecoyoteukCommented:
Sounds like a GDI printer issue.
GDI or "windows" printers rely on the host machine`s CPU for print job rendering, and so are not very good at network printing (or any printing at all, really).
They are also very OS dependant. (i.e. many of them will only work on one version of windows)
The 6200L seems to be a cutdown version of the 6200, so this may be a similar problem.

Ways to improve things:

1. In the print driver on host and client machine, disable bidirectional communication.
2. On host and client, if applicable, set spooling to "start printing after last page has spooled".
3. If possible, add more memory to the printer.
4. In windows 2k or XP, disable "advanced printing features"
5. Use a proper laser printer with it`s own processor.

0
jonoakleyCommented:
How is the printer connected to the network?
Is the printer connected to a PC/Server and shared or is the pinter connected directly to the network through a network card or a Print Server device attached to the printer?


The 6200 is a USB printer so you will need a USB print server? I currently have a Epson 5200 and lucked into a USB print server from AirLink that only cost about $10 US and is working very well.

http://www.airlinkplus.com/networking/ps.htm
0
Renante EnteraSenior PHP DeveloperAuthor Commented:
I have already tried everything to fix this problem but to no luck.

To wyliecoyoteuk:
   I also did what you suggested except on adding more memory to the printer.  How can I add memory on it ???

To jonoakley:
   Actually, EPSON EPL-6200L can be connected to a USB or parallel port.  I think I don't need a USB print server.

Info about the said printer is on this site : http://www.epson.com.au/products/home_and_office/epl6200L.asp


Regards!
eNTRANCE2002 :-)
0
wyliecoyoteukCommented:
looking at the brochure, the 2Mb standard memory is all that is available.
also, the printer language is described as "host based" this means that it is a GDI type  printer.
It is very unlikely that it will work properly with anything but a direct usb or parallel connection.
It may help if you use a usb port.
If you are using a parallel connection, ensure that the port is set in the bios to ECP, as the brochure states that it uses Nibble + ECP  mode.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hdhondtCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave a recommendation in the Cleanup topic area that this question is:
Accept wyliecoyoteuk
Any objections should be posted here in the next 4 days. After that time, the question will be closed.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

hdhondt
EE Cleanup Volunteer
0
Renante EnteraSenior PHP DeveloperAuthor Commented:
Sorry for the delay!

Actually, I've tried everything in order to resolve this issue.  An of course, followed those suggestions mention in here especially from "wyliecoyoteuk".

As a result, I decided to use "DIRECT USB CONNECTION" instead of "PARALLEL CONNECTION".  And it's working now.

Thanks for your time on helping me.


Regards!
eNTRANCE2002 :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.