Server Filter By Form Disables All Fields

I have an Access Project connected to a SQL Server 2000 backend. I have two development machines (one at home and one at my client site) that I use to maintain the project - one has Access XP and the other Access 2003. I have a form that has the "Server Filter By Form" property set to True so it opens up in the filter mode. This works fine on the Office XP machine, but on the 2003 machine when the filter form opens all the fields are disabled, so no filter can be applied. It is essential for it to open in the filter mode to allow the user to restrict the records they retrieve as they may be connecting from a remote site. Any ideas?
LVL 2
ChrisThorntonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arcrossCommented:
When that form opens in 2003 has a recordsource associate to it? maybe for any reason that recordsoruce has gone, i say this cause the only thing i cant think now is that the controls are unbound. Just a thought

Álvaro
0
ChrisThorntonAuthor Commented:
As soon as I press the "Apply Filter" button all the records show, so I guess the connection and the recordset are OK. I have tried setting the .enabled property of the controls manually in the Form_Filter event. They show as Enabled in the event, but as soon as I step out of the event they are reset back to false.
0
arcrossCommented:
When you do a filter the forms keeps the last filter string on it, could it be that when you apply the filter as soon the form opens has a field with sometging on it? If you do me.filter = "" it woud clean it.

Well, but i wouldnt let them disable Hmmm
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ChrisThorntonAuthor Commented:
Nothing in there I'm afraid. Tried setting me.filter = "" but no luck.
0
arcrossCommented:
if the OPEN event instead of your "server filter..." you do: (remove the property you have set to TRUE)

DoCmd.RunCommand acCmdFilterByForm

What does it come with?

0
ChrisThorntonAuthor Commented:
Tried this, but it applies a client-side filter. I need to use a server filter to avoid the unnecessary records being sent to the client over the WAN. So I tried

DoCmd.RunCommand acCmdServerFilterByForm

but I get Error 2046 - The command or action 'ServerFilterByForm' isn't available now.
0
arcrossCommented:
Hi Chris, I found this in internet too see if it can help you cause to be honest i dont know why, but this makes sense.

http://support.microsoft.com/kb/q283362

Álvaro
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ChrisThorntonAuthor Commented:
Thanks Álvaro.

There was I thinking you could just set a property in design mode - when in fact you have to set it in code, twice!

Chris.
0
arcrossCommented:
Hey Chris well done!

Glad it did work !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.