• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 411
  • Last Modified:

Slow response time with open, save as, or insert into on Windows XP Pro

Why does client system take so long to open, save as, or insert into a file on the server?  We have new Dell Optiplex workstations.  Operating system is Windows XP SP2 (problem existed before SP2 was installed).  Office 2003.  When I try to insert a file into Outlook, or open a file in Excel, or save as (in any program) the appropriate window opens (Open, Save As, for example), but when I select "Look in:" and try to select a location response is very slow.  System may take up to more than a minute to show the folders in the selected location and may take up to three minutes to drill down through the folders and open up the desired file.  Is there a fix?  
0
powellh
Asked:
powellh
  • 3
1 Solution
 
stevenlewisCommented:
try this
http://www.tweakxp.com/TweakXP/display.asp?id=1557

Create a text file on the server put this into it:



Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]

"SizReqBuf"=dword:0000ffff



Save the file as WHATEVER.REG not WHATEVER.TXT

Then double click on the file to apply the setting (once again on the SERVER not the pc).

What this does is it sets the DIR commad's buffer from 14000 to 65000. This fix works on NT/2000/XP.


0
 
sunray_2003Commented:
Hi powellh,

When you are trying to open file or save file or attach file , are those files in the local computer or in the server ..
If it is the server , then you need to check your network speed and connection.
if it is in the local machine , then make sure you donot have any virus or spywares that might be affecting this .

Try to create a new user account in the same machine and see if that same happens and if it all well and good then your original user account profile might be corrupted.

Try to close all applications , check the task manager and kill all the application process that you might not be using and see if that would help .


SR..
0
 
stevenlewisCommented:
also
After installing Service Pack 1 on several of my Windows XP workstations, I noticed a dramatic reduction in network performance when communicating with my Windows 2000 servers. Although everything worked fine with small files, when I tried to access, create, or modify a file over 70 KB, I would get a file creation error, a delayed write failure, or some other odd error. After a little digging, I discovered that my Windows 2000 servers were holding the files open even after I had closed them, thus making it impossible to modify the file. Unfortunately, these file lock problems often occurred while the file was open, resulting in a corrupt file.

I first suspected faulty hardware—a bad network cable or hard disk ribbon. Yet after months of experimenting, I determined that my hardware was working perfectly. Since I have almost 20 computers and only PCs running Windows XP with SP1 were experiencing these communication errors, I decided that SP1 must be the culprit. I began researching the problem and after months of searching I found three potential solutions.



Word of warning

The following article suggests ways to edit your system registry. Using the Windows Registry Editor incorrectly can cause serious problems that could require you to reinstall your operating system and you could possibly lose data. TechRepublic does not and will not support problems that arise from your editing the registry. Use the Registry Editor and the following directions at your own risk.





XP has trouble writing to 2000 domain controllers

Unfortunately Microsoft's support Web site doesn’t list Windows XP SP1 problems in a single location so I dug through its knowledge base until I found article 321169, "Slow SMB Performance When You Copy Files from Windows XP to a Windows 2000 Domain Controller."





According to the article, Windows sometimes has problems writing to domain controllers, but should have no trouble reading from domain controllers. Alas, I was having trouble reading and writing to Windows 2000. Sometimes it would take a full 60 seconds for Windows XP to open a 50-KB file that was stored on a Windows 2000 domain controller. Other times though, the same file would open instantly. Although this knowledge base article didn't address my exact problem, I decided to follow the instructions and see what happened.

The article suggests that the slow performance results from a delayed TCP/IP acknowledgement occurring in an SMB: C NT Transact-Notify Change packet. To put it simply, Windows 2000 uses what are known as SMB security signatures. If security signatures are enabled, the redirector is forced to wait until the current SMB command has completed before processing the next one. This means waiting for an SMB acknowledgement from the server. The easiest way to implement a workaround to the problem is simply to disable SMB security signatures on the domain controller by editing the registry.

To do this, open the Registry Editor and navigate to HKEY_LOCAL_MACHINE\System\

CurrentControlSet\Services\LanmanServer\Parameters. Double click on the RequireSecuritySignature value and enter 0 in the Value Data dialog box. Next, double-click on the EnableSecuritySignature value and enter 0 in the Value Data dialog box. However, this registry modification didn’t correct my particular problem.

Possible task scheduling bug

I decided to turn my attention to the Web and see if anyone else was having the same problem. A quick search revealed dozens of Web pages where people discussed similar problems. One of the suggested fixes involved a bug that exists in both Windows XP and in Windows 2000. The bug causes Windows to check for any scheduled tasks that might exist on a remote machine before displaying the browse contents.

This particular bug is also controlled by the registry. To solve the problem, just remove the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\

Explorer\RemoteComputer\NameSpace\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}. This registry fix did speed things up somewhat for me, but didn’t completely correct the problem.

A solution at long last: SMB signing incompatibility

Finally, after another month of digging, I discovered MSKB article 331519, "Network File Errors Occur After You Install Windows XP SP1," in which Microsoft acknowledges the problem. According to Microsoft, the problem is related to an incompatibility in SMB signing between Windows 2000 and Windows XP SP1. It appears several group policy settings are to blame.

To fix the problem, go to a domain controller and open the Active Directory Users And Computers console. Then, right-click on the Domain Controller organizational unit (OU) and select the Properties command from the shortcut menu. Doing so will display the Domain Controllers Properties sheet. Select the Group Policy tab. Select the Default Domain Controller Policy (or what ever group policy applies to the domain) and click the Edit button. Navigate through the policy to Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options. Then, locate the following four policy settings and change them to Disabled:

Digitally Sign Client Communications (Always)

Digitally Sign Client Communication (When Possible)

Digitally Sign Server Communication (Always)

Digitally Sign Server Communication (When Possible)



Close the Group Policy Editor, click OK, and close Active Directory Users And Computers. After you apply the settings, wait for the next replication cycle to complete and the settings should take effect. Once the settings took effect on my system the communication problems disappeared. Rumor has it that Microsoft intends to correct this issue in the next Windows XP Service pack.





0
 
stevenlewisCommented:
and one more
more
http://cyberwizardpit.net/article2.htm
Here's a great tip to speed up your browsing of Windows 2000 & XP machines. Its actually a fix to a bug that by default of a normal Windows 2000 setup that scans shared files for Scheduled Tasks. And its turns out that you can experience a delay as long as 30 seconds when you try to view shared files across a network as Windows 2000 is using the extra time to search the Remote Computer for any Scheduled Tasks. Note that though the fix is originally intended for only those affected, Windows 2000 & XP users will experience that actual browsing speed of both the Internet & Windows Explorers improving significantly after applying it since it doesnt search for Scheduled Tasks anymore. Here's how :

Open up the Registry and go to :

HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/Current Version/Explorer/RemoteComputer/NameSpace

Under that branch, select the key :

{D6277990-4C6A-11CF-8D87-00AA0060F5BF}

Right click it and select "Delete".







This is key that instructs Windows to search for Scheduled Tasks. If you like you may want to export the exact branch so that you can restore the key if necessary. This fix is so effective that it doesn't require a reboot and you can almost immediately determine yourself how much it speeds up your browsing processes.

Important

Note : This branch also exists in both Win98 & ME and Ive got so many mails asking me whether it's safe to apply the fix on it. However, I would like to warn users that the fix is intended only for Windows 2000 and XP. If you decide to try it for your Win98/ME system, pls make sure that you back up or export the exact branch so that you can restore the key if something should go wrong. Currently there are more than 20 users that have tried the fix in Win98/ME. Out of this 20, there are 4 users who reported that problems arises after removing the branch while the balance 16 reported great success.

0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now