[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

SP2 cant find home network

Posted on 2004-11-24
15
Medium Priority
?
354 Views
Last Modified: 2010-04-10
I have a three node home network.  98SE, XP Pro SP1, and XP Pro SP2.  They all have the same workgroup name.  The 98SE and the SP1 are able to see each other on the workgroup.  SP2 will not see that it can connect to the Workgroup even after verifying that the workgroup name is correct and that the IP address is on the same gateway and subnet.

I know that no sane person is going to SP2 yet.  Well I did reluctantly since I could not get a legal copy of XP Pro SP1, and would rather not format my primary drive for the fourth time in the past week to go back to Home SP1.

When I "View the Workgroup computers" I get

"(Workgroup name) is not accessable.  You might not have permission to use this network resource.  Contact the network administrator of this server to find out if you have access permissions.  
The list of servers for this Workgroup is not currently available."


Any help will be appriciated.
0
Comment
Question by:bdmayo
  • 7
  • 6
  • 2
15 Comments
 
LVL 41

Expert Comment

by:stevenlewis
ID: 12668429
enable NetBIOS over tcp and turn off the built in firewall and test
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 12668438
enable NetBIUOs
tcp properties of the LAN connection, advanced, wins tab
0
 
LVL 20

Expert Comment

by:Daniel Van Der Werken
ID: 12668959
Are you using a home-based routerfirewall like Linksys or Netgear or such?

If you can get to the configuration page and lookup the IP addresses for all the machines, you can run a cmd.exe (command console) and type:

ping <ip address> (for example, ping 172.27.5.3)

Another way to get the IP address of each machine is as follows:

For WinXP boxes:  cmd.exe and then run "ipconfig"
For Win98Se, do Start | Run "winipcfg"

Make sure they're all in the same network -- they should all have the same first three numbers with the last number different (xxx.yyy.zzz.different).

If you can ping everyone from everyone, then this gives us a good idea that you're "baseline" connectivity is good.

If push comes to shove and you still can't connect, then simply use the IP address in lieu of the NetBIOS name.  For example, you can connect to another computer via \\172.27.5.3\public_share

That will almost always work.

---Dan---

NetBIOS names let you connect by specifying a machine name.  For example, if you named your WinXP Home Sp2 box "myhomemachine", then you could potentially connect to it by doing Start | Run \\myhomemachine\<sharename>

If NetBIOS is not enabled over TCP/IP, then the system won't be able to make a correspondence between "myhomemachine" and an IP address such as 172.27.5.3.  For this reason, you want to assure you have NetBIOS over TCP/IP enabled on each system.



0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 

Author Comment

by:bdmayo
ID: 12670233
Firewall was not enabled.  Turned on the NetBIOS by installing the protocol of "NW Link NetBIOS".  After a subsequent reboot I was able to see "Localhost name" on the Workgroup and finally able to ping the other computers but not see them as a node of the Workgroup.
As I have been a DSL Support tech for the past three years ( I know I didn't mention that) I knew about how to ping the other nodes.  I have tried to ping them but unsuccessfully till the load of NetBIOS.  I have not yet tried to connect using the method of "\\computername\sharename".
0
 

Author Comment

by:bdmayo
ID: 12670325
After checking I am now able to surf to the IP address of the other nodes of the network and then to the shared drive of the node. I am also able to attach to the shared printer on one of the nodes.  I am still not able to see the other nodes when I look at list of servers in the Workgroup.

Does it not matter and will I have to take the long way around to get to the nodes of the network?  I'd like to consider my issue resolved when I cal open My Network Places and see the other two nodes in the Workgroup.

BTW, Localhost is the XPPro SP2 system.
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 12670655
>>NW Link NetBIOS
is not NetBIOS over tcp
Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.
0
 

Author Comment

by:bdmayo
ID: 12670922
I now have NetBIOS correctly enabled.  "NW Link NetBIOS" has been unistalled. Computer Browser Service was already set to Started\Automatically.  After a reboot, Workgroup servers no longer shows localhost, or any other computer.  

I still get:
"(Workgroup name) is not accessable.  You might not have permission to use this network resource.  Contact the network administrator of this server to find out if you have access permissions.  
The list of servers for this Workgroup is not currently available."

I am still able to ping the other nodes of my network.  As well as surf to the computer using

\\IP address\shared name
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 12671153
OK, now on the pro boxes
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled
not secure, but wil enable shiring, we cann make it more secure lateer
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 12671171
>>I know that no sane person is going to SP2 yet
I have it on all my  XP boxes :-)
0
 
LVL 20

Expert Comment

by:Daniel Van Der Werken
ID: 12671189
Make sure the "Computer Browser" service is up and running.  It's a service you can access via Service Manager (right-click My Computer, Manage, Services).  The Browser service is what handles the NetBIOS name handling for Workgroups.
0
 

Author Comment

by:bdmayo
ID: 12671365
Ah ha. I hadn't ever heard of the "Network Access: let everyone permissions apply to anonymous users" resolution.  I now have it enabled and will try it.

What all network admin friends of mine are telling me is that SP2 causes too many problems to be considered for instituting.  Besides, my wife is a programmer and has found that SP2 disables many of the MS programming tools that she has.


Dan,
Thanks but Steve mentioned that in his 6:11PM EST post.  It was already enabled.
0
 

Author Comment

by:bdmayo
ID: 12671428
Sorry, didn't work.  When I check for Workgroup computers I still get:

"(Workgroup name) is not accessable.  You might not have permission to use this network resource.  Contact the network administrator of this server to find out if you have access permissions.  
The list of servers for this Workgroup is not currently available."
0
 
LVL 41

Accepted Solution

by:
stevenlewis earned 2000 total points
ID: 12671437
time for the troubleshooting web site
http://65.24.134.81/KipSolutions/P2PNetworks/TroubleshootingP2P.htm
thanks FE
0
 

Author Comment

by:bdmayo
ID: 12672039
Troubleshooting site said to run the tool diagnostic.  Which I didn't know existed.  Result is that it was unable to ping the IP address of localhost.  I was however, able to ping 127.1.0.0.

Issue resolved.  

Norton Internet Security was installed but disabled.  Upon recopnfiguration of the disabled Norton IS I was finally able to ping the IP address of localhost.  after getting a successful ping of the IP I was able to see the other nodes on the network.

Thanks Steve.

Thanks for the try Dan.
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 12674253
Glad we could help!
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will inform Clients about common and important expectations from the freelancers (Experts) who are looking at your Gig.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question