printing to a local printer when using RDC

I have a sort of emergancy...
I need to print a document that i am viewing on a remote computer (using RDC) to a local printer (Physically connected to the computer i am sitting at).

The remote computer is running windows server 2003 and the local is Win xp pro

Thank you so much
LVL 1
MichaelSwitzerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

luv2smileCommented:
Is your computer on the domain? If so then just share the printer out and then add it to the windows 2003 server as a networked printer.
0
cfairleyCommented:
You should be able to turn on printer mapping on the 2003 server to automatically map the printers that you have on your local PC.
0
MichaelSwitzerAuthor Commented:
I am doing all of the RDC through the internet... We are physically 20 miles away... does your information still apply?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

cfairleyCommented:
Here is the ultimate guide to TS Printing.

http://www.brianmadden.com/content/content.asp?ID=62
0
brownmattcCommented:
To enable printing there is two things you need to check:

1.  When you connected to the termainal server you first launced the RDP client (mstsc.exe).  There was an options button and on the local resources tab you have to click Printers.

2. Printers must not be disabled from mapping on the server.  Do the following on the server:
  a. Click Start -> Run -> Type MMC
  b. Click Console -> Add/Remove snap-in
  c. Add Terminal Server Configuration
  d. Expand connections
  e. Right click on RDP-tcp and select properties
  f. On the Client Settings tab make sure that Windows Printer Mappings are not disabled

You should now be able to connect and have your local printer used.

There is one other way you can try.  If you are already connected to the server you can share your local printer on your machine.  Give it an easy name to type.  Open a command prompt and type the following: net use LPT1 client\SHARENAME - Replace sharename with the name of your printer share.  You should not be able to print to LPT1 and it should come out on your local printer.

Let me know,

Matt
0
MichaelSwitzerAuthor Commented:
my internet went down (because of snow :))...  brownmattc i am trying your solution
0
brownmattcCommented:
Move to Hawaii.  We don't have that problem.
0
MichaelSwitzerAuthor Commented:
Matt,

     I am having an issue.    Printers are enabled from mapping on the server. ( per your step 2)
I would like to be sure that we are on the correct page. (Thanks again for your help!!)...
I am essentially setting up a point of sale computer that is out side of the place of business. The location of the server that i am remote desktop connecting to is about 20 miles away. So, i can log on (through the router at the business) from any location that has the internet. I have a point of sale printer hooked up to the computer that will be remotely administrating the server (at the business location) **The reason for this is a Kiosk at the local mall, that we set up, needs to be able to sell items and giftcards. the only way to do this is by setting up a point of sale at the mall (that is connected to the place of business.** If you still agree with what you said a little bit ago, would you be so kind as to elaborate the steps i need to take and with which computers i need to take them.

Thanks again
Mike
0
brownmattcCommented:
Hey Mike,

If you need to print to a printer connected to the Kiosk then you may need to check the options that are selected when you launch the RDP client (mstsc.exe) on the Kiosk.

Start -> Run -> MSTSC.exe
Click the Options button
Under Local Resources make sure that printers are checked at the bottom.

The printer should now be automatically created when you connect.

As long as printers are NOT disabled (step 2 above) and the option to connect them is checked on the RDP client (mstsc.exe) then they should connect automatically.

If they do not then try adding the printer driver to the server and it should connect.

To add the driver to the server:
Start -> Settings -> Printers
File -> Server Properties
Click on the Drivers Tab
Click the Add button
Add the appropriate driver.

Let me know,

Matt
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MichaelSwitzerAuthor Commented:
Matt,

      The last solution did it for me. Thank you so much for your help.  15 other people appriciate your cooperation.

                                        Many thanks,
                                               Michael
0
mmacdougallCommented:
Matt,

I wonder if you can help me?

I was having the same issue.  Now I can see the printer, but the job just sits there. I have posted a question.
0
brownmattcCommented:
Hey Macdougall,

Not sure where your other question is but try checking the printer driver.  Make sure that it is the same on the workstation and on the server.

If a PCL driver doesn't work try the PS version of the driver or vice versa.

If you are using Citrix you can also add a printer driver mapping....

Matt
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.