Cyrillic characters in Access table

Hello,

I'm using Access-based ADO tables in my Delphi application. Some fields can contain Russian (cyrillic) characters. When I run it on a computer with Russian default system locale, everything is OK. But when the default system locale is different (English), all the cyrillic characters turn into question marks. Is there any way to provide that they are treated properly under any system settings?

Vadim Smolensky,
Saint-Petersburg, Russia
VSmolenskyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BlackTigerXCommented:
you need to have that language added to the "Language settings for the system"

even if that is not your default language

your default language can be english, but you need to add Cyrillic to the list

open Regional Options in the Control panel, General Tab

at the bottom there's a list called ""Language settings for the system"", check Cyrillic
0
VSmolenskyAuthor Commented:
No, it's not my case.
I haven't mentioned that this problem arises only when I run my application under Windows XP. In your post, you definetely meant another version (probably 2000). There's no "Language settings for the system" in XP but there's a list called "Code page conversion tables". On my computer, all the cyrillic checkboxes in this list are checked. And all the cyrillic letters appear properly - except for those extracted from the Access database. Therefore, I think it's a problem of Access rather than the whole system. Under Windows 2000, this doesn't happen.
0
BlackTigerXCommented:
in Windows XP would be "Regional and language options" in the control panel

then in the language TAB, suplemental language support check both boxes, that might fix the problem, seems like in XP most languages are preinstalled and you just have options for right-to-left languages and east asian languages
0
VSmolenskyAuthor Commented:
What are you talking about? Russian ISN'T a right-to-left language! It's a Indoeuropean language with just different letters. And, again, these letters look absolutely OK except those taken from Access database.
0
BlackTigerXCommented:
right, I didn't say that...

if it seems to be related only to ACCESS you might want to try posting in a different category

I found this in the MSACCESS category, it was accepted as the correct answer:
" Access doesn't have a crylic option for record storage.
It must be stored as a memo field or text etc...."

http://www.experts-exchange.com/Databases/MS_Access/Q_21096766.html?query=cyrillic&topics=39
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.