[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 149107
  • Last Modified:

Enable Folder redirection (My Documents) and Offline Files/synchronize Enables! I want absolutely NO offline/synchronize.

Ok, here it is. I bought this service today to test out my problem here in Windows I have spent over 40 hours working on, it is driving me absolutely nuts. I am going to try and document in detail all the goodies, please help!


Windows 2003 Server as domain controller running active directory with Windows XP SP1 clients connecting to it, all on a single domain. I have about 1200 students and 100 staff accounts in active directory and 450 computers broken down into labs.

Here is my goal... I want to extend my group policies for the students so that the My documents folder on the local machine is redirected to their own user folder on a server and have it updated in real-time...no syncronization or offline files gestappo or caching or buffering.

What I have completed... I have each user in active directory have their own home folder. On the users properties, under profile I have a Home Folder via the Connect (z:) then path \\server\share. What this does as far as I can see is when the user logs into any computer via their account, it maps the drive Z: right to their \\server\share\userfolder and it has all their goodies (files) inside it. Very nicely done, no hassles.

...continue...I have then edited their group policy for students on folder redirection on My Documents. I have chosen a "Basic-Home directory" method. User logs in, the my documents points to their home directory...also the same as the Z drive. Here is my problem...it puts offline files/synchronize icons on all the z:-my documents folders/files and syncs up at logoff. I do not want this.

Problem...Ok, so there is Offline files Group Policy for computer AND user and they have lots of options. I have tried simple combos and extensive set all options to not allow/show offline files and it still wont stop syncing. I even did some slow link detection overrides because supposively it has some factors in making stuff go offline. I have spent over 40 hours working on different setups and options trying to make it quit. The closest I have come is to have the offline files icons not show up on files/folders...but when i log off the stuff syncs up anyways (ahhh!) and I am absolutely sure i chose not to sync up when logging off. I have done numerious setups from doing only 1 option to config all, i am going nuts now. No one has been able to help me so far.



also a problem...it appears that offline files and crap sticks right onto the computer I use and wont change when i change out a policy or user. So i can do a simple change (such as hide Run in start menu), and the policy updates fine to reflect that change...but not for offline files options. How i am getting around this to make sure my policy is spankin new... I have a 10 computer lab and a clean xp ghost image that I use. I log in once to seee new policy settings on a computer, then log off and re-ghost it with a new image. That way I am super shure the computer isnt tainted. I dont know why, but it appears that only the offline options stick to the computer even after deleting the folder in c:\documents and settings and I have to reghost it. Other stuff like i say hiding Start/run or ctrl alt delte-log off/processmonitor/lock comptuer take effect immediately when i update policy.

plz help!
0
atkfrg56
Asked:
atkfrg56
  • 7
  • 2
  • 2
  • +6
1 Solution
 
atkfrg56Author Commented:
I just got done trying some more ideas I had on this, still no luck :(. The mini offline sync icons disappear on files/folder but it still syncs at logoff, idk.  if anyone has maybe a set of policies they used and can post that has my documents redirected to \\server\share\userfolder without offline files synchronization being used, please post then and I can test them out like friday or monday.
Thanks
0
 
dmoxCommented:
Why don't you edit the office settings to redirect their My Documents folder?  Example, in MS Word click Tools->Options File Locations Tab and change where the Documents and Templates are.  Same thing can be done with Excel and all Office Products.  If you're using Ghost, create an image with the new settings and go from there.  Sometimes the simplest way to do something is the best way....
0
 
atkfrg56Author Commented:
dmox,
That would be an awesome solution but the only downside is that MS Office is one of many applications that would need to get into 'my documents'.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
SembeeCommented:
Changing the offline file settings is one of those things that requires a reboot.
If you disable it by hand you will be prompted to reboot.
Therefore if you are testing and run gpupdate /force it will probably ask you to reboot.

Why don't you just disable offline folders completely?
There is also a GP setting "Do not automtically make redirected folders offline"

Simon.
0
 
Pete LongConsultantCommented:
Im confused? arnt the synced files syncronising with the system32/csc folder?

Pete
0
 
atkfrg56Author Commented:
Sembee,
I am going to load a clean image and try just that specific GP enabled right now. I am pretty sure I tried it, but I am going to load a clean image, apply the policy and restart the computer and see how it does.

Pete,
The files are trying to sync up with the server when the user logs off, I am not sure what the system32/csc is about, but I will take a look in there when the machine is done ghosting. User has Z: mapped to \\server\share\userfolder via the active directory user profile settings... and then once I activate GP folder redirection to the home home directory (basically points my documents to the z: drive) it wants to sync up when user logs off. I have set GP and I cant shake off the syncing.

I will post back soon. :) thx
0
 
atkfrg56Author Commented:
Sembee,
I have redone a clean copy of the client with your GP setting, and it still syncronizes when I log off. It does not mark the folders/files as offline...but it still syncs up at logoff. The good news... it is not trying to sync the entire root directory \\server\share as before...it syncs up just the specific user folder that is logged in such as \\server\share\userfolder.  It also doesnt try to sync up every userfolder of every user that ever loggin onto the machine...it did that sometimes before too.  Also, it is a bit quirky when I do updates to the home directory path in active directory, but re-creating the user and blowing away the 'documents and settings' folder on the local machine fixes it. Sometimes, not always, I have to re-make the shared user folder on the server.

I guess the only other thing, what is the set of group polices to remove the users local stash of the user profile from the local machine (its kept in 'documents and settings')? Please post that and I think I am set.
Thanks
0
 
SembeeCommented:
At the moment I haven't got access to a site where I am doing this... however from a quick look at another GP setup... the minimum I would configure:
(I have shorted them... but you should be able to tell which ones I mean)

Computer\Admin Templates\Network\Offline Files:

Allow Offline - Disabled
Prohibit user - enabled
Prevent use of offline folder: enabled
Remove "Make available offline": enabled
Prohibit make available offline: enabled

User\Admin Templates\Network\Offline Files:
As above, and:
Do not automatically make redirected folders available offline

Simon.

0
 
chumps007Commented:
OK, you have a share called MyDocs on the server.  When each user logs on, their My Documents is redirected there:

MyDocs\User1
MyDocs\User2  etc.

(Obviously this isn't right in terms of naming, but I'm just trying to conceptualise this.)

When a user logs on and off, you're noticing that their My Documents is synching even though you don't want this to happen; you just want it to be redirected without a local copy being kept and synchronised.  

When you right click on MyDocs and go to the Sharing tab, click on Offline Settings.  What is configured in there?  Is it set to "Files or programs from the share will not be available offline"?

Cheers,
Katherine
0
 
atkfrg56Author Commented:
Katherine (chumps007),
sorry, but the sharing tab is removed on My Documents when I enable folder redirection. I found what i think you mean under "setup" when it tries to syncronize at logoff and went into it. I have disabled offline files...and it stops if from syncing up.

I went under local admin, removed documents and settings folders for all users (except 'admin' and 'all users') and logged in again. It continues to prevent syncing up, as it should. One weird thing i notice... if I log in just using User1... then it puts both a User1 and User2 (user2=my other test account) inside documents and settings...as if the users are somehow linked together. I am going to spend tomarrow with clean images and play around with it some more, see if those settings will carry from computer to computer. I am also going to make a completely spanking new set of test accounts.

Simon ( Sembee),
"Prohibit make available offline: enabled" - It asked to specify a location, I added \\server to it so it could be enabled. I have set all of your other options as specified too. I used this on my second image, but it did not seam to do the trick...files sync at logoff. I even enabled under computer policy, DO not sync offline files at logoff in addition to your settings....it has no effect. I am going to do a clean image and try again tomarrow.

thx all
0
 
chumps007Commented:
I don't think that you quite get what I'm saying...I'm talking about on the file share on the server side, not the My Documents on the client side.  The server would have a share called MyDocumentsShare or whatever else it's called, which is where you're redirecting the clients' My Documents to.

In Windows Explorer on the server, find the share where you're redirecting the users' My Documents to, in my example MyDocumentsShare.  Right-click on it and go to the Sharing tab.  Click on the Offline Settings button on this tab.  Then make sure that it has "Files or programs from the share will not be available offline" selected.
0
 
atkfrg56Author Commented:
Katherine (chumps007),
Thx for the updated post, I understand now and tried it out.  It indeed works, thanks.

 For some strange reason, I am having issues where it is not mounting the homedirectory set in active directory to the drive letter specified as it used to...I dont think its because of the offline files. Existing users and users added using dsadd scripts will not mount the drive, new users created manually work fine.
0
 
atkfrg56Author Commented:
Ok. I have got it perfect! Thanks for all the help!

1. Katherine (chumps007) and make the offline files via sharing tab on server so it cant be offline.
2. add to script "net use \\server\share\userfolder"
3. Group Policy - Redirection of My Documents - Basic - Create a folder for each user under the root path - \\server\share (it auto appends \username\my documents to it)


This way the My Documents ponits onto user share...they have a mapped drive letter...and absolutely no gestappo offline files/syncronizing of stuff.
0
 
nonsCommented:
i haven't read through all the posts cus i need to get going to a job interview in like 25min lol. but here's my input...

have you tried to setup roaming profiles for domain users?
that would involve setting up a public share, telling active directory where each user profile is to be kept, and then AD will do the rest.

also when you make the share, disable offline caching so that AD profiles and the offline caching feature for file sharing dont interfere with each other. because they are two different things all together.

in such a scenerio AD will sync local profiles with the shared folder on the server.

you can also use GPO to disable local profile caching and run it all over the network with the shared folder for roaming profiles. but rememer.... constant syncing between local and remote profiles means heavy increase in network usage. especially if someone decides to put a giant 700mb divx movie in their my documents folder. that is why you might want to limit profile sizes to 30mb or less to force users NOT to keep movies and mp3's and other stuff that is really big in their folders.
0
 
MarkusKolbeckCommented:
Just a note (to achieve the same result):

in the GPO
- User Configuration
- Administrative Templates
- Network
- Offline Files

--> Do not automatically make redirected folders available offline.

They changed the default behaviour from W2K to WinXP.
0
 
gmh300968Commented:
Dont forget that Offline Folders is on a per computer basis and not on a per user account basis.
If one user profile of a computer is using offline folder it will atatempt to synch no matter who logs on.
Its a stupid feature which was changed in Vista.
You need to reset the Cache to clear all users offlien folder synch.

MY Computer - Tools - Folder Options - Offline Files - Press CTRL + SHIFT and click on Delete Files. Then click Yes to re-initialise.

0
 
johnb6767Commented:
Hate to ping this old thread, but I wanted to add the source for the last posting, as I came across the identical verbage, including a typo......

http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.windows.server.general&tid=e3ec54ed-4b01-4d50-8ed8-956f90284d32&cat=en_US_9741c575-ec92-42f8-85ba-00dfe1483cf5&lang=en&cr=US&sloc=&p=1

Dont like having unreferenced articles out here.....   :)
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 2
  • 2
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now