unknown hostname

128.153.144.233 (i am sure it is correct) is the ip address of the machine i put red hat 9.0 on it. but i cannot ssh to. its saying host/servername not known. What should do
komlaaaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

komlaaaAuthor Commented:
sorry if i did not make myself clear enough.
i am able to ssh from machine with ip address 128.153.144.233 BUT not to it.
In another 128.153.144.233 seems unknown from outside.
0
rindiCommented:
either your SSH Daemon isn't running on that machine or your firewall settings are blocking port 22.
0
cyb3rj0hnCommented:
I am going to assume this is a box on a cable modem. If this is the case you need a dynamic DNS client (www.dyndns.org) to one make the machine accessible from the Internet. Two as mentioned above  by rindi you need to make sure if you have a router in front of the box that it allows SSH connections through from the Internet. Then you should be all set because all default SSH installs will allow connections from 0.0.0.0/24 (i.e anywhere). Hope this helps.

Cheers,
John
0
cyb3rj0hnCommented:
I need to ammend my above statement: "If this is the case you need a dynamic DNS client (www.dyndns.org) to one make the machine accessible from the Internet" It should read "If this is the case you need a dynamic DNS client (www.dyndns.org) to one make the machine accessible from the Internet by hostname otherwise you can continue to access by IP, provided your IP does not change.

John
0
wesly_chenCommented:
For RedHat Linux 9, login as root
# service sshd start    <=== start sshd
# chkconfig --level 2345 sshd on  <=== turn on sshd at boot time

>128.153.144.233 seems unknown from outside.
Your machine is not registered in your DNS domain, ask your sysadm or network administrator to add
your hostname and IP address into your company's DNS.
Before that, try "ssh 128.153.144.233" from other machine first.

Wesly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.