unknown hostname/severname

128.153.144.233 is the ip address of the machine i put red hat 9.0 on it. but i cannot ssh to. its saying host/servername not known. What should do
komlaaaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
Where is ssh from? From another Lniux box?
Put
128.153.144.233  <hostname>
in /etc/hosts at the Linux box which you are ssh from.

Wesly
0
komlaaaAuthor Commented:
> Where is ssh from? From another Lniux box?
from a UNIX machine where i am not a root.
Also i would like any other user who have an account my my linux box to be able to access it.

0
komlaaaAuthor Commented:
sorry if i did not make myself clear enough.
i am able to ssh from machine with ip address 128.153.144.233 BUT not to it.
In another 128.153.144.233 seems unknown from outside.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

rindiCommented:
Have you started the SSH Daemon?
0
komlaaaAuthor Commented:
>Have you started the SSH Daemon?
I don't know how but i was able to ssh from 128.153.144.233 to another machine

====================just for info=============
I am not sure if this is relevent but i looked at the file /etc/hosts
the address that was there is 127.1.1 and NOT 128.153.144.233
0
komlaaaAuthor Commented:
===========Another infos.==============================
Also when i tried to log in to my machine (128.153.144.233 ) there was a message that pop up reading:
that my hostaname(sclab-56.144....) is not found in the domain... That if i want to try gain on log in anyway?
0
wesly_chenCommented:
>>Have you started the SSH Daemon?
> I don't know how but i was able to ssh from 128.153.144.233 to another machine
Ssh is server-client base. So you need to start sshd on your Linux box to allow people ssh into it from other machines.
If you use Fedora/RedHat Linux, as root,
# /etc/init.d/sshd start    <=== start ssh server
# chkconfig --level 2345 sshd on  <===turn sshd on at boot up.

Wesly
0
komlaaaAuthor Commented:
===========Another infos.==============================
>Have you started the SSH Daemon?
All i did was to include everything during the installation. I am not sure if that is enough
to start ssh Deamon
0
wesly_chenCommented:
> Also when i tried to log in to my machine (128.153.144.233 ) there was a message that pop up reading:
> that my hostaname(sclab-56.144....) is not found in the domain

Your machine is not registered in your DNS domain, ask your sysadm or network administrator to add
your hostname and IP address into your company's DNS.
Before that, try "ssh 128.153.144.233" first.

Wesly
0
wesly_chenCommented:
> All i did was to include everything during the installation. I am not sure if that is enough
> to start ssh Deamon
No, your ssh daemin is not started. Installation is one thing, running the software is another.
What Linux do you have?

Wesly
0
wesly_chenCommented:
For RedHat Linux 9, login as root
# service sshd start    <=== start sshd
# chkconfig --level 2345 sshd on  <=== turn on sshd at boot time

Wesly
0
wesly_chenCommented:
Hi,

  Is this issue resolved?
  Is this the same issue as the following:
http://www.experts-exchange.com/Operating_Systems/Linux/Linux_Administration/Q_21219748.html
which is using IP address
ssh 128.153.144.233
since your Linux box is not registered to your DNS server.

Wesly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.