[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

FTP Folder Error from Internet Explorer

Posted on 2004-11-24
7
Medium Priority
?
860 Views
Last Modified: 2008-01-09
Hello,

I have just installed IIS 5.1 on my Windows XP Pro machine. I have also configured my LinkSys Router to forward ports 20-21 and 80 to my computer.

(I was not able to find any posts about this particulart error - some like it though).

Here is my problem:
I can access the web site no problem - remotely and locally. Using IP from ISP, local IP and "localhost".

I have 3 computers on this network and a Unix web server is VA.
On all 3 I can FTP using IE and "FTP" command using my local IP.
I get errors using ISP-IP and "localhost".

my computer - localhost - cannot access folder. check filename and permissions. FTP session teminated.
ISP-IP - cannot access folder. check filename and permissions. connect reset

the other 2 computers - ISP-IP - Error opening folder. Check permissions.
200 type set to A
227 entering passive mode
426 connection closed; transfer terminated.

on my webserver (VA) using the FTP command (ISP-IP) i can log on but cannot view directory. It errors saying something like "Can't open data connection" then it freezes.

if you need anymore information please ask.
Thanks in advance.




0
Comment
Question by:lunatic359
  • 5
  • 2
7 Comments
 

Author Comment

by:lunatic359
ID: 12672628
I got the "localhost" working on my computer now. Seems that IP address in the FTP Properties should have been set to "All Unassigned".

Still cannot access using ISP-IP.
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 12676734
From your post:

"I have also configured my LinkSys Router to forward ports 20-21 and 80 to my computer"

"227 entering passive mode"

Passive mode FTP does not use ports 20 and 21, it uses ports 21 and a random port over 1024.

Try configuring your FTP client to use Active FTP and it should work properly.

Dave Dietz
0
 

Author Comment

by:lunatic359
ID: 12683604
Thank you for you comment, however you can't set Internet Explorer to use Active FTP. If you are referring to unchecking the "Use passive mode", I have unsuccessfully tried that.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:lunatic359
ID: 12683623
I unchecked "Use passive mode" within Internet Explorer just to double check. This time it worked. I will give you the points no-the-less. However do you know if this is caused by a configuration within IIS.

(I would rather not have the need to tell "everyone" in order to connect, disable passive mode) Since it is "ON" by default.
0
 

Author Comment

by:lunatic359
ID: 12683656
I re-checked "Use passive mode" and forwarded ports from 1024 - 65535 to my computer and still receive the error.
0
 
LVL 34

Accepted Solution

by:
Dave_Dietz earned 1000 total points
ID: 12684549
The error is not being caused by IIS.

The error is being caused by the NAT functionality of your router.  When you use Passive FTP the client sends a PASV command and the server responds with a set of 6 numbers seperated by commas that define the IP address of the server and the port to use for the Data channel.  The server sends its IP address which is likely the internal IP of the server and the NAT server isn't changing it to the external IP address that the client needs to use.  This is a common shortcoming of NAT devices.

Your only real choices are to use Active FTP or get a different NAT/Router that properly supports NATting Passive FTP traffic.

Dave Dietz
0
 

Author Comment

by:lunatic359
ID: 12684949
Thank you Dave for your time and knowledge!
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Integration Management Part 2
Suggested Courses
Course of the Month18 days, 20 hours left to enroll

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question