Good Smarthost or Roadrunner Info

Backround info: I have an Exchange 2003 server setup on my domain. My ISP is Roadrunner. I have a dynamic IP address.

Problem:  More and more ISPs are blocking email from dynamic IPs so I need to find a workaround. I got my username and password from Roadrunner and confirmed that it works by using thier web access mail client. The address of thier smtp server is  smtp-server.nyc.rr.com. I setup a smarthost using this address as well as basic authentication in Exchange. However as soon as I make the change I can no longer send out any emails. Eventually I get a bouncback saying that delivery has been delayed.

Question: Is there a better way to setup the smart host? Is there a good company other then my ISP that you could recommend that provides smarthosting services?
ShurafaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

VahikCommented:
why do u use authentication...smart host work on annonymous authentication
between servers......unless RR ask for it.......just change authentication back to
annonymous and mail should work...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SembeeCommented:
How are you configuring the Smart Host? Are you doing it directly on the SMTP Virtual Server?
If so, switch to an SMTP connector. By using a connector you can use authentication if Road Runner require it.

More information: http://www.amset.info/exchange/smtp-connector.asp

Simon.
0
eedleeCommented:
Also change the default timeouts for delay and fail messages by opening exchange system manager and entering the default smtp connector settings. In advanced, change the local and remote delivery notification times to lower values, preferably as low as possible while you are testing so you can troubleshoot the connections.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.